Author Topic: WIFI RGB/W Lights  (Read 997 times)


  • Veteran
  • ***
  • Posts: 77
    • View Profile
« on: February 15, 2014, 02:25:01 pm »
Hi, I have purchased some RGB LED lights which can be controlled using a central controller that accepts basic UDP network packets to make it change.

These are mine (v2):
They are also sold under the mi-light and easybulb brand names - although I believe they use slightly different commands depending on version.

I tried to create a template and made a basic ruby script to turn them on similar to this:

require 'socket'
socket =
socket.send([0x22, 0x00, 0x55].pack('C*'), 0, '', 50000)

I have tried a few different things and was wandering where I was going wrong? The icon to turn them on/off appear in the orbiters but they dont react to the orbiters. I also believe they don't report status (on/off, etc..) they only accept commands.



  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: WIFI RGB/W Lights
« Reply #1 on: February 15, 2014, 05:32:38 pm »
I would look to see if:

* your DCE router is receiving the command (DCERouter.log)
* your Generic Serial Device is reacting to the command (look at its log, either in web admin, follow log, or tail -f /var/log/pluto/XX_Generic_Serial_Device.log from console.. also looking at the GSD's screen session is a good thing to do (screen -ls to get a list of screen processes, and screen -r <pid#> to connect to one of them... control-A d exits cleanly.