Author Topic: FYI - Snap April 13 28939 xorg.conf defaulted to nouveau driver  (Read 347 times)

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Hi,

Just in case anyone was interested.

Cheers

tompin2

  • Veteran
  • ***
  • Posts: 65
    • View Profile
Re: FYI - Snap April 13 28939 xorg.conf defaulted to nouveau driver
« Reply #1 on: April 19, 2014, 06:51:18 am »
Hi pigdog,

Same happened to me, sound  used to work ok on a previous 1204 release, I logically have no hdmi audio anymore :o. I have a zotac zbox.

Here is my video card info, probably is not listed and thats why is not detected during the boot up

root@moon159:~# lspci -nnk | grep VGA -A3
03:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [ION] [10de:0a64] (rev a2)
        Subsystem: ZOTAC International (MCO) Ltd. Device [19da:3100]
        Kernel driver in use: nouveau
        Kernel modules: nouveau, nvidiafb


Cheers,

T
« Last Edit: April 19, 2014, 07:03:38 am by tompin2 »

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: FYI - Snap April 13 28939 xorg.conf defaulted to nouveau driver
« Reply #2 on: April 19, 2014, 01:24:05 pm »
Hi tompin2,

I went a head and installed the current nvidia driver on my Core, it had a GeForce 8500 GT card.

I could use the current driver because my card was supported.  Older hardware needs different versions.

apt-get update && apt-get install nvidia-current && nvidia -xconfig

When I built my MD's (both could run the current driver) they came up with the nvidia driver.  Whether this happened because I installed the nvidia driver on the Core before creating the MD's, or, the MD get created with the nvidia drivers.

I'm not sure.

MD's use a different process when generated and can even have different kernels.

Cheers.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1004
    • View Profile
Re: FYI - Snap April 13 28939 xorg.conf defaulted to nouveau driver
« Reply #3 on: April 22, 2014, 09:11:09 pm »
Here is my video card info, probably is not listed and thats why is not detected during the boot up

root@moon159:~# lspci -nnk | grep VGA -A3
03:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [ION] [10de:0a64] (rev a2)
        Subsystem: ZOTAC International (MCO) Ltd. Device [19da:3100]
        Kernel driver in use: nouveau
        Kernel modules: nouveau, nvidiafb

hmm, the ION *should* be detected properly.  nvidia-current will work with it.

J.