Author Topic: FIXED: Unable to set heating setpoint on zwave thermostat  (Read 291 times)

hamster

  • Newbie
  • *
  • Posts: 7
    • View Profile
FIXED: Unable to set heating setpoint on zwave thermostat
« on: February 13, 2014, 08:11:25 am »
Howdy,

I couldn't find anything with a forum search, so hopefully I didn't overlook anything.

I have setup LinuxMCE 1204 (I couldn't get 1004 to work on my hardware).  I'm using a Aeon Z Stick v2 as the interface, and a Radio Thermostat / 2gig CT100 thermostat.

The system sees the thermostat, and I can set heat/cool/off no problem, and I can set a cooling setpoint, but not a heating setpoint.  It just ignores it.  I get this error in the logs when trying to request a set point:

No such setpoint 'Heating 1' found!

When adding the thermostat, it tells me (in part):

2014-02-12 23:53:17.109 Node002, Received manufacturer specific report from node 2: Manufacturer=2GIG Technologies, Product=Unknown: type=6401, id=0107

2014-02-12 23:53:26.587 Node002, Received supported thermostat setpoints
2014-02-12 23:53:26.588 Node002,     Added setpoint: Cooling 1
2014-02-12 23:53:26.588 Node002,     Added setpoint: Unused 3

In addition, setting the fan mode has no effect

2014-02-12 23:53:27.770 Node002, Received supported thermostat fan modes
2014-02-12 23:53:27.770 Node002,     Added fan mode: Auto Low
2014-02-12 23:53:27.770 Node002,     Added fan mode: On Low


Any hints?
« Last Edit: February 13, 2014, 08:45:14 am by hamster »

hamster

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Unable to set heating setpoint on zwave thermostat
« Reply #1 on: February 13, 2014, 08:35:00 am »
I think I may have fixed it.  There's a .xml file for the ct100, but it wasn't picking it up with the ID code mine is reporting.  Once I finally get it to re-see the network, I'll report if it is working, hah.

hamster

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Unable to set heating setpoint on zwave thermostat
« Reply #2 on: February 13, 2014, 08:44:32 am »
Yup that fixed it.  I added this line to /etc/openzwave/config/manufacturer_specific.xml:

<Product type="6401" id="0107" name="CT100 Thermostat" config="2gig/ct100.xml"/>

Still no fan, but that's less important.