Author Topic: Volume issue with LG TV template  (Read 431 times)

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1393
  • If it ain't broke, tweak it
    • View Profile
Volume issue with LG TV template
« on: September 16, 2014, 09:30:13 am »
Hello all,

I recently had to re-add my LG TV as it mysteriously stopped working. It works fine for the most part, although the TV volume doesn't work when switching over to a different input - a quick reload fixes this. This is a known issue.

However the behaviour I'm now seeing is that following a reload, you touch the volume controls (up or down), and bam the TV volume goes straight up to 99! Which in case you are wondering, is very, very loud :-)

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1003
    • View Profile
Re: Volume issue with LG TV template
« Reply #1 on: September 18, 2014, 06:27:51 pm »
Couple of questions: 

1) What DT exactly are we dealing with here?
2) What release are you using 1004/1204?
3) Have you recently done an sqlcvs update on your system?
4) Have you recently done an apt-get update && apt-get upgrade?

J.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1393
  • If it ain't broke, tweak it
    • View Profile
Re: Volume issue with LG TV template
« Reply #2 on: September 22, 2014, 11:19:32 pm »
Thanks for the reply.

1. #2126 - LG RS232 (newer models)
2. 1004 (although it's days are numbered, gagging to try this RPi MD!)
3. Nope, never.
4. No, last upgraded 01/04/2013

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Volume issue with LG TV template
« Reply #3 on: September 24, 2014, 07:47:57 am »
I've been trying to work on that template for a while now, as it had bugs where it would emit erroneous volume values (which would be ignored.)

The code is buggy and needs to be audited and fixed (and I only have so many hands)

-Thom

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1003
    • View Profile
Re: Volume issue with LG TV template
« Reply #4 on: September 25, 2014, 06:23:26 pm »
Heh.

Purps can you pastebin some logs from the device around when this happens?

"/var/log/pluto/" + device_.devid_.to_s + "_Generic_Serial_Device.log"  <- XX_Generic_Serial_Device.log in /var/log/pluto

I see some potentially bad handling of data in the volume sections.  Do you have a link to the codes for this TV?

J.