Author Topic: Smoke detector Everspring SF-812 detection  (Read 2397 times)


  • Veteran
  • ***
  • Posts: 58
    • View Profile
Smoke detector Everspring SF-812 detection
« on: January 19, 2014, 02:37:35 pm »

i recently got this smoke detector.
It is still detected as Generic Tuner #75 like it is said in this ticket:

I am on 10.04 and did an apt-get update and upgrade today.
also tried to ex- and include the detector again but without any luck of correct detection.

I have now added it manually as child device of ZWave Embedded Security Interf and changed the port/channel number to the port channel number of the generic tuner. (Don`t know if this has the slightest chance to work, but there was hope and not much knowledge. :) )

What can i do now? Iwill be thankfull for any hint.

For the future:
Should i just reopen the ticket or is it okay to ask in this forum.
Really unsure about it and what version  had been fixed.
milestone 12.04 means it is fixed in 12.04 only?

thanks for this fine programm


  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: Smoke detector Everspring SF-812 detection
« Reply #1 on: January 20, 2014, 03:36:00 pm »
I would suggest testing this in 12.04, as we have rewritten the ZWave driver to use Open-ZWave. We are no longer making code changes to the old driver.



  • Veteran
  • ***
  • Posts: 58
    • View Profile
Re: Smoke detector Everspring SF-812 detection
« Reply #2 on: January 21, 2014, 08:13:02 pm »

the perfect reason for me to try 12.04 finally.  ;)
will try to install it (dual boot?) and report back!


  • Veteran
  • ***
  • Posts: 58
    • View Profile
Re: Smoke detector Everspring SF-812 detection
« Reply #3 on: January 26, 2014, 02:55:11 pm »
So i am back.

Installing 12.04 (snapshot: LMCE-1204-20140121095528629.iso) was "smoother" than i thought.
a few obstacles that occured:

bevor the first reboot it seemed to hang at 90%. i switched to a text conole and it magically resumed. maybe it was just superstition and it would have gone further anyway ....

the core/hybrid needed direct access to the internet as it was mentioned here somewhere in the forum. otherwise it got stuck in a reboot-loop due to not detecting the network.
after the installation i can now put a router between core and the internet and network is fine.

my tv-usb-card win-tv-nova is recognized and added several times like it is in 10.04.


first my aeon labs z-stick was not detected. today i have put another usb-stick into the core (tricklestar 300zw-eu). that wasn`t recognized either but after switching back, the aeon stick got detected and added.
i cannot control any lights.
They show up in the web-administration-page but turning on/off has no effect.
the smoke detector is still not recognized correctly (generic tuner).

The new grub recognized my 10.04 installation. so after changing the default grub entry, i now have a nice dual boot.
one stable sysem and one to fiddle arround.
Video and audio is doing fine.
Again thanks!
I wouldn`t have thougt that 12.04 has come that long way already.
The smoke detector is not so important. it is just a nice thing to have that linked to the "matrix".  :)