Author Topic: PXE boot MD  (Read 1464 times)

B34N

  • Guru
  • ****
  • Posts: 155
    • View Profile
Re: PXE boot MD
« Reply #15 on: January 17, 2014, 02:32:44 am »
What is the GPU?

I have no clue. Any thoughts on how to find out?

On core sudo -i
ssh moonXX where XX is the MD number
lspci -nn | grep VGA

I saw the "Generic PC as MD" entry as Device 63. I got back "ssh: connect to host moon63 port 22: No route to host"

The first time the MD sets up it goes through a great deal of installing in the background... did you force it to reload during this process or shut it down or anything? While you are at it dpkg --configure -a

If that returns anything, you have broken packages it is trying to fix.

I was very patient and let everything complete. Nothing came back after "sudo dpkg --configure -a"

Thank you,
B34N


l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: PXE boot MD
« Reply #16 on: January 17, 2014, 03:10:07 am »
I have no clue. Any thoughts on how to find out?

I saw the "Generic PC as MD" entry as Device 63. I got back "ssh: connect to host moon63 port 22: No route to host"

I was very patient and let everything complete. Nothing came back after "sudo dpkg --configure -a"

Thank you,
B34N

What followed is how to find out.

In order to ssh into the moon, it must be on. In web admin/Media Directors it will say what the MD number is. You can also see the list of MDs in /usr/pluto/diskless.

Everything in linuxmce runs as root with limited exception. My first instruction is almost always "sudo -i" so that you do not have to run sudo before commands, because sometimes sudo will not transfer across some of the commands I want run. When you ssh into an MD, you will be root. You must of course instantiate the ssh session as root. The dpkg --configure -a was to be run from the ssh session.

So turn on the MD, root up, confirm the MD number and try again.

In situations where the MD cannot be booted we will chroot it, but that should not be the issue here. *nor would it be helpful as we would tie it to the cores hardware*
« Last Edit: January 17, 2014, 03:17:49 am by l3mce »
I never quit... I just ping out.

B34N

  • Guru
  • ****
  • Posts: 155
    • View Profile
Re: PXE boot MD
« Reply #17 on: January 17, 2014, 03:19:21 am »
L3mce:
So you are saying that the computer must me on for me to ssh to it. Sorry...I have had a long day at work and wasn't thinking. Thank you for your patience! Response from lspci was:
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV370/M22 [Mobility Radeon X300] [1002:5460]

Nothing came back after kpkg


l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: PXE boot MD
« Reply #18 on: January 17, 2014, 03:31:02 am »
lspci -nnk | grep VGA -A3

I believe that is going to be on the radeon driver, and myth might not like it much... this is due to ATI dropping support like mad. Not much to be done if the open source driver cannot keep up.
« Last Edit: January 17, 2014, 03:33:41 am by l3mce »
I never quit... I just ping out.

B34N

  • Guru
  • ****
  • Posts: 155
    • View Profile
Re: PXE boot MD
« Reply #19 on: January 17, 2014, 03:35:06 am »
I believe that is going to be on the radeon driver, and myth might not like it much... this is due to ATI dropping support like mad. Not much to be done if the open source driver cannot keep up.

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV370/M22 [Mobility Radeon X300] [1002:5460]
   Subsystem: Dell Device [1028:2002]
   Kernel driver in use: radeon
   Kernel modules: radeon, radeonfb


Would be nice to get working, but not a big deal. I have a NUK on the way...but using this old laptop would work for a lesser used TV.

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: PXE boot MD
« Reply #20 on: January 17, 2014, 03:39:35 am »
Yeah... that's what I thought. It should work for everything but mythtv and true HD video files.

You can adjust the mythtv playback settings in the regular setup menu in myth (not the main setup under computing) to the "slim" playback profile, and you can playback recorded myth stuff in all likelihood... but live streaming is going to be HD and probably break or be unwatchable.
I never quit... I just ping out.

B34N

  • Guru
  • ****
  • Posts: 155
    • View Profile
Re: PXE boot MD
« Reply #21 on: January 17, 2014, 03:42:12 am »
Yeah... that's what I thought. It should work for everything but mythtv and true HD video files.

You can adjust the mythtv playback settings in the regular setup menu in myth (not the main setup under computing) to the "slim" playback profile, and you can playback recorded myth stuff in all likelihood... but live streaming is going to be HD and probably break or be unwatchable.

Thank you very much! This old laptop worked well as a MythTV frontend for a few years so I have no complaints. I guess it's time to move onto the next machine.With luck the NUC will work well and I will be able to ditch the old laptop with the broken screen.

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: PXE boot MD
« Reply #22 on: January 17, 2014, 03:46:38 am »
Thank you very much! This old laptop worked well as a MythTV frontend for a few years so I have no complaints. I guess it's time to move onto the next machine.With luck the NUC will work well and I will be able to ditch the old laptop with the broken screen.

Well... tell me what it does when you open myth. If you had good playback of HD myth before...

I mean unless this was a very old setup back when fglrx still worked with your HW on an old kernel...
I never quit... I just ping out.