Author Topic: Z-Wave USB Dongle  (Read 560 times)

Blues

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Z-Wave USB Dongle
« on: January 08, 2014, 04:13:24 am »
Running 1004. After plugging in Aeon DSA02203-ZWUS Labs Z-Wave Z-Stick Series 2 USB Dongle I can see following in /var/log/messages:
Code: [Select]
Jan  7 21:05:10 dcerouter kernel: [  703.240243] usb 1-2: new full speed USB device using ohci_hcd and address 4
Jan  7 21:05:10 dcerouter kernel: [  703.509506] usb 1-2: configuration #1 chosen from 1 choice
Jan  7 21:05:10 dcerouter kernel: [  703.517138] cp210x 1-2:1.0: cp210x converter detected
Jan  7 21:05:10 dcerouter kernel: [  703.728267] usb 1-2: reset full speed USB device using ohci_hcd and address 4
Jan  7 21:05:11 dcerouter kernel: [  703.976988] usb 1-2: cp210x converter now attached to ttyUSB0
AFAIK it is supposed to appear in Devices? But it does not ... :( Any ideas how to troubleshoot?

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3013
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Z-Wave USB Dongle
« Reply #1 on: January 08, 2014, 12:13:22 pm »
Did you see an Orbiter message asking you if you want to use a device?

Blues

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: Z-Wave USB Dongle
« Reply #2 on: January 08, 2014, 02:24:41 pm »
Nope, I had no time to mess with it, but methinks I need to check if usbserial module was even loaded, I believe this is needed? Anyhow, I downloaded 1204 and I'm going to install it today after I get home from work.

sambuca

  • Guru
  • ****
  • Posts: 447
    • View Profile
Re: Z-Wave USB Dongle
« Reply #3 on: January 08, 2014, 05:03:14 pm »
Maybe the usb ID of this dongle is not autodetected..?
Look at the output from the "lsusb" command and see if that id exists in the ZWave device template.

br,
sambuca

hamster

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Z-Wave USB Dongle
« Reply #4 on: March 16, 2014, 10:54:28 am »
You have to actually add it.  Add a new device to the 'Interfaces' section, use device template 'Zwave'.  Once that adds, make sure the 'COM port on PC' is selected and save.  Might have to tell the DCERouter to restart, and then wait a bit for it to discover the rest of the devices on your zwave network.