Author Topic: MD on Zotac Zbox ID42 Plus not playing audio [SOLVED]  (Read 376 times)

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
MD on Zotac Zbox ID42 Plus not playing audio [SOLVED]
« on: December 25, 2013, 09:05:19 pm »
I am trying to configure a new Zotac Zbox ID42 Plus.
It is PXE booting from the core.
At the audio / video setup stage in audio settings (step 5) the list of audio output connectors is empty.

The device has audio on board:
Code: [Select]
root@moon63:~#  lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: NVIDIA Corporation GF119 HDMI Audio Controller (rev a1)

aplay can not recognize the sound card
Code: [Select]
root@moon63:~# aplay -l
aplay: device_list:240: no soundcards found...
The instructions in http://wiki.linuxmce.org/index.php/Audio_in_1004
talk about alternate sound configuration settings in:
/etc/pluto.conf
/etc/asound.conf
/etc/pluto/alsa/virtual_cards.conf

In: /etc/pluto.conf there is no flag named "AlternateSC"

I the MD, there is no file or directories for:
/etc/pluto/alsa/virtual_cards.conf, /etc/pluto/alsa/, /etc/asound.conf, /etc/asound/

Code: [Select]
root@moon63:~# ll /etc/pluto/alsa/virtual_cards.conf
ls: cannot access /etc/pluto/alsa/virtual_cards.conf: No such file or directory

root@moon63:~# ll /etc/pluto/alsa/
ls: cannot access /etc/pluto/alsa/: No such file or directory

root@moon63:~# ll /etc/asound.conf
ls: cannot access /etc/asound.conf: No such file or directory

root@moon63:~# ll /etc/asound/
ls: cannot access /etc/asound/: No such file or directory

Any advice?
Thanks,
Avner
« Last Edit: January 05, 2014, 10:36:17 am by Avner »
Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: MD on Zotac Zbox ID42 Plus not playing audio
« Reply #1 on: December 27, 2013, 01:56:42 am »
I forgot... before my time away becoming l3mce the White... it was decided that automagic kernel upgrading would not happen. This and some other hardware requires the backported natty kernel.

For those with this hardware, or other newer nvidia stuff running 1004, where nothing appears in aplay -l  the following is required.
sudo -i on the core and ssh moonXX where XX is the moon number if this is an MD.
Code: [Select]
apt-get install -yf linux-image-generic-lts-backport-natty linux-headers-generic-lts-backport-natty
chmod +r /vmlinuz

If there is an issue then you might apt-get install --reinstall -yf alsa-base alsa-utils and remove the old kernel with apt-get remove. I am not providing that specifically because it would depend on what version your kernel is, which can change.
« Last Edit: December 27, 2013, 02:10:56 am by l3mce »
I never quit... I just ping out.

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: MD on Zotac Zbox ID42 Plus not playing audio
« Reply #2 on: January 05, 2014, 09:33:47 am »
L3top, thanks for helping to solve this problem.

Now, I can play video and hear audio successfully via lmce.
I can still not mute from lmce, but I can live with that (decrease / increase is not expected to work anyways because the digital signal via hdmi can only be controlled to on/off).

To summarize, the relevant settings that eventually worked for me were:

Code: [Select]
cat /etc/pluto/xine.conf
...
audio.device.alsa_front_device:asym_hdmi
audio.device.alsa_default_device:asym_hdmi
audio.device.alsa_passthrough_device:plughw:1,3
audio.output.speaker_arrangement:Pass Through


Code: [Select]
cat /etc/asound.conf
</etc/pluto/alsa/virtual_cards.conf>

pcm_slave.hdmi_convert48k {
        pcm "plughw:1,3"
        rate 48000
}

pcm.hdmi_playback {
        type plug
        slave hdmi_convert48k
}

pcm.asym_hdmi {
        type asym
        playback.pcm "hdmi_playback"
        capture.pcm "plughw:1,3"
}

pcm.nvidia_hdmi {
        type hw
        card 1
        device 3
}

pcm.!default asym_hdmi


Code: [Select]
cat /usr/pluto/diskless/35/usr/share/alsa/alsa.conf
...
defaults.ctl.card 1
defaults.pcm.card 1
defaults.pcm.device 3
...


I also verified that /etc/pluto.conf does not contain the variable AlternateSC

The following tests / utilities helped me solve the problem:

1. Check the sound card
I used the following command to verify that nvidia hdmi maps to 1,3:
Code: [Select]
root@moon35:~# aplay -l
List of PLAYBACK Hardware Devices ****

card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

2. Generate some audio signal in the TV
I used the following command to verify that the moon can generate sound in the TV
Code: [Select]
speaker-test -t sine -D plughw:1,3

3. Play xine via KDE
I used xine directly to see that I can play a video/audio using xine outside lmce.
Code: [Select]
root@moon35:~# xine /home/public/data/videos/movie.avi


Setting of moon MD in webadmin

# In Wizard / devices / Media Directors
moon MD is set to:
Code: [Select]
Hardware accelaration: vdpau
Deinterlace quality: vdpau
Video Card : Geoforce or TNT2

Audio settings
Selecting HDMI (or anyhting other than "Manual") causes to execute Setup_AsoundConf in /usr/pluto/bin/SetupAudioVideo.sh
Ideally this should set e.g. asound.conf, xine.conf correctly but, for some reasons it replaces the good settings with settings that break Xine_Player.
So instead, use:
Code: [Select]
Audio settings: Manual Settings (M)This prevents /usr/pluto/bin/SetupAudioVideo.sh from overwriting (returns from Setup_AsoundConf)
« Last Edit: January 11, 2014, 08:31:28 pm by Avner »
Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2934
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: MD on Zotac Zbox ID42 Plus not playing audio
« Reply #3 on: January 05, 2014, 12:15:46 pm »
L3top, thanks for helping to solve this problem.

Now, I can play video and hear audio successfully via lmce.
I can still not mute from lmce, but I can live with that (decrease / increase is not expected to work anyways because the digital signal via hdmi can only be controlled to on/off).


Whenever you go digital from a media director to an amp, all volume control function are a function of the amp, and not of the PC. Mute, Vol+ and Vol- will only work by controlling the amp.