Author Topic: Forum and wiki server upgrade on 25.10.2013  (Read 5585 times)

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Forum and wiki server upgrade on 25.10.2013
« on: October 22, 2013, 10:08:41 pm »
Hey,

the server running wiki and forum on is quite a bit outdated.
So the i plan to do a major upgrade to most recent debian version on friday, 25.10.2013 (starting at 19.00 CEST).

i try to keep the downtime to a minimum.

how come?
i  wanted to do a upgrade to the wiki and setup a apache solr search coz' me and others complaining about finding anything in the wiki but php version is to old for the latest wiki version.
maybe more in case this worked ;-)

Cheers,
ochorocho
« Last Edit: October 22, 2013, 10:11:20 pm by polly »

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #1 on: October 28, 2013, 01:31:02 am »
Update to debian 7  done.
will test to update the wiki tomorrow.

:-)

if you find any issues in forum or wiki let me know.

Cheers,
ochorocho

WhateverFits

  • Guru
  • ****
  • Posts: 228
    • View Profile
    • Sean Walker
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #2 on: October 28, 2013, 03:30:39 am »
Awesome! Thanks!


polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #3 on: October 29, 2013, 01:14:22 am »
Hey ....

work on wiki migration done, looks like everything works nice after update to latest mediwiki version.
http://wiki.linuxmce.org/ocho/mediawiki/

working on ldap integration atm.
Currently trying to setup the group and stuff, when done next step is to connect it to mediawiki.

step by step ....

Cheers,
ochorocho

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3013
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #4 on: October 29, 2013, 09:35:17 am »
ochorocho,

thank you very much for your help and dedication in getting the infrastructure up to snuff!

It is greatly appreciated.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #5 on: October 30, 2013, 08:57:39 am »
ldap to mediawiki works fine :-)
forum is next.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #6 on: October 30, 2013, 04:01:50 pm »
Yes, No kidding. Thank you so much :)

-Thom

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #7 on: November 03, 2013, 08:39:11 pm »
thanks, for paying attention :-)

currently i'm fighting against my own stupidity. A Backup ended in a 100% filled up hdd which forced me to reinstall.
Cant work on the forum till my core is up again.

current state of the forum is:
* Update to smf2 required to make ldap Auth plugin work
* smf2 upgrade worked after some db modifications which shouldnt be required when doing on the life system
* ldap auth plugin looks fine but i couldnt log in after doing all the setup stuff.

cheers,
ochorocho

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3013
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #8 on: November 03, 2013, 08:46:36 pm »
GO! POLLY! GO!

Govo

  • Veteran
  • ***
  • Posts: 114
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #9 on: November 04, 2013, 08:58:21 pm »
NICE

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #10 on: November 21, 2013, 09:42:51 am »
while waiting for the LDAP Mod release for smf (http://www.simplemachines.org/community/index.php?topic=247449.msg3635934#msg3635934)
i did a redesign of the forum.

This is the test installation: http://wiki.linuxmce.org/ocho/smf/

any hint/ideas a greatly appreciated :-)

Cheers,
ochorocho

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #11 on: November 21, 2013, 01:15:51 pm »
On initial load all looks good, but once I log in as my user or descend into a sub-forum I loose all graphics.
Am I meant to be able to go further than initial page?

-Coley.

RayBe

  • Guru
  • ****
  • Posts: 286
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #12 on: November 21, 2013, 01:27:24 pm »
Hi ochorocho,
Great job,
Overall a much cleaner look, which i like a lot :)
A big improvement!
If i may, some design suggestions:
  • make all corners square, ditch the rounded ones
  • don't use outlined squares, only use filled squared like each topic on the main page
  • make each item on the different pages slightly higher to match more the height of the items on the frontpage
  • use the color-scheme used on www.linuxmce.org to get a more overall consistent look and feel
Its a nice feature that you can retract the top navigation bar :)
Thanks for all your work

br,
Raymond
When you were born, you were crying and everybody else was laughing.
Live your life so when you die, you are laughing and everybody else is crying.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #13 on: November 21, 2013, 01:48:00 pm »
Coley, after login all images showing up as expected ....  ???
Would you mind providing a screenshop?

RayBe, yes Sir! Will change the stuff you suggested....

Cheers,
ochorocho

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: Forum and wiki server upgrade on 25.10.2013
« Reply #14 on: November 21, 2013, 03:28:08 pm »
I tried on a different browser and all appears as it should - sorry about that.
Must be something local I'll need to investigate.

-Coley.