Author Topic: Failed to start X - (EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/  (Read 9512 times)


  • Guru
  • ****
  • Posts: 463
    • View Profile
    • LMCE user Page
Bushtech had a bit of a problem yesterday which we seem to have resolved with a bit of hacking. Thought I'd post the details here in case it helps anyone else or... if anyone can shed light on why it occurred.

Firstly, due to him running out of space on his root file system, his core froze and after a lot of messing about, he decided to re-install.

He did a clean install from iso image. First reboot brought black screen with cursor hanging (I think) at which point he dropped into command line and did an apt-get update; apt-get upgrade; reboot.
This time it came up with "Failed to start X". messages seemed to indicate that the correct nvidia drivers and alsa backports had been successfully installed.

We tried a lot of stuff- many deletes of xorg.conf and reboots with no luck. In the end, we tried a direct "startx" from the command line. This produced the following:
Code: [Select]
creating new authority file /root/.Xauthority
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.42-37-generic i686 Ubuntu
Current Operating System: Linux dcerouter 2.6.32-45-generic #104-Ubuntu SMP Tue Feb 19 21:21:41 UTC 2013 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-45-generic root=UUID=6f5b3d7b-8d58-421b-9580-c6fc8418acbf ro vmalloc=256m quiet uvesafb mode_option=1024x768-24 mtrr=3 scroll=ywrap
Build Date: 11 April 2013  01:18:49PM
xorg-server 2:1.7.6-2ubuntu7.12 (For technical support please see
Current version of pixman: 0.16.4
Markers: (--) probed, (**) from config file, (==) default setting,
(==) Using config file: "/etc/X11/xorg.conf" (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct  2 Using config directory: "/usr/lib/X11/xorg.conf.d" 14:58:18 2013
(EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/evdev
XKB: Failed to compile keymap
Keyboard initialization failed. This could be a missing or incorrect setup of xkeyboard-config.
Fatal server error:
Failed to activate core devices.
giving up.
xinit:  No such file or directory (errno 2):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.

We focussed on the critical error - couldn't open rules file /usr/share/X11/kxb/rules/evdev. Confirmed that the folder(s) file(s) didn't exist at all and managed to track down the package that provides them- xkb-data. Package was already installed but folders/files not there so we did a

Code: [Select]
apt-get install --reinstall xkb-data
After which the folders were created, startx worked and took him to kde... a reboot brought up avwiz with badly sized but usable screen.

Not sure what happened but hope this helps someone else who hits the same issue or is trying to figure out the problems.

bushtech - can you post your nvidia card details?



  • Veteran
  • ***
  • Posts: 98
    • View Profile
Just a clarification: I could move cursor during black screen.

lspci output: VGA Compatible controller : NVIDIA Corporation GT215 [Geforce GT240] rev a2
Core:Asus P8H77-V, Intel core i3-3240 LGA155, Inno 3D Nvidia 240 GT (DVI+VGA+HDMI), 4Gb ram, 125Gb SSD
MD: Zotax Zbox ID41