Author Topic: Dianemo S (maybe LMCE): problem with large video collection ?  (Read 1016 times)

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 884
  • Living with LMCE
    • View Profile
Hi,

I'm spotting frequent crashes when I try to enter Video collection media browser. I always try this on main Screen Orbiter... I get either really slow response for first screen or even get DCERouter crash, cause obviously mysql query didn't finish in planned time and DCERouter restarts...

Anyone with similar size of collection? Any other advice ?

Regards,

Bulek.
Thanks in advance,

regards,

Bulek.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2928
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Dianemo S (maybe LMCE): problem with large video collection ?
« Reply #1 on: April 30, 2013, 09:29:30 pm »
Get an SSD as your root disk, and see if that helps.

Esperanto

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: Dianemo S (maybe LMCE): problem with large video collection ?
« Reply #2 on: May 01, 2013, 08:16:23 am »
how many entries you have?

Check if there are no double entries (by removing drives or moving stuff manually). I removed all entries from the database and did a rescan and that made a lot of difference.

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 884
  • Living with LMCE
    • View Profile
Re: Dianemo S (maybe LMCE): problem with large video collection ?
« Reply #3 on: September 20, 2013, 09:38:14 am »
Hi,

I did some further research (with the help of Dianemo's Radu) and we found out that slow disk is causing this.

If after x secs video data is not retrieved, then DCERouter crashes thinking of deadlock...

I've written my finidings about slow disk in other thread...

Regards,

Bulek.
Thanks in advance,

regards,

Bulek.