Author Topic: MKV's with mediatomb  (Read 1370 times)

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
MKV's with mediatomb
« on: August 25, 2013, 01:11:20 am »
I do not want to re-encode my mkv's at this time, as the WD live, supports mkv's. Unfortunately I do not see any MKV's via mediatomb.

I add the following to mediatomb config, reboot the machine,  to see if its helps, but not luck, I still only see avi's

<map from="mkv" to="video/x-matroska"/>






CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: MKV's with mediatomb
« Reply #1 on: August 26, 2013, 04:09:56 pm »
Got the mkv to show without transcoding, it seems that mediatomb does not just add the new mime types, so I thought of an re-import, but no luck.

I then deleted all the files on the mediatomb site http://192.168.80.1:49153/, drop the database tables in pluto_mediatomb, recreated them using the /usr/share/mediatomb/mysql.sql and restarted the core; no luck with sudo /etc/init.d/mediatomb restart.

This then started the DB import, and I can see the mkv files now.

Also added the following <map from="mka" to="video/x-matroska"/>

Next step, see if I can get my galaxy tab to see and play the files, that should be easy now as the WD live tv, does it.

If there is a better way to do it, I am open to suggestions.

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: MKV's with mediatomb
« Reply #2 on: August 26, 2013, 04:55:13 pm »
Quick question, anyone got linuxmce coverart display in mediatomb?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: MKV's with mediatomb
« Reply #3 on: August 26, 2013, 07:33:54 pm »
Nope. If you figure it out, send us a patch!

Thanks

-Thom

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: MKV's with mediatomb
« Reply #4 on: August 26, 2013, 11:46:14 pm »
I have been looking on their forum and found this taglib and LNMCE version used is complied with it, though id3lib is not

I have yet to figure out how its works and from where (how to run it). But my plan hopefully is to get it or a similar tool reading the existing id3 tags that are in LMCE.


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: MKV's with mediatomb
« Reply #5 on: August 26, 2013, 11:52:36 pm »
The id3 tags are literally just raw id3 tags, without an mp3 stuffed on the back. id3lib can read the tags and parse the data just fine.

-Thom

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: MKV's with mediatomb
« Reply #6 on: August 27, 2013, 01:30:58 am »
Really silly, but my c++ is none existant and I am trying to test reading the id3 tags.

Pieced this together of the internet but getting compile errors, advice welcomed. Just want to pass the id3 tag file and then display output, just checking to see how it works, yes will get a c++ for dummies

Quote
#include <iostream>
#include <string>
#include <sstream>
#include <id3/tag.h>
using namespace std;

int main ()
{
  string mystr;

  cout << "Enter file ";
  getline (cin,mystr);
  ID3_Tag myTag(mystr);
  //use an std::auto_ptr here to handle object cleanup automatically
   ID3_Tag::Iterator* iter = myTag.CreateIterator();
   ID3_Frame* myFrame = NULL;
   while (NULL != (myFrame = iter->GetNext()))
   {
     cout << "Frame " << myFrame << "yea";
   }
   delete iter;
 
  return 0;
}


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: MKV's with mediatomb
« Reply #7 on: August 27, 2013, 02:06:23 am »
What compile errors are you getting?

-Thom

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: MKV's with mediatomb
« Reply #8 on: August 27, 2013, 03:55:11 pm »
See below

Quote
g++ id3tagTesting.c
id3tagTesting.c:1: error: expected constructor, destructor, or type conversion before â<â token
In file included from /usr/include/c++/4.4/string:53,
                 from id3tagTesting.c:2:
/usr/include/c++/4.4/bits/basic_string.h:2242: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2243: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2243: error: âtypename __gnu_cxx::__enable_if<std::__is_char::__value, bool>::__type std::operator==(const int&, const int&)â must have an argument         of class or enumerated type
/usr/include/c++/4.4/bits/basic_string.h:2488: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2488: error: template-id âoperator>><>â for âstd::basic_istream<char, std::char_traits<char> >& std::operator>>(std::basic_istream<char, std::char_t        raits<char> >&, int&)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.h:2547: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2547: error: template-id âgetline<>â for âstd::basic_istream<char, std::char_traits<char> >& std::getline(std::basic_istream<char, std::char_traits<        char> >&, int&, char)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.h:2553: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2553: error: template-id âgetline<>â for âstd::basic_istream<wchar_t, std::char_traits<wchar_t> >& std::getline(std::basic_istream<wchar_t, std::cha        r_traits<wchar_t> >&, int&, wchar_t)â does not match any template declaration
In file included from /usr/include/c++/4.4/string:56,
                 from id3tagTesting.c:2:
/usr/include/c++/4.4/bits/basic_string.tcc:1111: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.tcc:1114: error: âstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1114: error: template-id âoperator>><>â for âstd::basic_istream<char, std::char_traits<char> >& std::operator>>(std::basic_istream<char, std::char        _traits<char> >&, int&)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1117: error: expected â,â or â...â before â&â token
/usr/include/c++/4.4/bits/basic_string.tcc:1117: error: template-id âoperator<< <>â for âstd::basic_ostream<char, std::char_traits<char> >& std::operator<<(std::basic_ostream<char, std::cha        r_traits<char> >&, int)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1120: error: âstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1120: error: template-id âgetline<>â for âstd::basic_istream<char, std::char_traits<char> >& std::getline(std::basic_istream<char, std::char_trait        s<char> >&, int&, char)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1123: error: âstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1123: error: template-id âgetline<>â for âstd::basic_istream<char, std::char_traits<char> >& std::getline(std::basic_istream<char, std::char_trait        s<char> >&, int&)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1126: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.tcc:1129: error: âwstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1129: error: template-id âoperator>><>â for âstd::basic_istream<wchar_t, std::char_traits<wchar_t> >& std::operator>>(std::basic_istream<wchar_t,         std::char_traits<wchar_t> >&, int&)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1132: error: expected â,â or â...â before â&â token
/usr/include/c++/4.4/bits/basic_string.tcc:1132: error: template-id âoperator<< <>â for âstd::basic_ostream<wchar_t, std::char_traits<wchar_t> >& std::operator<<(std::basic_ostream<wchar_t,         std::char_traits<wchar_t> >&, int)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1135: error: âwstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1135: error: template-id âgetline<>â for âstd::basic_istream<wchar_t, std::char_traits<wchar_t> >& std::getline(std::basic_istream<wchar_t, std::c        har_traits<wchar_t> >&, int&, wchar_t)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1138: error: âwstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1138: error: template-id âgetline<>â for âstd::basic_istream<wchar_t, std::char_traits<wchar_t> >& std::getline(std::basic_istream<wchar_t, std::c        har_traits<wchar_t> >&, int&)â does not match any template declaration
In file included from /usr/include/c++/4.4/bits/ios_base.h:43,
                 from /usr/include/c++/4.4/ios:43,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/locale_classes.h:213: error: âstringâ does not name a type
/usr/include/c++/4.4/bits/locale_classes.h:611: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/locale_classes.h:786: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
In file included from /usr/include/c++/4.4/bits/locale_classes.h:809,
                 from /usr/include/c++/4.4/bits/ios_base.h:43,
                 from /usr/include/c++/4.4/ios:43,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/locale_classes.tcc: In member function âvirtual int std::collate<_CharT>::do_compare(const _CharT*, const _CharT*, const _CharT*, const _CharT*) constâ:
/usr/include/c++/4.4/bits/locale_classes.tcc:142: error: request for member âc_strâ in â__oneâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:143: error: request for member âdataâ in â__oneâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:143: error: request for member âlengthâ in â__oneâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:144: error: request for member âc_strâ in â__twoâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:145: error: request for member âdataâ in â__twoâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:145: error: request for member âlengthâ in â__twoâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc: In member function âvirtual int std::collate<_CharT>::do_transform(const _CharT*, const _CharT*) constâ:
/usr/include/c++/4.4/bits/locale_classes.tcc:180: error: request for member âc_strâ in â__strâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:181: error: request for member âdataâ in â__strâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:181: error: request for member âlengthâ in â__strâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:206: error: request for member âappendâ in â__retâ, which is of non-class type âintâ
/usr/include/c++/4.4/bits/locale_classes.tcc:212: error: request for member âpush_backâ in â__retâ, which is of non-class type âintâ
In file included from /usr/include/c++/4.4/ios:43,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/ios_base.h: At global scope:
/usr/include/c++/4.4/bits/ios_base.h:223: error: expected â,â or â...â before â&â token
/usr/include/c++/4.4/bits/ios_base.h:234: error: âstringâ does not name a type
In file included from /usr/include/c++/4.4/bits/basic_ios.h:39,
                 from /usr/include/c++/4.4/ios:45,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/locale_facets.h:1643: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/locale_facets.h:1744: error: âstringâ does not name a type
/usr/include/c++/4.4/bits/locale_facets.h:1812: error: âstringâ does not name a type
/usr/include/c++/4.4/bits/locale_facets.h:1872: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/locale_facets.h:2102: error: âstringâ has not been declared
In file included from /usr/include/c++/4.4/bits/locale_facets.h:2599,
                 from /usr/include/c++/4.4/bits/basic_ios.h:39,
                 from /usr/include/c++/4.4/ios:45,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/locale_facets.tcc:123: error: expected â,â or â...â before â&â token
/usr/include/c++/4.4/bits/locale_facets.tcc:131: error: âstringâ has not been declared
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function â_InIter std::num_get<_CharT, _InIter>::_M_extract_float(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, int&) constâ:
/usr/include/c++/4.4/bits/locale_facets.tcc:190: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:190: error: expected â;â before â__found_groupingâ
/usr/include/c++/4.4/bits/locale_facets.tcc:192: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:256: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:263: error: request for member âclearâ in â__xtrcâ, which is of non-class type âintâ
/usr/include/c++/4.4/bits/locale_facets.tcc:277: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:300: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:336: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function â_InIter std::num_get<_CharT, _InIter>::_M_extract_int(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, _ValueT&) constâ        :
/usr/include/c++/4.4/bits/locale_facets.tcc:446: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:446: error: expected â;â before â__found_groupingâ
/usr/include/c++/4.4/bits/locale_facets.tcc:448: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:494: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:534: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:547: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function âvirtual _InIter std::num_get<_CharT, _InIter>::do_get(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, float&) constâ:
/usr/include/c++/4.4/bits/locale_facets.tcc:674: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:674: error: expected â;â before â__xtrcâ
/usr/include/c++/4.4/bits/locale_facets.tcc:675: error: â__xtrcâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function âvirtual _InIter std::num_get<_CharT, _InIter>::do_get(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, double&) constâ:
/usr/include/c++/4.4/bits/locale_facets.tcc:689: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:689: error: expected â;â before â__xtrcâ
/usr/include/c++/4.4/bits/locale_facets.tcc:690: error: â__xtrcâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function âvirtual _InIter std::num_get<_CharT, _InIter>::do_get(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, long double&) co        nstâ:
/usr/include/c++/4.4/bits/locale_facets.tcc:721: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:721: error: expected â;â before â__xtrcâ
/usr/include/c++/4.4/bits/locale_facets.tcc:722: error: â__xtrcâ was not declared in this scope
In file included from /usr/include/id3/utils.h:37,
                 from /usr/include/id3/tag.h:34,
                 from id3tagTesting.c:4:
/usr/include/id3/id3lib_strings.h: At global scope:
/usr/include/id3/id3lib_strings.h:198: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/id3/id3lib_strings.h:198: error: invalid type in declaration before â;â token
/usr/include/id3/id3lib_strings.h:199: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/id3/id3lib_strings.h:199: error: invalid type in declaration before â;â token
/usr/include/id3/id3lib_strings.h:200: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/id3/id3lib_strings.h:200: error: invalid type in declaration before â;â token
id3tagTesting.c: In function âint main()â:
id3tagTesting.c:9: error: âstringâ was not declared in this scope
id3tagTesting.c:9: error: expected â;â before âmystrâ
id3tagTesting.c:12: error: âmystrâ was not declared in this scope


CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: MKV's with mediatomb
« Reply #9 on: August 27, 2013, 04:17:49 pm »
I also tried installing libtag1-dev and libmp4v2-dev, based on mediatomb forum.

I dropped the database again, reboot and am now seeing some information under the column metadata, have to check on my upnp device to see what changed.

mysql> select metadata from mt_cds_object where mime_type like 'video/x-ma%';
+------------------------------------------------------------------+
| metadata                                                         |
+------------------------------------------------------------------+
| dc%3Atitle=xmen                                                  |
| NULL                                                             |
| NULL                                                             |
| NULL                                                             |
| NULL                                                             |
| NULL                                                             |
| dc%3Atitle=Disney%27sRedo%20A%20Christmas%20Carol%202010%201080p |
| NULL                                                             |
| NULL                                                             |
| dc%3Atitle=matrix                                                |
| NULL                                                             |
| NULL                                                             |
+------------------------------------------------------------------+
12 rows in set (0.00 sec)


Only checked the mkv files I had, if this work, have to figure out what going on with my dvd's

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: MKV's with mediatomb
« Reply #10 on: August 27, 2013, 05:44:00 pm »
You may want to install development dependencies. The best way to do this, is to check out the source tree somewhere, e.g. /home/src

Code: [Select]
mkdir -p /home/src
cd /home/src
svn co http://svn.linuxmce.org/svn/trunk/src

and then

Code: [Select]
cd /home/src

You'll see our entire source tree in here, for all our core code.

What we're interested in is in our builder scripts:

Code: [Select]
cd Ubuntu_Helpers_NoHardCode/conf-files/lucid-i386

There is a list of development packages in here in the file build-packages, but we need to make one slight change, as there is one package that is in here that is normally not available on standard LinuxMCE system (it's related to some DVB stuff that VDR uses, which is not relevant for you, but if we don't get rid of it, apt will complain that the package does not exist.)

Use your favorite text editor to remove line 19, which looks like

Code: [Select]
dvb-s2api-liplianin-headers

save, exit, and then:

Code: [Select]
apt-get install `cat build-packages`

NOTE THE BACK TICKS, they are not apostrophes!

It should install all the relevant development stuff.

If apt complains, remove the offending package from the build-packages file, and try the above step again.

Once this is done, try compiling your code... you'll want to use -lid3tag probably in your compile statement, so that gcc will link the library you need.

-Thom

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: MKV's with mediatomb
« Reply #11 on: August 28, 2013, 04:09:05 pm »
I went ahead, would these below, class for troublesome packages and should be removed

Quote
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libpcre3-dev: Depends: libpcre3 (= 7.8-3build1) but 8.12-1yavdr1 is to be installed
                Depends: libpcrecpp0 (= 7.8-3build1) but 8.12-1yavdr1 is to be installed
  libxine-dev: Depends: libxine2 (= 1.2.0~hg20111226.0300-0yavdr0~lucid) but 1.2.1.git20120214-0yavdr2~lucid is to be installed

Also most packages said there were at the latest version, a few also said the following

Quote
x11proto-core-dev is already the newest version.
x11proto-core-dev set to manually installed.
x11proto-xext-dev is already the newest version.
x11proto-xext-dev set to manually installed.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2987
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: MKV's with mediatomb
« Reply #12 on: August 28, 2013, 05:08:07 pm »
If you on 1204 try apt-get update and see if it works better.

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: MKV's with mediatomb
« Reply #13 on: August 30, 2013, 01:45:39 pm »
I am on 10.04

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: MKV's with mediatomb
« Reply #14 on: August 30, 2013, 06:32:52 pm »
Worse comes to worse, try doing a virtualbox install of 12.04 and set it up for a dev environment.

-Thom