Author Topic: HDMI NO AUDIO GT 430  (Read 3011 times)

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #15 on: August 16, 2013, 11:10:15 pm »
I do not even see the audio devices, see aplay -l output below. Home this afternoon, going see what I can do

Quote
linuxmce@dcerouter:~$ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****

Crumble

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #16 on: August 16, 2013, 11:24:52 pm »
After further research found this.

 http://wiki.linuxmce.org/index.php/1004_Video_Hardware_Compatibility_List

Has the kernel upgrade instructions you were looking for and is required.

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #17 on: August 17, 2013, 02:01:35 am »
I did the following

Quote
apt-get update
CurKernel="-generic"
if uname -r | grep "pae"; then CurKernel="-generic-pae"; fi
NewKernel="linux-image${CurKernel}-lts-backport-natty"
NewHeaders="linux-headers${CurKernel}-lts-backport-natty"
apt-get -yf install "$NewKernel"
apt-get -yf install "$NewHeaders"
apt-get -yf remove linux-headers${CurKernel}
apt-get -yf remove linux-image${CurKernel}
apt-get -yf dist-upgrade

When it finished I rebooted, the headers were not installed realized after I rebooted, as the second variable NewHeaders seemed to have not been set, so I installed the hearders after.

Then I did the following

Quote
/usr/pluto/bin/Stop_X.sh
add-apt-repository ppa:ubuntu-x-swat/x-updates
apt-get update
apt-get install -y nvidia-current

But on reboot, the nvidia-install.sh, redid the 260 install and then rebooted twice and then dumped me into the Av Wizard, where sound did work this time, nice :).

Well I am not using the latest nvidia driver, but ok, see below

Quote
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)
     ................................................
        Kernel driver in use: nvidia
        Kernel modules: nvidia-glx-260, nouveau, nvidiafb

Plan, play a movie make sure it working, then backup the system and then try upgrading alsa as alsamixer claims its v1.0.22. Then try upgrading the nvidia version, hopefully editing the nvidia-install.sh, removing the card ID from 260 group and putting it in current may help. will tell you the progress.

Thanks Crumble, that did the trick

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #18 on: August 17, 2013, 03:03:15 am »
Ok although I got audio in Av Wizard, did not get any on xine. Found someone else who disable Use AC3/DTS pass-through, and rebooted, then I got audio, maybe its the TV, its a simple Toshiba, no receiver.

 So still smiling, thus far. Also I believe I am using vdpau, set it in the admin page and also for Deinterlace Quality.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #19 on: August 17, 2013, 04:26:33 am »
Often TVs only support PCM through the digital/HDMI ports. You're going to need an amp with real speakers to do any better. So you'll need to disable the DTS pass through (by saying no and no in the AVWizard, or by deselecting in web admin).

-Thom

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #20 on: August 20, 2013, 02:57:52 am »
Ok

I went ahead and tried upgrading to the current Nvidia driver following below. On reboot, it kept re-installing the 260 driver, so I removed the card entry from nvidia-install.sh and rebooted, which kept the 304*.

Quote
/usr/pluto/bin/Stop_X.sh
add-apt-repository ppa:ubuntu-x-swat/x-updates
apt-get update
apt-get install -y nvidia-current

The issue is, I cannot choose 1080p for my resolution, it bigger than the screen, only getting through with 720p, is this expected with the 304*


Crumble

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #21 on: August 20, 2013, 03:56:07 am »
have you tried removing your xorg.*?  New driver possibly different detection methods.

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #22 on: August 20, 2013, 09:51:31 am »
Yes it was removed saw the message saying it did not exist and I also rebooted with this

/usr/pluto/bin/RebootWithAVWizard.sh


Crumble

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #23 on: August 20, 2013, 10:41:17 am »
did you check if you have an xorg?

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #24 on: August 20, 2013, 11:19:24 am »
Yes it has an xorg.conf, its using the nvidia driver and  "720p (16:9)".

Crumble

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #25 on: August 20, 2013, 12:30:31 pm »
hmm, maybe try /usr/bin/pluto/Stop_X.sh
nvidia-xconfig

then manually change the resolution to 1080p

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #26 on: August 20, 2013, 01:44:41 pm »
Will try that this afternoon, when I reach home from work and let u know

CentralMedia

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #27 on: August 21, 2013, 12:24:19 am »
Na that did not help.

Every thing seems to work well with the 260 driver I might very well keep it or might stick with the 720p resolution

Crumble

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #28 on: August 21, 2013, 02:03:20 am »
You could always try this

http://wiki.linuxmce.org/index.php/Custom_Display_Resolutions

But if your tv's native resolution is 720p you will get better quality at this setting anyway. 

darkwizard864

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: HDMI NO AUDIO GT 430
« Reply #29 on: August 21, 2013, 04:41:25 am »
 did you upgrade to alsa 24 ?
it needs alsa 24.