Author Topic: ZWave stack fixes  (Read 1214 times)

stefan

  • Newbie
  • *
  • Posts: 8
    • View Profile
ZWave stack fixes
« on: July 17, 2013, 03:19:23 pm »
Hi,

Where should suggested fixes be sent? I made the following updates:
- fixed logic to not overwrite the setpoint in the State string with basic reports
- added functionality for more setpoint types (e.g. economy heat, economy cool)
- added polling of thermostats for the setpoint and mode
- added support for floating point setpoints reported by thermostats
- made the code a bit more legible by defining constants for the setpoint types

I can send the delta of the code to whoever needs it.

Thanks,
Stefan

coley

  • Guru
  • ****
  • Posts: 474
    • View Profile
Re: ZWave stack fixes
« Reply #1 on: July 17, 2013, 05:11:16 pm »
Sambuca or Hari are probably best to check this with.
Did you make these changes on the current Zwave stack? or the newer one based on OZW?

-Coley.

stefan

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: ZWave stack fixes
« Reply #2 on: July 17, 2013, 06:15:21 pm »
The changes are on the current Zwave stack.

Everything was tested using a Honeywell YTH8320ZW1007 thermostat.

Thanks,
Stefan

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: ZWave stack fixes
« Reply #3 on: July 17, 2013, 06:28:28 pm »
Thanks! Feel free to make a ticket in http://svn.linuxmce.org/ and submit an svn diff as an attachment!

-Thom

stefan

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: ZWave stack fixes
« Reply #4 on: July 17, 2013, 06:39:47 pm »
Thanks. I created Ticket #1844 and attached the svn diff.

Regards,
Stefan

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: ZWave stack fixes
« Reply #5 on: July 17, 2013, 06:42:49 pm »
Cool, according to Hari, we've moved over to using the zwave-OZW stack, based on the OpenZWave 1.0 library, have you looked @ it yet?

-Thom

stefan

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: ZWave stack fixes
« Reply #6 on: July 17, 2013, 06:55:38 pm »
No I haven't in the context of LinuxMCE. Only browsed the code a bit in the Google repository for the purpose of gaining a better understanding of ZWave. It does appear to have a more complete implementation, but I'm not familiar with how it get integrated into LinuxMCE.

Regards,
Stefan

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: ZWave stack fixes
« Reply #7 on: July 17, 2013, 06:58:44 pm »
The relevant code is in trunk/src/ZWave-OZW.

-Thom

Hackit2me

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: ZWave stack fixes
« Reply #8 on: July 29, 2013, 06:45:03 pm »
I recently submitted a seperate ticket which covers ~some~ of the same issues, before I noticed this other ticket was already submitted.

Mine: Ticket 1853

I'm thinking a merge of these two might be in order.   But we may have to hammer out some of the differences first....

Chris

Hackit2me

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: ZWave stack fixes
« Reply #9 on: August 13, 2013, 11:34:21 pm »
Completed Partial merge.

See Trac Ticket# 1853

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: ZWave stack fixes
« Reply #10 on: August 14, 2013, 03:47:11 am »
FANTASTIC! Thanks! :)

-Thom

Hackit2me

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: ZWave stack fixes
« Reply #11 on: August 21, 2013, 04:30:25 am »
Added another version of the patch to the Trac ticket, containing feedback and bug fixes from Stefan.
Will wait for a review and more comments from him.