Author Topic: [Solved] MythTV .25 in 12.04  (Read 708 times)

B34N

  • Guru
  • ****
  • Posts: 155
    • View Profile
[Solved] MythTV .25 in 12.04
« on: January 07, 2014, 01:33:59 pm »
Thank you Tschak for putting MythTV .25 in the latest 12.04 snapshots. I can now use my Silicondust HDHomeRun Prime with Cablecard with LMCE. This was really important to me as my local Comcast Cable company will be encrypting the limited basic channels in two weeks. They are supposedly keeping the "copy freely" tag on those local broadcast channels.

I went into MythTV setup and added my HDHomeRun Prime following the  instructions on the MythTV Wiki http://www.mythtv.org/wiki/Silicondust_HDHomeRun_Prime#Illustrated_Guide_.28Master.2F.25.29
Everything seemed to work. My channel guide populated after exiting and I was able to access even my encrypted local HDs. I setup MythTV to record a few shows that night and then left everything as is and worked on a ZWave issue I was having.

I went back this morning and the shows didn't record. I went into MythTV to check that the recording rules were there and I noticed that my guide data wasn't there.

I went back into MythTV setup and checked the settings. Everything seem find so I just exited setup and mythfilldatabase ran. Upon going back into Myth my guide data was there.

My questions are:
  • Did I cause a potential problem by adding a new video source instead of using the LMCE default?
  • What is the proper way to schedule MythTV recordings in LMCE? I was going into MythTV and then scheduling there.
  • Which LMCE MythTV Wiki guide is the correct one for 12.04?

Thank you,
B34N
« Last Edit: January 13, 2014, 01:47:17 am by B34N »

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: MythTV .25 in 12.04
« Reply #1 on: January 07, 2014, 05:04:19 pm »
Scheduling in MythTV should be fine, I am guessing the MythTV Plugin still thinks it needs to manage capture devices. You may want to go to

Go To Web Admin
Go to Advanced > Configure > Devices
Find the MythTV Plugin device, underneath your CORE and DCERouter.
Scroll to the device data at the bottom.
Check "Don't Auto Configure"
Save
Reload router.

If this persists, we'll go further.

-Thom

B34N

  • Guru
  • ****
  • Posts: 155
    • View Profile
Re: MythTV .25 in 12.04
« Reply #2 on: January 10, 2014, 01:31:06 am »
Thom,

Thank you for the reply. I made the changes as you suggested. I re-entered MythTV setup and it ran mythfilldatabase. All of the program guide populated and I was able to record a few shows. Unfortunately the program guide has disappeared after over 24-hrs. Might this be a problem with me adding a new video source rather than editing the LMCE default?

The recordings showed up nicely with descriptions and thumbnails in the videos section. Unfortunately the videos I tried playing back included sound only. I think they are MPEG-2? Might this be due to the LMCE 12.04 installation not having Internet access during initial install and is unable to install the third restricted extras? If so, how do I add these after the fact? It might have also been the reason why I only heard Sarah rather than saw her.

B34N

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: MythTV .25 in 12.04
« Reply #3 on: January 10, 2014, 06:14:12 am »
you may want to look at Xine_Player's screen session to see if anything interesting shows up:

Code: [Select]
screen -ls

find Xine_Player's pid, then

Code: [Select]
screen -r XXXXX

be sure to hit control-a d to exit without killing Xine Player.

You can also hit control-a ] to enable back scroll. esc exits.

-Thom

B34N

  • Guru
  • ****
  • Posts: 155
    • View Profile
Re: MythTV .25 in 12.04
« Reply #4 on: January 11, 2014, 02:00:51 am »
Thom,

Thanks again.

I run "screen -ls" from dcerouter and I get "No Sockets found in /var/run/screen/S-mark." I may/must be doing something wrong. I did this by going to a terminal from the hybrid while a video was running and also by remoteing into the hybrid. Same results.

When I playa recorded show and all I get is sound. I don't know the exact keystrokes I hit but I twice was able to get to a screen where I saw the video playing...but not likely wrapped in the LMCE controls. All I have setup on this system is the keyboard and mouse so control is really limited. Is there a list of keyboard shortcuts that I can use with playing back videos? When I start playing back I can't figure out how to exit.

I also noticed that the guide is not keeping up. Does mythfilldatabase run nightly? I did setup the LMCE-default source to use with my schedules direct account and removed the other source I added. Unfortunately the guide problem persists.

Thank you,
B34N

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: MythTV .25 in 12.04
« Reply #5 on: January 11, 2014, 02:03:55 am »
You must do the screen commands as root, as all the screen sessions, run as root.

What video hardware are you using ?

-Thom

B34N

  • Guru
  • ****
  • Posts: 155
    • View Profile
Re: MythTV .25 in 12.04
« Reply #6 on: January 11, 2014, 02:27:02 am »
Thom,

I'm not 100% sure what video hardware I'm using but I want to say it's an nvidia 8200 that I got in a barebones system from lmcecompatible.com a few years ago. This is just my hybrid core. My MDs will be something newer once I get the core working well.

Running as root certainly got me back different results. http://pastebin.com/qwA1qhGA

B34N

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: MythTV .25 in 12.04
« Reply #7 on: January 11, 2014, 04:07:58 am »
Sorry for the lag in responses, I'm doing some major late night work for AT&T...and i'm knee deep in sheet.

I see some big red flags in that output, namely that you are not running the NVIDIA drivers.

1. You need to talk to l3top asafp, to amend the detection code so that the correct drivers are chosen.
2. You need to set the accelleration to vdpau, using Web admin > Wizard > Media Directors, finding the appropriate media director, and selecting vdpau under Video Accelleration.

-Thom

B34N

  • Guru
  • ****
  • Posts: 155
    • View Profile
Re: MythTV .25 in 12.04
« Reply #8 on: January 12, 2014, 02:17:31 am »
To update this thread:

I changed my source from being a separate source and just edited linuxmce-default with all of the information needed. I don't know if this makes any difference.

I realized that the mythfilldatabase that runs upon exiting Myth Setup is not grabbing any content that starts after midnight of that day. Is there something in the call that specifies only grab until midnight? Also, isn't there anything that runs on a regular (nightly) basis that will update the program guide? IMHO it would ideally grab the next two weeks of listings just like in my standard MythTV setup.

With the help of L3top I was able to update my video driver and can watch live MythTV with no problems. I switched to UI 2 and can NOW watch videos through Xine with picture and sound through HDMI. The videos seem scaled down but maybe that's due to my 720p configuration and these are 1080 videos.

I marked this as Solved  and will create a thread more specific to my current issue.
B34N

« Last Edit: January 13, 2014, 01:48:12 am by B34N »