Author Topic: DHCP server not starting - SOLVED  (Read 5910 times)


  • Addicted
  • *
  • Posts: 666
    • View Profile
DHCP server not starting - SOLVED
« on: June 02, 2013, 06:25:13 pm »
yesterday, i did an update and upgrade, and since then, dhcp is having problems.
The dhcp server fails on start.
Was anything changed?
Best regards.

Found the problem:
error in syslog:
dhcpd: Open a socket for LPF: Permission denied
The bug was recognized and fixed for 12.04
<> but
not for 10.04. It may have to do with the server change; with 10.04 the
dhcp server is 'dhcp3-server', and with 12.04 it is 'isc-dhcp-server'.
Anyway, to fix edit:


network inet raw,
network packet packet,

network inet raw,
network packet packet,
network packet raw,

Then reload apparmor:
sudo service apparmor reload

And then the dhcp server will now start:
sudo service dhcp3-server start
« Last Edit: June 02, 2013, 06:45:09 pm by pw44 »


  • Guru
  • ****
  • Posts: 213
    • View Profile
Re: DHCP server not starting - SOLVED
« Reply #1 on: June 03, 2013, 04:53:52 am »
Hi pw44!

Thanks! I can confirm your fix worked on my 10.04 installation.  apt automatically created a usr.sbin.dhcpd3.dpkg-dist in the apparmor directory, because LMCE has modified the standard config to let it read bind's files.  With your fix applied to the config file, here's the diff that LMCE had in it

Code: [Select]
/etc/apparmor.d# diff -u usr.sbin.dhcpd3 usr.sbin.dhcpd3.dpkg-dist
--- usr.sbin.dhcpd3     2013-06-02 22:45:15.825854835 -0400
+++ usr.sbin.dhcpd3.dpkg-dist   2013-05-23 21:38:06.000000000 -0400
@@ -49,7 +49,4 @@
   /var/run/eucalyptus/net/*.pid lrw,
   /var/run/eucalyptus/net/*.leases* lrw,
   /var/run/eucalyptus/net/*.trace lrw,
-  # Let dhcpd read bind's config files
-  /etc/bind/** r,

Thanks for researching the fix!