Author Topic: 10.04 Web Admin Network settings: domain name and host name  (Read 636 times)

ajward

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Hi,
I just want to check I'm not missing something obvious, but I think there's a bug in the Web Admin Advanced->Network->Network Settings screen.
:-
For various historical reasons, I wanted a non-default host name and domain name for the dcerouter. This screen seems to suggest that you can change them.

Sure enough, if you change the default values of dcerouter and (from memory) LinucMCE for host and domain, they seem to change. BUT, if you reboot, they seem to revert to dcerouter and pluto respectively.

Looking into the scripts in /usr/pluto/bin, it seems that whenever changes to this page are submitted, the dhcp and named configuration areas (probably some others) are re-written.

That's not completely unreasonable given the purpose of LinuxMCE, but it would be nice to be told  :).

Also, the domainname seems to be forced to the value of /etc/default/domainname. The dcerouter host name is hard coded into the network scripts.

However, some of the dhcp and named configuration files do change with changes to the network setting page.

So, in summary,

  • it isn't clear that manual changes to the network configuration will be overwritten when you make *any* change through the network setting page.
  • it isn't possible to get consistent settings if you change the domain name and host name though that page

I have made some minor changes to make this work consistently, but I'm not familiar enough with php and the relationship to the pluto network scripts to get everything right, but I've got what I want out of it.

If someone wants to see the changes ask me, but the reason for the post was to ask someone who knows this area if I've got the wrong end of the stick.

Andy.