Author Topic: NAS not recognized  (Read 1597 times)

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
NAS not recognized
« on: April 18, 2013, 10:15:00 pm »
I'm trying to install a DNS321. I just reset it to factory settings, and I just re-installed LMCE 1004 final. I connected the NAS to the internal LAN, but PNP does not recognize it.  I checked DHCP leases in LMCE admin and see that the NAS has been assigned 192.168.80.133. I can use that IP to access the NAS admin page. I can also browse the NAS on my home network. I expected that LMCE would recognize the device and ask if I'd like to use it for TV, movies, etc but its not happening. I'd like some advice on troubleshooting this.
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: NAS not recognized
« Reply #1 on: April 19, 2013, 04:21:25 pm »
Those devices, do indeed, work.

For testing purposes, make sure that Windows or NFS file sharing is enabled.
Make sure that there is at least one visible share, preferrably public.

If it is not finding the device, you can try checking the Advanced > Configuration > Unknown Devices page, in the web admin for your NAS.

You can also check the SambaScanner.log and NFSScanner.log files in /var/log/pluto to see if the system is seeing your device.

-Thom

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: NAS not recognized
« Reply #2 on: April 20, 2013, 12:54:55 am »
Thank you for that. I'll start digging into it. I plugged in a Synology NAS to see if it was recognized, and it was. LMCE also asked me about using my desktop computer and my laptop, so I think my LMCE install is good - its a fresh install so I haven't had time to pork it up yet! I had already concluded that it had to be a problem with the DNS321 configuration. The most detailed LMCE wiki on D-link NAS's is for 0810 so I didn't know if setup was still the same.
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

Zerk

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Re: NAS not recognized
« Reply #3 on: April 21, 2013, 11:11:13 pm »
i have the same model used it on previous install not tried it on 1004 yet ill hook it up later tonight and see if works fine and post setting to see if can find the issue

Edit: just noticed you have 192.168.80.133 as the nas ip thats outside for non lmce devices how is it getting that number do you have the nas set to dhcp and lmce is treating it as a windows device or did you set that as a static on the nas?
« Last Edit: April 21, 2013, 11:22:23 pm by Zerk »

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: NAS not recognized
« Reply #4 on: April 22, 2013, 09:23:31 pm »
Making progress. I found the NAS in the unknown devices list. I also found a year-old post from tschak and gave it a shot.

Currently there is a bug which prevents the storage radar from finding the NAS again, if it has made it into the PnpQueue table, for now, do this:

Code: [Select]
mysql -uroot

mysql> use pluto_main
mysql> DELETE FROM PnpQueue;


Then reload the router.

PnP found the device and asked if I wanted to use it. I told it to use LMCE file structure and I think its good to go. My only issue now is how to get my movies over to it. I though I could drag and drop using my desktop computer (running Mint at the moment). No such luck yet.



http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1374
  • If it ain't broke, tweak it
    • View Profile
Re: NAS not recognized
« Reply #5 on: April 22, 2013, 10:39:12 pm »
You said you tried another NAS - isn't there a bug that prevents new NASs from being detected?

If you want to trying cleaning the database (at your own risk, but I have done this before without any adverse effects)...

Code: [Select]
mysql -uroot

mysql> use pluto_main
mysql> DELETE FROM PnpQueue;

...then reload router.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: NAS not recognized
« Reply #6 on: April 23, 2013, 03:12:45 am »
See my previous post. I just cleared the database and it seemed to get things working. I expected to be able to browse to the file structure that LMCE should have installed on the NAS, but my desktop computer is whining about an unrecognized file type.
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1374
  • If it ain't broke, tweak it
    • View Profile
Re: NAS not recognized
« Reply #7 on: April 24, 2013, 10:57:39 am »
I do beg your pardon, didn't see that.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: NAS not recognized
« Reply #8 on: April 24, 2013, 03:02:41 pm »
Things are working now. Not sure what caused the initial problem. When I first plugged in the DNS-321 it did not correctly plug and play. LMCE Admin showed that the NAS was in the unknown device list. I clicked the "unlock" button and reloaded the router, but this did not fix the problem. Manually clearing the PnP queue was what finally worked. I installed the device using the LMCE file structure. Then I ran into a problem with my Mint desktop machine that would not let me browse or add files to the NAS. The fix was simply right-clicking and unmounting the NAS folder, then opening it up again. I've copied all my videos over to the NAS and all is well.

Just fyi, while troubleshooting this, I plugged in my Synology DS207+ and this was immediately detected. I told LMCE to ignore it, because I'm going to use the Synology to store backups.

I set up the DNS321 as a samba share. Is there any advantage to using NFS instead? Also, jumbo frames are disabled in the default configuration. Any reason to mess with this?
« Last Edit: April 24, 2013, 10:26:11 pm by twodogs »
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: NAS not recognized
« Reply #9 on: April 24, 2013, 04:04:45 pm »
Jumbo frames can vastly improve performance in some cases, however, the rest of your network must be set up to properly handle it too, both your switches, and your target devices.

If you wish to use this, you will need to find out the size of the jumbo frames that all of your devices can support, and use that value for all your devices.

-Thom

Esperanto

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: NAS not recognized
« Reply #10 on: March 08, 2014, 09:44:21 pm »
Code: [Select]
mysql -uroot pluto_main
mysql> delete from PnpQueue where category="fileserver"\G

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: NAS not recognized
« Reply #11 on: March 09, 2014, 10:30:44 pm »
Esperanto:  This is a year old thread/topic.  There is no need to respond at this time.  Thanks.