Author Topic: Disable ATI drivers in 10.04? [side-stepped]  (Read 1379 times)

Armor Gnome

  • Guru
  • ****
  • Posts: 304
    • View Profile
Disable ATI drivers in 10.04? [side-stepped]
« on: April 09, 2013, 09:22:11 am »
10.04 Final.iso is working marvelously on my new hybrid as long as I am not connected to the net. 

Once I connect and the flgrx drivers are downloaded I am getting some pretty severe problems that I would like to share with L3top and others via IRC.  The way that it is breaking however is preventing booting so I need a way to assure those drivers are not selected and allow me to take the system online.

I could once installed off-line edit the sources list to remove ati.  This would work for now as I won't be adding MDs until this gets resolved.  Could someone please share the source that contains ati flgrx and anything that points to them?

Block flgrx or specify a rule to not select it for this particular chipset (ATI 4200 HD)?  I would go this route but the chip detection and driver selection rules happen so early that I am willing to bet would require a custom boot script.  If those scripts however pull from a single file I can modify values in, I could make LMCE devalue the ATI driver and choose to leave the existing drivers alone
« Last Edit: April 28, 2013, 03:11:38 pm by Armor Gnome »
I made a wiki!  Click here to check out my system.

Armor Gnome

  • Guru
  • ****
  • Posts: 304
    • View Profile
Re: Temporarily disable ATI drivers in 10.04?
« Reply #1 on: April 10, 2013, 12:26:36 am »
I got the natty back ports
It loaded flgrx
It is destroyed

Working on reinstalling so I can get back to IRC.


Radeon driver = flawless
flgrx = can't boot
I made a wiki!  Click here to check out my system.

Armor Gnome

  • Guru
  • ****
  • Posts: 304
    • View Profile
Disable ATI drivers in 10.04? [please help]
« Reply #2 on: April 10, 2013, 09:24:46 am »
Still very desperate for help on this issue. 

I know exactly what is breaking the system, but can not manage to prevent it from happening.  Once again in summary:

Install system using 1004 Final.iso
system loads radeon driver, I get to av wizard, everything works flawlessly
on reboot the flgrx driver is loaded automatically and the entire system breaks

I made a wiki!  Click here to check out my system.

Armor Gnome

  • Guru
  • ****
  • Posts: 304
    • View Profile
Re: Disable ATI drivers in 10.04? [please help]
« Reply #3 on: April 10, 2013, 07:16:55 pm »
I have found a work around, but it is bound to fail sooner or later and I will have to reinstall again after that happens.

On each reboot I have to watch very closely and the moment it starts to download flgrx, I have to pull the eth0 cable.  It hesitates a second and then defaults back to driver it has and continues to load.  After bootup is complete and I am at the onscreen orbiter I can reconnect eth0.  Typically I have my core set to automatically restart following a power failure but for the time being I have that disabled.  It's not pretty but at least I am using the system again and can start adding my devices.  Clone backups in case that driver loads....

I made a wiki!  Click here to check out my system.

Armor Gnome

  • Guru
  • ****
  • Posts: 304
    • View Profile
Re: Disable ATI drivers in 10.04? [SOLVED]
« Reply #4 on: April 10, 2013, 08:58:23 pm »
With some help on how to search for keywords, I was able to find the value assigned to various drivers.  I simply changed the value given to the problem driver and on next reboot, the system decided to use the basic working one.

I have some hesitations about what will happen if I try to add another gpu in my network that does need the flgrx driver to function properly, but if each MD doesnt have its own Utils.sh then I guess I stick with Nvidia.
I made a wiki!  Click here to check out my system.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2997
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Disable ATI drivers in 10.04? [SOLVED]
« Reply #5 on: April 10, 2013, 11:34:06 pm »
Each MD has its own OS.

ggmce

  • Veteran
  • ***
  • Posts: 60
    • View Profile
Re: Disable ATI drivers in 10.04? [SOLVED]
« Reply #6 on: April 11, 2013, 02:30:59 am »
Can you post what you did to disable the driver? I may give it a try....

Armor Gnome

  • Guru
  • ****
  • Posts: 304
    • View Profile
Re: Disable ATI drivers in 10.04? [SOLVED]
« Reply #7 on: April 11, 2013, 08:53:46 am »
I am at the very least, hesitant about providing the path I took to get this particular chip and board working.  Please read the next few lines carefully.

I have a tremendous respect for the work of L3top on video and audio detection and driver installation.  If you have an issue please at least get his take on the problem.  If nothing else the information will assist him in improving the way LinuxMCE makes more hardware plug and play in the future.  I chatted with him and ran a few complete reinstalls trying to get this card to work OOB.  After researching the issue much more I learned prior to 1004 Final, there were few test cards made available to get the NattyBackport method of flgrx installation ironed out, and that the 4200 HD is on the lower end of the supported list of GPUs under flgrx.

This system is also my core/hybrid and with just under 3TB of media, I have zero HD files.  I watch FTA television and rarely rip DVDs as I don't mind a smaller file size .avi I can download quickly.  Any driver that didn't crash would have made me happy, even in UI1 640x480.

To summarize the solution I used, I read through the Utils.sh and saw where drivers are given a priority value.  I believe flgrx was given an 8 and Radeon a 5.  This is in place to give LMCE that 'intelligence' to use the best available driver for your hardware and to sort out which chip to use when multiples are present.

sudo -i
kwrite /usr/pluto/bin/Utils.sh
located flgrx and change the value from 8 to 4
save and close, ctrl+c to get back to prompt
rm /etc/X11/xorg.con*
/usr/pluto/bin/RebootWithAVWizard.sh

*Notice the above section is not formated to appear as code, do not copy paste things like this.  Take the time to read over the Utils.sh so you understand what is going on.  #Commented out, sections are like notes left behind by the author that let you follow along with the idea and purpose of a given section or command.  Code contributers for LMCE have always been outstanding at using them in my opinion.
I made a wiki!  Click here to check out my system.