Author Topic: Does a Dedicated Core Need a Video Card?  (Read 460 times)

paulv

  • Newbie
  • *
  • Posts: 6
    • View Profile
Does a Dedicated Core Need a Video Card?
« on: March 30, 2013, 06:50:16 pm »
I have been advised, in response to a post on the "Installation" section, to replace 8.04 with 10.04 on a Poweredge 2850 that I intend to use as a dedicated core in a rack in the garage.

However, lest I waste time and energy, I'd like to know if the PE 2850 will work at all.

It appears that its Radeon 7000 onboard video will not allow X to setup and it also seems that there is no way to disable the onboard video or to replace or substitute it.

My question is...  Does a dedicated core have to have a video card at all?  Or a properly set up X environment?

Thanks.


posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2962
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Does a Dedicated Core Need a Video Card?
« Reply #1 on: March 30, 2013, 07:11:33 pm »
My core has an ATI card in it, but X is not being used.

I did setup my core originally as a hybrid, because it is easier to configure lots of initial stuff that way. But later set autostart media to 0 in /etc/pluto..conf on my core. No more X since then.

Armor Gnome

  • Guru
  • ****
  • Posts: 304
    • View Profile
Re: Does a Dedicated Core Need a Video Card?
« Reply #2 on: April 01, 2013, 08:26:41 am »
I have personally gotten 10.04 installed and running (incredibly fast btw) on a 2850 with your identical issue.  The Dell board had a front located VGA display port where av wizard was able to get the information from a standard crt monitor and make it through.  We used lowest possible settings as like you our intention was to disable autostart media once the elements were setup.  This functioned as a nice test machine as with a couple 15k scsi drives reboots/reloads/regens were fast enough that the grey screen messages were a blur.

When this needed to act as a hybrid though we came across a PCI-X video card that I am fairly certain was a 7xxx series.  The 2850s had two major versions however and although it is drawing a blank right now on its exact name, it had something to do with console redirections.  If this onboard chip is not installed on your 2850 then you are free to pull the riser board and install your video card in the pci-x.  However if you do have the series with this chip you are mostly out of luck.  I say mostly because tehbard, a member here on the forums and former roommate was able to desolder the chip from above without pulling the board from the chassis.  The error message preventing boot stopped and he was still using that machine the last time I knew.

*hopefully it goes without saying that neither I or linuxmce recommends putting a soldering iron to your equipment.  There are more "I fried my poweredge" posts scattered around than there are guides and success stories.  The hybrid I am mentioning also following surgery displayed an orange error led on the front panel (fixed with electrical tape behind the bezel) and its fan control ability.  After the initial full spins of the CPU fans when the system would normally relax, this machine stayed near the top of their rpm capability.  Rackmounted in a custom repurposed deep freezer, reboots could still be noticed outside the house as a temporary moment of peace from the noise.
I made a wiki!  Click here to check out my system.