Author Topic: Tellstick on 1004  (Read 955 times)

PSM

  • Newbie
  • *
  • Posts: 13
    • View Profile
Tellstick on 1004
« on: March 29, 2013, 11:07:26 am »
Hi Folks,

I have used a tellstick USB lighting controller for quite while on 8.10. Changed recently to 1004.
Tellstick installs automagically when the USB device is connected. That's great.
However any lights created in LMCE fail to switch anything at all.
LMCE says this to me:
Code: [Select]
Message Sent succesfully.
/usr/pluto/bin/MessageSend localhost -r 0 83 1 192 97 "" 98 ""
Response was:
RESP: Delivery failed

I tried learning and switching devices on and off from the command line with the 'tdtool'. That works flawlessly, so it seems like the messages from LMCE don't reach the Tellstick software.
Has anybody encountered this too? And if so, has it been solved?
Jetway JNC62K
AMD Athlon X2 4850
1GB Ram
4x 1TB SATA
1x 250 GB IDE
1x DVD R/W IDE
WMCE UIRT
Kubuntu 8.10 i386

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2846
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Tellstick on 1004
« Reply #1 on: March 29, 2013, 11:25:24 am »
Check if the tellstick device is running, i.e. screen -ls on the core and check for a tellstick in that list.

PSM

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Tellstick on 1004
« Reply #2 on: March 29, 2013, 09:30:50 pm »
Thanks so much, Posde! Ran screen as root on core, where the tellstick is: no tellstick device in the list.
So might fail to start at boot up. any suggestions where to look for what happens?

Code: [Select]
root@dcerouter:~# screen -ls
There are screens on:
6819.BkgSS-UpdateMediaDaemon.sh (03/27/2013 11:40:52 AM) (Detached)
11485.VDR_32 (03/26/2013 05:42:36 PM) (Detached)
11473.Picture_Viewer_27 (03/26/2013 05:42:36 PM) (Detached)
11469.MPlayer_Player_26 (03/26/2013 05:42:36 PM) (Detached)
11463.LaunchPhoto_Screen_Saver.sh_25 (03/26/2013 05:42:35 PM) (Detached)
11458.Xine_Player_23 (03/26/2013 05:42:35 PM) (Detached)
11454.SimplePhone_22 (03/26/2013 05:42:35 PM) (Detached)
11110.OnScreen_Orbiter21 (03/26/2013 05:42:33 PM) (Detached)
10220.Slim_Server_Streamer57 (03/26/2013 05:42:23 PM) (Detached)
10114.External_Media_Identifier30 (03/26/2013 05:42:21 PM) (Detached)
6411.Disk_Drive29 (03/26/2013 05:42:16 PM) (Detached)
5075.Text_To_Speech19 (03/26/2013 05:42:14 PM) (Detached)
4943.Asterisk18 (03/26/2013 05:42:12 PM) (Detached)
4856.HAL16 (03/26/2013 05:42:11 PM) (Detached)
4774.App_Server15 (03/26/2013 05:42:10 PM) (Detached)
13531.discovery (03/26/2013 05:32:29 PM) (Detached)
13444.DCERouter (03/26/2013 05:32:28 PM) (Detached)
5633.LMCE_Launch_Manager (03/26/2013 05:31:52 PM) (Detached)
5439.XWindowSystem (03/26/2013 05:31:51 PM) (Detached)
4026.GamepadRadar (03/26/2013 05:31:49 PM) (Detached)
3922.NFSRadar (03/26/2013 05:31:49 PM) (Detached)
3868.SambaRadar (03/26/2013 05:31:49 PM) (Detached)
3837.StorageStatusRadar (03/26/2013 05:31:49 PM) (Detached)
3650.VoiceMailMonitor (03/26/2013 05:31:48 PM) (Detached)
3644.NewMDinteractor (03/26/2013 05:31:48 PM) (Detached)
3638.DhcpdPlugin (03/26/2013 05:31:48 PM) (Detached)
26 Sockets in /var/run/screen/S-root.
Jetway JNC62K
AMD Athlon X2 4850
1GB Ram
4x 1TB SATA
1x 250 GB IDE
1x DVD R/W IDE
WMCE UIRT
Kubuntu 8.10 i386

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2846
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Tellstick on 1004
« Reply #3 on: March 30, 2013, 12:00:09 am »
see what the tellstick device says in web admin.

pointman87

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: Tellstick on 1004
« Reply #4 on: March 30, 2013, 10:28:16 am »
Are you using a headless core or a hybrid? I had the same problem when trying the tellstick on my headless core, moving it to an MD fixes than. Dont know why thou.

BR Daniel

PSM

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Tellstick on 1004
« Reply #5 on: March 30, 2013, 01:42:47 pm »
Hi Posde, I am not sure what I should see in webadmin. The tellstick devices  show up as generic serial devices, which, I assume, is correct. Actually I have 2 of them, one that has a first line saying 'COM port on PC' and another one that has 'Serial Number' as a first line in the webadmin. Both identifie as 'Tellstick RF USB Controller' with device template 2169. see attached screen shot.
Pointman87: I have a hybrid core. Nevertheless, I will give installing on a separate MD a try.

Jetway JNC62K
AMD Athlon X2 4850
1GB Ram
4x 1TB SATA
1x 250 GB IDE
1x DVD R/W IDE
WMCE UIRT
Kubuntu 8.10 i386

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2846
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Tellstick on 1004
« Reply #6 on: March 30, 2013, 02:47:28 pm »
looks strange to me. What I meant initially was, check under advanced on those devices if they are disabled.

EDIT: Just checked the wiki page. I do not see anything that denotes having to have two tellstick devices. If I were you, I would unplug the tellstick, reboot the core, remove the two tellstick devices, quick reload the core, plug the tellstick back in, and see what happens.
« Last Edit: March 30, 2013, 02:52:35 pm by posde »

PSM

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Tellstick on 1004
« Reply #7 on: March 31, 2013, 12:50:18 pm »
Pointman87: tried to install the device on a MD. seemed to go ok, until I got a screen saying "the device failed to start, something is not right'. Then the Tellstick was detected again and the software installation ran again, the device was started again, and also failed to start again.
Tested if I could switch on/off lights through the webadmin, did not work. So same result as on the core.
Then removed the tellstick from the MD, both physically and in the webadmin.
Posde: After I removed the Tellstick from the MD, I rebooted the core, removed the Tellstick devices, did a quick reload router, and plugged in the Tellstick.
Result: after a while Tellstick is detected, software is installed, asked to restart the router. nothing seems to happen, so quick reload router from webadmin.
Result: one single instance of Tellstick in the webadmin under device tree - core. Added an on/off light switch. Quick reload router. Try the new light device: no luck, nothing happens. Rechecked functionality with 'tdtool' :working. Did a screen -ls to check if any tellstick process is there: no Tellstick process:

Code: [Select]
root@dcerouter:~# screen -ls
There are screens on:
6807.VDR_32 (03/31/2013 12:26:33 PM) (Detached)
6801.Picture_Viewer_27 (03/31/2013 12:26:33 PM) (Detached)
6791.MPlayer_Player_26 (03/31/2013 12:26:33 PM) (Detached)
6782.LaunchPhoto_Screen_Saver.sh_25 (03/31/2013 12:26:33 PM) (Detached)
6772.Xine_Player_23 (03/31/2013 12:26:33 PM) (Detached)
6768.SimplePhone_22 (03/31/2013 12:26:33 PM) (Detached)
6501.OnScreen_Orbiter21 (03/31/2013 12:26:30 PM) (Detached)
6242.Slim_Server_Streamer57 (03/31/2013 12:26:21 PM) (Detached)
5765.External_Media_Identifier30 (03/31/2013 12:26:19 PM) (Detached)
2811.Disk_Drive29 (03/31/2013 12:26:13 PM) (Detached)
644.Text_To_Speech19 (03/31/2013 12:26:11 PM) (Detached)
31652.Asterisk18 (03/31/2013 12:26:09 PM) (Detached)
31428.HAL16 (03/31/2013 12:26:07 PM) (Detached)
31176.App_Server15 (03/31/2013 12:26:06 PM) (Detached)
13048.discovery (03/31/2013 12:16:29 PM) (Detached)
12946.DCERouter (03/31/2013 12:16:27 PM) (Detached)
5870.LMCE_Launch_Manager (03/31/2013 12:15:59 PM) (Detached)
5752.BkgSS-UpdateMediaDaemon.sh (03/31/2013 12:15:59 PM) (Detached)
5309.XWindowSystem (03/31/2013 12:15:54 PM) (Detached)
3942.GamepadRadar (03/31/2013 12:15:52 PM) (Detached)
3630.NFSRadar (03/31/2013 12:15:52 PM) (Detached)
3581.SambaRadar (03/31/2013 12:15:52 PM) (Detached)
3549.StorageStatusRadar (03/31/2013 12:15:52 PM) (Detached)
3401.VoiceMailMonitor (03/31/2013 12:15:51 PM) (Detached)
3388.NewMDinteractor (03/31/2013 12:15:51 PM) (Detached)
3375.DhcpdPlugin (03/31/2013 12:15:51 PM) (Detached)
26 Sockets in /var/run/screen/S-root.

So, I am a bit lost now.....
Jetway JNC62K
AMD Athlon X2 4850
1GB Ram
4x 1TB SATA
1x 250 GB IDE
1x DVD R/W IDE
WMCE UIRT
Kubuntu 8.10 i386

PSM

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Tellstick on 1004
« Reply #8 on: March 31, 2013, 12:58:44 pm »
Update: after writing the previous post, the core again detected the same Tellstick, and asked  to use it. Saying yes, would no doubt lead to another instance of a Tellstick controller on the core. So for the time being I slicked 'No, ignore it this time'
Jetway JNC62K
AMD Athlon X2 4850
1GB Ram
4x 1TB SATA
1x 250 GB IDE
1x DVD R/W IDE
WMCE UIRT
Kubuntu 8.10 i386

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2846
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Tellstick on 1004
« Reply #9 on: March 31, 2013, 01:58:58 pm »
Look at the logfile for the device, and try to decipher any kind of error message it might contain. Logfile is on the core under /var/log/pluto/. filename starts with the device id of your device.

PSM

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Tellstick on 1004
« Reply #10 on: March 31, 2013, 08:36:26 pm »
HI Posde,

I tried that already and checked again just no: device ID of the Tellstick device is 88. There is no log starting with 88 in /var/log/pluto.
Highest device id in var/log/pluto is 57_LaunchSlimServer.sh.log. So no log is written.
Code: [Select]
32_VDR.log.6.gz
32_VDR.log.7.gz
57_LaunchSlimServer.sh.log
57_LaunchSlimServer.sh.log.1
57_LaunchSlimServer.sh.log.2.gz
57_LaunchSlimServer.sh.log.3.gz
57_LaunchSlimServer.sh.log.4.gz
57_LaunchSlimServer.sh.log.5.gz
57_LaunchSlimServer.sh.log.6.gz
57_LaunchSlimServer.sh.log.7.gz
avremote_detect.log
avremote_detect.log.1
avremote_detect.log.3.gz
avremote_detect.log.6.gz
Jetway JNC62K
AMD Athlon X2 4850
1GB Ram
4x 1TB SATA
1x 250 GB IDE
1x DVD R/W IDE
WMCE UIRT
Kubuntu 8.10 i386

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2846
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Tellstick on 1004
« Reply #11 on: March 31, 2013, 09:03:48 pm »
execute the tellstick command manually, and see what happens.

PSM

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Tellstick on 1004
« Reply #12 on: March 31, 2013, 09:24:28 pm »
HI Posde, I'd like to, but what is 'the tellstick command'?
There is the tdtool from the Tellstick software suite, that works, but you might mean something else...
I am not that familiar with what has been built for Tellstick inside LMCE....
Jetway JNC62K
AMD Athlon X2 4850
1GB Ram
4x 1TB SATA
1x 250 GB IDE
1x DVD R/W IDE
WMCE UIRT
Kubuntu 8.10 i386