Author Topic: ATI GPUs that can use fglrx (HD2xxx +)  (Read 492 times)

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
ATI GPUs that can use fglrx (HD2xxx +)
« on: February 27, 2013, 02:38:53 am »
I wasn't able to squeeze it in quick enough for final release. I did not have enough testing time... however it worked on the scale machines... well... the method anyway...

Download this Utils.sh and replace yours with it in /usr/pluto/bin
http://svn.linuxmce.org/trac.cgi/export/27224/trunk/src/BootScripts/Utils.sh
Code: [Select]
cd ~/Documents
sudo -i
<enter password>

Code: [Select]
wget http://svn.linuxmce.org/trac.cgi/export/27224/trunk/src/BootScripts/Utils.sh
cat ./Utils.sh > /usr/pluto/bin/Utils.sh
apt-get remove --purge fglrx
rm /etc/X11/xorg.con*
apt-get update
reboot

This is going to take a LONG time. It has to upgrade your kernel, and as everything uses dkms these days, I have to do some trickery with the headers. This upgrade, on a weakly powered MD, can take up to 3 hours. DO NOT INTERRUPT!!! Yes it unpacks headers forever... and does it like 3 times.



If that isn't quite enough to get the job done do this after.

Code: [Select]
apt-get -y remove --purge xorg-driver-fglrx fglrx* --force-yes
apt-get -y install --reinstall libgl1-mesa-glx libgl1-mesa-dri fglrx-modaliases --force-yes
dpkg-reconfigure xserver-xorg
apt-get -y install --reinstall xserver-xorg-core --force-yes
rm /etc/X11/xorg.con*
reboot

But I see no need for that last mess...
« Last Edit: February 27, 2013, 02:47:16 am by l3mce »
I never quit... I just ping out.

matrex

  • Veteran
  • ***
  • Posts: 67
  • 16 Years Linux exp.
    • View Profile
Re: ATI GPUs that can use fglrx (HD2xxx +)
« Reply #1 on: February 27, 2013, 04:52:06 am »
Do I do this on the core and each md?
Hybrid core Gigabyte GA-EP45-UD3R m/b 2.8Ghz 2 gig ram. HVR1600 on the core. 2 Orbiter on Android for control 1 phone the other tablet. Running 10.04

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: ATI GPUs that can use fglrx (HD2xxx +)
« Reply #2 on: February 27, 2013, 04:41:45 pm »
Just the ATI machine.

Please report your results. We do not have VAAPI support in 1004, but performance should still be much better than the radeon driver.
I never quit... I just ping out.

matrex

  • Veteran
  • ***
  • Posts: 67
  • 16 Years Linux exp.
    • View Profile
Re: ATI GPUs that can use fglrx (HD2xxx +)
« Reply #3 on: March 01, 2013, 07:09:07 pm »
Ok, Thanx! Will let you know if I run into any problems on my end.
Hybrid core Gigabyte GA-EP45-UD3R m/b 2.8Ghz 2 gig ram. HVR1600 on the core. 2 Orbiter on Android for control 1 phone the other tablet. Running 10.04