Author Topic: Asterisk outgoing calls [solved]  (Read 2025 times)

G.I.R.

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Asterisk outgoing calls [solved]
« on: March 17, 2013, 07:43:31 pm »
Hello,

first let me thank You all again for this great application.
really enjoying linuxmce.
I recently changed my passive graphic card from a gs8400 to a gt520 in my hybrid and it really boosts the video quality.

but in this whole update tingletangle i updated the system including asterisk.

now i am unable to make extern calls.

It was working just a few weeks ago.

here is my setup:

2 phone lines:
sip.voicheap.com  used for outgoing calls / no prefix
sipgate.de used for incomming calls / prefix 9 (but this doesn`t seem to have any effect)

I only have softphones configured.

I can call every phone in the house and i can call sip adresses like thetestcall@sip2sip.info.

If i try to call a "real" phone number, i get this error (asterisk -r):

Code: [Select]
[2013-03-17 17:20:52] WARNING[17580]: chan_sip.c:5441 create_addr: Purely numeric hostname (00mytelephonenumber00), and not a peer--rejecting!
Really destroying SIP dialog '05b97f1759f5631663a257272b88e7c7@192.168.80.1:5060' Method: INVITE
[2013-03-17 17:20:52] WARNING[17580]: app_dial.c:2218 dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Unknown)

00mytelephonenumber00 is the number i got from sipgate.de and the number i registered at voipcheap.

recently i changed

Code: [Select]
ALLOW_SIP_ANON=no
to
ALLOW_SIP_ANON=yes

in /etc/asterisk/extensions.conf mentioned in another thread.

So incomming calls are working quite fine, besides a missed call is not shown on any orbiter and i cannot access the mailboxmessage.

I googled for the error message but cannot find anything of use (for me).
Is there something (an extension?) in asterisk that translates phonenumbers to sipnumbers?
And did I somehow messed it up?

My past experience with linuxmce taught me to stay away from editing config files on my own. :)

Really would appreciate a hint.

Edit:

Thought that I tried that already. But it seems that i haven`t.
Deleting all phone lines and adding them again did the trick.
...have you tried turning it off and on again.... :)

but the problem with the mailbox remains.
« Last Edit: March 24, 2013, 12:37:14 pm by G.I.R. »

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3046
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Asterisk outgoing calls
« Reply #1 on: March 17, 2013, 08:11:51 pm »
1004 or 810

G.I.R.

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: Asterisk outgoing calls
« Reply #2 on: March 17, 2013, 09:18:07 pm »
sorry
10.04