Author Topic: networking issues during install  (Read 1404 times)

TNT

  • First post!
  • Posts: 1
    • View Profile
networking issues during install
« on: March 26, 2007, 08:00:49 pm »
I am having issues with my installation.  Before installation, my network is configured as in the before image.  As I understand it, I need to disable the DHCP server on my router, and let my MCE core perform that function.

In preparation for the install, I disabled the DHCP server in my router and connected my MCE core machine to the switch via one of its two interfaces (eth0).  eth1 is disabled in the software, enabled in the BIOS.  The IP address of my router (and hence my gateway) is 10.11.1.1.  When I go through the installation process, I tell MCE about my network (static ip address - 10.11.1.199 - subnet mask 255.255.255.0 - gateway address 10.11.1.1 (my existing gateway) - dns servers as appropriate from Cable modem configuration).  MCE then enables eth1 and sets it's IP address to 10.11.1.1 - obviously causing the inability of any network traffic from leaving this machine.  This configuration is depicted in the after image.

I do not want to use this box as my firewall for a number of reasons, one of which being that the WRT54G is performing that function quite nicely.

First off, am I correct in thinking this configuration should work?  If so, do I need to disable the other ethernet port in the BIOS so the installer doesn't try to enable it and configure it as the gateway I already have?

« Last Edit: March 27, 2007, 12:12:50 am by TNT »

webpaul1

  • Veteran
  • ***
  • Posts: 140
    • View Profile
Re: networking issues during install
« Reply #1 on: March 27, 2007, 11:08:49 pm »
do you want pc2 and pc3 to do diskless boot off the mce core?  If so, they need to on the same net as eth1 (assuming that's the one mce runs dhcp on).  I'd run eth0 from mce to teh linksys (making that the 'external' net), and eth1 from the mce to the switch with all the other pc's off the switch getting ip addresses from the mce core, which are by default in teh 192.168.80.x range