Author Topic: Zotac Z-boxes - ID81 or AD04  (Read 2846 times)

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Zotac Z-boxes - ID81 or AD04
« Reply #15 on: December 06, 2012, 06:33:29 pm »
I have changed stuff... try updating.
I never quit... I just ping out.

jamo

  • Guru
  • ****
  • Posts: 461
    • View Profile
    • LMCE user Page
Re: Zotac Z-boxes - ID81 or AD04
« Reply #16 on: December 08, 2012, 12:16:47 pm »
Blast. Still no luck, even rebuilt the MD from scratch to ensure my fiddling with lirc etc hadn't affected anything. The only way I hear sound is when in KDE desktop and I test the multimedia settings.

So it is possible, obviously, to play the sound over HDMI but why not from LMCE, I wonder?

L3, can you point me in the right direction? I'm happy to dig through code and scripts and whatnot and test various things.

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Zotac Z-boxes - ID81 or AD04
« Reply #17 on: December 08, 2012, 07:56:18 pm »
Something is breaking.
I need to see /etc/asound.conf
I need to see tail -4 /etc/pluto/xine.conf
I need to see sudo aplay -l
I never quit... I just ping out.

jamo

  • Guru
  • ****
  • Posts: 461
    • View Profile
    • LMCE user Page
Re: Zotac Z-boxes - ID81 or AD04
« Reply #18 on: December 09, 2012, 07:50:17 am »
Thanks... as requested:

/etc/asound.conf:
http://pastebin.com/Lp2TBRiC

tail -4 /etc/pluto/xine.xonf:
Code: [Select]

audio.device.alsa_front_device:hw:0
audio.device.alsa_default_device:hw:0
audio.output.speaker_arrangement:Stereo 2.0

aplay -l:
Code: [Select]
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: HDA Generic [HDA Generic]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Zotac Z-boxes - ID81 or AD04
« Reply #19 on: December 09, 2012, 08:03:03 pm »
Change (or add if it does not exist) AlternateSC = 1 in /etc/pluto.conf
I never quit... I just ping out.

jamo

  • Guru
  • ****
  • Posts: 461
    • View Profile
    • LMCE user Page
Re: Zotac Z-boxes - ID81 or AD04
« Reply #20 on: December 10, 2012, 08:34:34 pm »
Woohoo! L3mce, you're a winner once again!

AlternateSC = 1 in /etc/pluto.conf

RebootWithAvWiz and I have sound over HDMI!!!