Author Topic: Missing template  (Read 646 times)

mcefan

  • Veteran
  • ***
  • Posts: 89
    • View Profile
Missing template
« on: November 02, 2012, 09:22:34 pm »
I'm in the process of looking at what it takes to start viewing/duplicating/editing templates.
I started with IP cams because it seems straight forward since there is no interface configuration issue.
I've read the articles on the wiki and found the starting point on the webadmin to be advanced > configuration > device templates. The Advanced IP CameraAdvanced IP Camera page mentions the template for the D-Link DCS-2121 as an example. However, after selecting dlink as the mfr, i have no "D-Link DCS-2121" in the template drop down list. Since I don't know what's supposed to be there, I can't tell if I'm looking in the wrong place. Is it that my list of templates is not up to date? If so, can someone give the steps to follow to update it?

Thank you.

sambuca

  • Guru
  • ****
  • Posts: 444
    • View Profile
Re: Missing template
« Reply #1 on: November 02, 2012, 10:05:29 pm »
You perhaps need to do a sqlCVS update. In the web admin -> Advanced -> sqlCVS -> Update. Check all (at least under DCE), and click next. (You need to have allowed popup windows for this to work.)

See if that helps.

br,
sambuca

mcefan

  • Veteran
  • ***
  • Posts: 89
    • View Profile
Re: Missing template
« Reply #2 on: November 02, 2012, 11:05:05 pm »
It definitely was the problem. Now the template is showing in the list.
I now know that:
  • to look at any template, I can go to the webadmin and navigate to advanced > configuration > device templates where I will find all the existing templates available in my system
  • I can go to admin -> Advanced -> sqlCVS -> Update to download templates
  • The process runs in a separate pop up window, so pop ups need to be enabled for the site
  • The window is blank while the update is taking place and the log displays when it's complete: wait for it to complete

Thank you.
« Last Edit: November 02, 2012, 11:11:43 pm by mcefan »