Author Topic: mythtv problems, mp3 cover art, and visualization  (Read 1460 times)

webpaul1

  • Veteran
  • ***
  • Posts: 140
    • View Profile
mythtv problems, mp3 cover art, and visualization
« on: March 26, 2007, 09:10:25 pm »
I got Ubuntu installed and updated and that was working. I then installed LMCE from a CD and although the install worked it seemed to have replaced my nvidia drivers as moving windows around was very slow and sloppy. Although it detected my XP PC's it never used the media that was on them. I had to manually load PlutoBas on them to get it to work. Then there is the issue with no cover art. I've not been able to get this to download cover art automatically like you said you did (or did I misunderstand something?). Then MythTV gave problems about back end server connection or something and I got no guide data or no knowledge of how to get this guide data.

Now, if I could get those simple things working flawlessy I might be able to give it more a test. Questions I have right now (assuming together we can get the above fixed) are:

1. If I have two satellite set top boxes and two PVR 150 cards can LMCE use them like MCE does?

2. Can LMCE visualize whilst I'm playing music?

I'm running LMCE on a PC with a 19" TFT (1280 x 1024) monitor. I can seem to get the menus to display well at all.


webpaul1

  • Veteran
  • ***
  • Posts: 140
    • View Profile
Re: mythtv problems, mp3 cover art, and visualization
« Reply #1 on: March 26, 2007, 09:14:32 pm »
1) What video driver did you have, what did you want, and what is it switching to?  You can make lmce stop messing with it and the conf file by putting an exit in /usr/pluto/bin/XConfigure.sh.  LMCE and Ubuntu have separate x11 conf's, so they can use different settings.  My experience is the only driver I've ever gotten to work well, even on a stock ubuntu, is the nVidia closed driver.  ATI's drivers crash all the time for me.  The stock nv driver (the open source nvidia driver) I find doesn't work.  I can only pick 3 resolutions: 640x480, 800x600 and 1024x768, no matter what monitor I connect (I've tried several with varying resolutions, but could never get the resolution to match).  Plus the nv driver can't play mpeg files, even within Ubuntu.  I've thrown tons of 1080i mpeg's at it and it chokes.  This is why I always recommend nVidia, and why the XConfigure always switches to nVidia's proprietary drivers.  That combination *should* work, and has worked well on every system I've tried, even with full ATSC hd content.

2) Regarding the PVR-150's...  Almost all the hardware mpeg capture cards use ivtv drivers.  My experience is they're not reliable and crash a lot.  That's why in my recommended configuration I chose the PVR USB 2, which uses the v4l drivers.  As I disclose in the 'what to expect' wiki, they're still not perfect and still do crash sometimes, and myth is very flaky in lmce.  This issue really baflles me because Myth has a huge and loyal user base of ardent fans.  So other users must be getting it work well, and I'm just using the stock myth ubuntu packages.  I'm hoping the myth team can help out with this.  This is a big problem, I know, and I should have disclosed it in the video--I honestly didn't think hardly anybody would see the video so I didn't put much effort into it.

3.  Regarding visualization...  When playing music what you see on the screen is the flickr gallery art.  It was my personal preference that I found this more interesting than a visualizer, especially since it changes each day.  However this is a matter of taste and I agree adding a visualizer in the future versions is a good idea.

4.  Regarding the cover art...  What I have tried doing, and what I did in the video, was to rip a bunch of dvd's *using Windows*, putting them on a NAS or USB drive, and connecting it to LMCE.  Windows MCE uses an xml file next to the dvd rip, which includes cover art info.  LMCE does correctly process windows xml file.  Regarding mp3 files, I've used xp mce (not vista) which didn't do fingerprinting.  Therefore, there was no cover art in windows to import.  So I used the cover art scanner in lmce which did add the cover art to the mp3's id-3 tags.  Since I just use the same mp3 files for each install, LMCE always has the right cover art.  I will have to see with vista if ms stores the cover art somewhere that I can read it, or if it fingerprints each time, which I won't be able to do because that requries a commercial license from AMG.