Author Topic: Insteon 2413U  (Read 2076 times)

SBCC

  • Veteran
  • ***
  • Posts: 131
    • View Profile
Insteon 2413U
« on: September 24, 2012, 08:51:55 pm »
Anyone have a problem with this hardware and buffer overrunning?

I've switched from CM15A to insteon and noticed the code has issues with X10. I'm adding patches for my devices and noticed the unit crashing sporadically. I chased it down to the unit not clearing its buffer after sending its string to DCE and just adding it all up. Just want to make sure It's not me. Or not just me. This may be limited to X10 commands.

Armor Gnome

  • Guru
  • ****
  • Posts: 304
    • View Profile
Re: Insteon 2413U
« Reply #1 on: September 25, 2012, 01:54:18 am »
I am also having problems with my CM15A.

The error I am getting primarily is failure to get x protocol trappings (libxtrap6) and DCE router failing to get status or list of child devices from it.  After 50 wake up attempts it closes communication and refuses to continue trying.

It appears to me that it insists on getting that x protocol trappings file which is no longer available.  Me and tehbard recently invested in this unit believing that it was the supported way to use cheap battery operated x10 motion sensors.  Because we are so vested, if work is needed to get this supported again we are 100% willing to make it our top priority and then share the working code/template with other users.

The wiki article is very clear on building instructions so there is a lot of information to get us rolling.  If anyone with experience with "libxtrap#", "x10 interfaces" or the CM15A from Activehome Pro could help get us going in the proper solution to this issue we would appreciate it.
I made a wiki!  Click here to check out my system.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: Insteon 2413U
« Reply #2 on: September 25, 2012, 02:16:16 am »
libxtrap6 is a non-error. It is an X11 library that has no relevance to X10, or INSTEON, etc. You're probably seeing it due to one of your dependencies (I believe Game Player) still has it listed in its dependencies.

-Thom

SBCC

  • Veteran
  • ***
  • Posts: 131
    • View Profile
Re: Insteon 2413U
« Reply #3 on: September 25, 2012, 03:07:55 am »
I moved away from the CM15A to insteon to make use of the added functionality. I believe my CM15A was damaged but did not look that hard into it. It was, I believe, a communication problem. It is not serial so it makes it hard to work with. Insteon has serial units like the 2413U and 2413S that are both RF and power line. The unit I have 2413U is plagued with problems, as I found out. This was mostly seen on HomeSeer so I thought I was ok. The units buffer will suddenly stop clearing out and just keeps adding to the buffer and send that nonsense along until it crashes. I found it easy to develop with a lot of good code already written in ruby. It does communicates fine with X10 MS16A of which I have some set up already. I've ordered a 2413S and will see if that works.

Armor Gnome

  • Guru
  • ****
  • Posts: 304
    • View Profile
Re: Insteon 2413U
« Reply #4 on: September 25, 2012, 03:42:20 am »
Thanks to tschak909 and others in IRC for helping me understand my misconception about libxtrap6.

I was seeing the failed to install "x protocol trappings" each time I connected a CM15A only because adding any new device checks dependancies on all other devices.  I assumed the package download was related to the latest device.  Before I move on completely from that package and start looking for other possible problems with the CM15A I do have a remaining question.

A failure to get any update during a apt-get upgrade results in nothing being upgraded, because it downloads all first and then updates everything.  When LMCE detects a new device and goes to get packages, does it follow the same rules?

"Would failure to get "x protocol trappings" prevent the complete installation of my CM15A?
I made a wiki!  Click here to check out my system.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: Insteon 2413U
« Reply #5 on: September 25, 2012, 05:42:30 am »
No.

ConfirmDependencies, the program that takes care of installing the "dependencies" that a device needs, deals with all the devices on a particular computer.

That is to say, that if a dependency fails to install, it will try to install it again, and again, each time a device changes, in an effort to repair the system.

Since Game Player had libxtrap6 as a dependency, ConfirmDependencies would be called when the CM15A is installed, install its stuff, and look around and ask, "is there anybody else that needs dependencies installed?" … It sees that the dependency libxtrap6 isn't installed for the game player, and then it will try to install it to confirm and satisfy the dependencies.

-Thom

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Insteon 2413U
« Reply #6 on: October 01, 2012, 01:16:18 pm »
I have a CM15a on my upto date 1004 machine that is working fine. Just to confirm this device currently works with LMCE

SBCC

  • Veteran
  • ***
  • Posts: 131
    • View Profile
Re: Insteon 2413U
« Reply #7 on: October 13, 2012, 03:19:44 am »
I agree this is not a LMCE issue. It is some kind of hardware issue with the newer PC that I have. I believe I did get it working on that machine with a powered USB hub. I did get it working on an older machine.
Both machines I needed to run a separate circuit over to get good signal.
I will try again on the newer machine so others can use this information.