Author Topic: No HDMI sound with NVIDIA GeForce 8200  (Read 1203 times)

bugman

  • Making baby steps
  • Posts: 2
    • View Profile
No HDMI sound with NVIDIA GeForce 8200
« on: September 22, 2012, 04:19:39 am »
I have done a fresh install of the LMCE-1004-20120915220026485.iso.  My system is an Acer Aspire X3400 with a Nvidia GeForce 8200 graphics card.  I have hooked up the HDMI output to my receiver and get a picture but no sound through the receiver to the TV.  :'(  During the AV Wizard setup, I selected HDMI sound but didn't hear anything through my receiver speakers.  However, I do hear sound from my computer speakers.  With my graphics card, can I get HDMI sound to work with LinuxMCE?  If not, do you recommend a graphics card for my system (U.S based)?  If I can get sound, what steps should I try?

lspci -nnk | grep VGA -A3
03:00.0 VGA compatible controller [0300]: NVIDIA Corporation C77 [GeForce 8200] [10de:084b] (rev a2)
        Kernel driver in use: nvidia
        Kernel modules: nvidia-glx-260, nvidiafb, nouveau
03:00.0 Ethernet controller [0200]: Intel Corporation 82574L Gigabit Network Connection [8086:10d3]

File: asound.conf
pcm_slave.convert {
        @args [ RATE CARD DEV ]
        @args.RATE {
                type integer
        }
        @args.CARD {
                type string
        }
        @args.DEV {
                type integer
                default 0
        }
        pcm {
                @func concat
                strings [ $CARD "," $DEV ]
        }
        rate $RATE
}

pcm.spdif_playback {
        type plug
        slave {
                @func concat
                strings [ "convert:RATE=48000,CARD=spdif:0" ]
        }
}

pcm.hdmi_playback {
        type plug
        slave {
                @func concat
                strings [ "convert:RATE=48000,CARD=hdmi:0" ]
        }
}

pcm.asym_spdif {
        type asym
        playback.pcm "spdif_playback"
        capture.pcm "plughw:0"
}

pcm.asym_hdmi {
        type asym
        playback.pcm "hdmi_playback"
        capture.pcm "plughw:0"
}

pcm.asym_analog {
        type asym
        playback.pcm "plug:dmix:0"
        capture.pcm "plughw:0"
}
pcm.!default asym_hdmi

sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidial], device 0: ALC888 Analog [ALC888 Anolog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: No HDMI sound with NVIDIA GeForce 8200
« Reply #1 on: September 22, 2012, 07:31:00 pm »
aplay -l does not list an hdmi device. This is my 8200... which works.

root@dcerouter:/usr/pluto/bin# lspci -nnk | grep VGA -A2
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation C77 [GeForce 8200] [10de:0849] (rev a2)
        Kernel driver in use: nvidia
        Kernel modules: nvidia-glx-260, nvidiafb, nouveau

root@dcerouter:/usr/pluto/bin# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: VT1708B Analog [VT1708B Analog]
  Subdevices: 1/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
card 0: NVidia [HDA NVidia], device 1: VT1708B Digital [VT1708B Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Please add 084b to /usr/pluto/bin/nvidia-install.sh  under Backports_Required=  and reboot. Maybe reboot twice... and get into avwizard on second reload. Report back.
« Last Edit: September 22, 2012, 07:46:04 pm by l3mce »
I never quit... I just ping out.

bugman

  • Making baby steps
  • Posts: 2
    • View Profile
Re: No HDMI sound with NVIDIA GeForce 8200
« Reply #2 on: September 23, 2012, 01:16:50 am »
I modified the /usr/pluto/bin/nvidia-install.sh and rebooted twice.  Next I went into avwizard and tried to get HDMI sound but no luck.  I noticed that the backport didn't install so I added the following line "deb security.ubuntu.com/ubuntu lucid-security main" to /etc/apt/sources.list and rebooted.  Still the backport didn't install, so I ran the install command from terminal to successful get the backport installed.  Next, I copied /usr/pluto/templates/asound.conf to /usr/pluto/templates/asound.conf.backup and copied /usr/pluto/templates/asound.conf.backports to /usr/pluto/templates/asound.conf.  Finally, I rebooted the machine.  The backports still exist but no HDMI sound, no change in aplay -l output, and /etc/asound.conf has the backports template settings.

I noticed that my alsa version is 1.0.22? Is this to be expected with the above backport changes?

By the way, in /usr/pluto/bin/nvidia-install.sh the line in checkALSAbackportsNeeds function should be modified to get the correct results for the backport.  A grep was left out of the statement.

alsa_backports=$(dpkg-query -l | grep "linux-backports-modules-alsa*" | grep "^ii" | awk '{print $2}') 2>/dev/null

Also, the file /usr/pluto/bin/RestartALSA.sh does not exist but is listed in the function.
« Last Edit: September 23, 2012, 01:19:14 am by bugman »

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: No HDMI sound with NVIDIA GeForce 8200
« Reply #3 on: September 23, 2012, 11:21:14 am »
Well... hdmi audio is buggered at the moment. I am working hard to fix it... however yours isn't showing in aplay, and I am not sure it is related to what I have broken... won't know until I fix it. It is my number one priority.

re the grep... it is correct as it sits.

if you type in a terminal (assuming it is installed)
dpkg-query -l "linux-backports-modules-alsa*" | grep "^ii"

It will return the correct result. If it does not return a result, it means it is not installed and the logic continues.
I never quit... I just ping out.