Author Topic: 10.04 does not seem to install correct hdpvr.ko driver please help  (Read 976 times)

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile
10.04 does not seem to install correct hdpvr.ko driver please help
« on: September 15, 2012, 09:55:48 pm »
Loaded 10.04 and overall very impressed however I again found a problem detecting hdpvr if you have a new model  "4903"

In all fairness, it looks like the files to make and install the driver are there--it just didn't get compiled against the correct kernel and was never installed. I need to know how to make and install the hdpvr.ko driver agains the current kernel. Since the files are in different places than in 8.10 I'm hesitant to wade in without some guidance.

Background:
When you do a modinfo hdpvr you get:

filename:       /lib/modules/2.6.32-42-generic/kernel/drivers/media/video/hdpvr/hdpvr.ko
description:    Hauppauge HD PVR driver
author:         Janne Grunau
license:        GPL
srcversion:     B206354E5E27473B8EAF8BB
alias:          usb:v2040p4902d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2040p4901d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2040p4900d*dc*dsc*dp*ic*isc*ip*
depends:        videodev,v4l2-common
vermagic:       2.6.32-42-generic SMP mod_unload modversions 586
....

which shows that the driver has loaded but 4903 is not included in the list and it was compiled against the 2.6.32-42-generic kernel.

However, if you go to

/mnt/device/38/copy _root_files/v4l-dvb/v4l

(38 is the device number of my hard drive)

there is another hdpvr.ko which--if you check hdpvr.h--has been compiled to include the 4903 id
The problem is that you can not simply copy it to the folder the system looks for the modules because it is compiled against the wrong version of linux and will not load:

 modprobe hdpvr
FATAL: Error inserting hdpvr (/lib/modules/2.6.32-42-generic/kernel/drivers/media/video/hdpvr/hdpvr.ko): Invalid module format

however, a modinfo reveals what the hdpvr.h file reveals--it is setup for 4903--just the wrong kernel

filename:       hdpvr.ko
description:    Hauppauge HD PVR driver
author:         Janne Grunau
license:        GPL
srcversion:     F6C2EB82D72336F87FBCDC3
alias:          usb:v2040p4982d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2040p4902d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2040p4901d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2040p4903d*dc*dsc*dp*ic*isc*ip*
depends:        usbcore,videodev,v4l2-common
vermagic:       2.6.27-17-generic SMP mod_unload modversions 586

I don't want to mess anything up at this point--so does anyone have a suggestion about how to compile these files agains the current kernel? A simple make does not work even though the makefile is there as it wants a target which I am hesitant to give without some more guidance.

As from my earlier post in 8.10, the problem is that unless LMCE has the correct driver in place it does not see "4903" and the PNP will not detect the device. And please, if any developers are reading this, it looks like everything has been fixed except for compiling/loading the correct driver. Please help!

Here is the link to my 8.10 post:
http://forum.linuxmce.org/index.php/topic,10945.0.html

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: 10.04 does not seem to install correct hdpvr.ko driver please help
« Reply #1 on: July 27, 2013, 04:48:36 pm »
Finally got myself an HDPVR and I thought it was the one supported by lmce, but I'm having the same issue... New install of 1004. same pvr model, Anyone have any info on this?

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: 10.04 does not seem to install correct hdpvr.ko driver please help
« Reply #2 on: July 27, 2013, 04:55:49 pm »
I see there was a ticket:

http://svn.linuxmce.org/trac.cgi/ticket/1058

can someone comment on this?

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: 10.04 does not seem to install correct hdpvr.ko driver please help
« Reply #3 on: July 27, 2013, 08:43:33 pm »
Ok, I installed kernel-image-2.6.38-10-generic and kernel-headers-2.6.38-10-generic (which have the patched kernel module) and everything worked fine.

**NOTE**

I have a firmware where color saturation is an issue so I added:

Quote
$v4lctl --device="$DevEntry" --set-ctrl brightness=0x80 --set-ctrl contrast=0x40 --set-ctrl hue=0xf --set-ctrl saturation=0x40 --set-ctrl sharpness=0x80
to CaptureCards_SelectInput_HDPVR.sh on line 30 and it did the trick since I dont do channel changes.