Author Topic: DeviceGroup  (Read 649 times)

brononius

  • Guru
  • ****
  • Posts: 381
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
DeviceGroup
« on: August 23, 2012, 06:53:10 pm »
Hey,

I'm trying to configure my lightbuttons to act as a kind of 'away' / 'home' status.
For this, i add several buttons in a Device group. And with advanced Events, i'm trying to configure this now.
But when i select the DeviceGroup, and try to switch on a light. It doesn't work.
Am I doing something wrong with the Devicegroup?

In the log, i see the buttons coming in. So this part is working.

/var/log/pluto/DCErouter.log
Quote
001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:49.576           Received Message from 273 (K Eetplaats 3x / Eetplaats) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:51.551           Received Message from 273 (K Eetplaats 3x / Eetplaats) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:53.118           Received Message from 273 (K Eetplaats 3x / Eetplaats) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:55.441           Received Message from 277 (K Inkom 3x / Inkom) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:56.943           Received Message from 277 (K Inkom 3x / Inkom) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>

Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3062
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: DeviceGroup
« Reply #1 on: August 23, 2012, 08:30:38 pm »
I am not sure that DeviceGroups are actually working.

brononius

  • Guru
  • ****
  • Posts: 381
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: DeviceGroup
« Reply #2 on: August 24, 2012, 05:54:03 am »
Ahh, ok. Can explain a lot. :$

Is there another way i can create an event that listen to several input buttons?
I was trying with a nesting group, but this didn't give me the wanted result.

ps i'm a bit confused about the selection buttons AND - NOT that gives me the result AND - OR...  :o
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: DeviceGroup
« Reply #3 on: August 24, 2012, 07:26:39 pm »
The issue here is that we don't have anything that emits a DeviceGroup as an event parameter. This could be added to the Lighting Plugin to facilitate this.

-Thom