Author Topic: Update / Upgrade with Limited Internet Access  (Read 2078 times)

bushtech

  • Veteran
  • ***
  • Posts: 98
    • View Profile
Re: Update / Upgrade with Limited Internet Access
« Reply #15 on: August 10, 2012, 05:52:17 pm »
Well, what about doing your sneaky upgrade thing on the md? Would that work to get the md in sync with the core? I see my md needs 231Mb of upgrades with a whole bunch of open-office files which I could probably quite safely ignore?
Core:Asus P8H77-V, Intel core i3-3240 LGA155, Inno 3D Nvidia 240 GT (DVI+VGA+HDMI), 4Gb ram, 125Gb SSD
MD: Zotax Zbox ID41

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Update / Upgrade with Limited Internet Access
« Reply #16 on: August 10, 2012, 05:56:12 pm »
Well, what about doing your sneaky upgrade thing on the md? Would that work to get the md in sync with the core? I see my md needs 231Mb of upgrades with a whole bunch of open-office files which I could probably quite safely ignore?

Pinning the versions on your core would be the tricky way to do it. All that will be available to the MDs will be what is available on the core... so if the core is pinned then the mds will use the pinned versions by proxy because I only leave available the deb-cache repository, which everything is moved to.
I never quit... I just ping out.

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Update / Upgrade with Limited Internet Access
« Reply #17 on: August 12, 2012, 07:26:31 pm »
So... to take this further... you first figure out what your big almost never changing package versions are (they should all be the same)
Code: [Select]
root@dcerouter:/usr/pluto/deb-cache# apt-cache policy lmce-skins-uita
lmce-skins-uita:
  Installed: 2.0.0.45.12080426303
  Candidate: 2.0.0.45.12081126341
  Version table:
     2.0.0.45.12081126341 0
        500 http://deb.linuxmce.org/ubuntu/ lucid/beta2 Packages
 *** 2.0.0.45.12080426303 0
        500 file:/usr/pluto/deb-cache/ ./ Packages

That is mine... so my installed version of all of these packages is 2.0.0.45.12080426303. Now I create a file /etc/apt/preferences    and populate it with this.
Code: [Select]
Package: lmce-skins-titanium
Pin: version 2.0.0.45.12080426303*
Pin-Priority: 1000

Package: lmce-skins-uita
Pin: version 2.0.0.45.12080426303*
Pin-Priority: 1000

Package: lmce-skins-slate
Pin: version 2.0.0.45.12080426303*
Pin-Priority: 1000

Package: pluto-skins-basic
Pin: version 2.0.0.45.12080426303*
Pin-Priority: 1000

Package: mce-diskless-tools
Pin: version 2.0.0.45.12080426303*
Pin-Priority: 1000

Package: pluto-avwizard-skin-basic
Pin: version 2.0.0.45.12080426303*
Pin-Priority: 1000

Package: pluto-sample-media
Pin: version 2.0.0.45.12080426303*
Pin-Priority: 1000

and do an apt-get update.
Now my upgrade goes from:
Code: [Select]
Need to get 531MB/531MB of archives.to:
Code: [Select]
Need to get 130MB/130MB of archives.Quite a difference. Now if you create this file on your core, and use the global upgrades script, it will update, and upgrade the core, then move these packages to /usr/pluto/deb-cache and changes your MDs to only fetch packages from the core... so as those are the only available packages to the MD, they, by proxy, keep those versions as well... and do not download ANYTHING on their own. See http://forum.linuxmce.org/index.php/topic,12634.0.html

This also creates a backup of your current MDs before doing the upgrade.

This knocks down a hybrid, with 3 MDs  average upgrade package downloads from 2.124 GB to 130 MB. Hope some find this useful.
I never quit... I just ping out.

bushtech

  • Veteran
  • ***
  • Posts: 98
    • View Profile
Re: Update / Upgrade with Limited Internet Access
« Reply #18 on: August 14, 2012, 04:24:13 pm »
Thanks for this L3. Certainly helps me
Core:Asus P8H77-V, Intel core i3-3240 LGA155, Inno 3D Nvidia 240 GT (DVI+VGA+HDMI), 4Gb ram, 125Gb SSD
MD: Zotax Zbox ID41