Author Topic: Why is "Composite" default not "Disable" in xorg.conf ?  (Read 1508 times)

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Why is "Composite" default not "Disable" in xorg.conf ?
« on: July 20, 2012, 11:12:00 pm »
Hi,

testing 1004 I had a lot of tearing and enabled Sync to vblank in the nvidia-settings but it did not help.

So I did some searching and found out that I should disable Composite in xorg.conf - after that really nice TV playback without tearing :-)
http://www.mythtv.org/wiki/VDPAU#Tearing.2FStuttering

Now I am wondering why it is not defaultly so configured?

Regards Viking

JaseP

  • Addicted
  • *
  • Posts: 526
    • View Profile
    • JaseP's LinuxMCE Wiki User page
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #1 on: July 20, 2012, 11:48:46 pm »
Is this true of all chipsets or only certain ones???

Personally, I think it should be on by default, but I'm an Intel user... I don't think I've seen tearing on playback, unless I don't know what I'm looking at.
See my User page on the LinuxMCE Wiki for a description of my system configuration (click the little globe under my profile pic).

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #2 on: July 21, 2012, 02:04:40 am »
Because you chose UI2 with compositing?

Just a thought.


What is your gpu please?
lspci -nnk | grep VGA -A2
I never quit... I just ping out.

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #3 on: July 22, 2012, 07:45:03 pm »
Not sure if I am using compositing!?
I did not change anything myself. It is the standard setup of LinuxMCE.

with the standard option the menu's are looking better as one can "see through" the buttons (video/audio) and so on. After disable Composite in xorg.conf they are black.

# lspci -nnk | grep VGA -A2
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400 GS [10de:06e4] (rev a1)
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nvidia

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #4 on: July 23, 2012, 12:00:56 am »
A few things.

1) compositing is what gives you transparency (the see through buttons). When I say ui2 with compositing I mean you chose the third option, ui2 with alpha (compositing) in AVWizard.
2) You have done something naughty. You are not running our driver. This is one of mine similar to yours.
02:00.0 VGA compatible controller [0300]: nVidia Corporation C77 [GeForce 8200] [10de:0849] (rev a2)
        Kernel driver in use: nvidia
        Kernel modules: nvidia-glx-260, nvidiafb, nouveau
                                 
This is yours
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400 GS [10de:06e4] (rev a1)
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nvidia
                                             
nouveau is also missing because it is blacklisted by the nvidia installer you downloaded. You have been toying around... installing custom drivers. Tsk tsk.  >:(

What you needed to do was enable vdpau by selecting "Gforce or TNT2" under video card under media director in web admin, and selecting "vdpau" for accelleration and interlacing. That should have taken care of the tearing/performance problems. However now you have both drivers installed, and it is using our configs and their module, and I don't know what is going to result.

In short, nothing is chosen by default... you chose it.
« Last Edit: July 23, 2012, 12:39:15 am by l3mce »
I never quit... I just ping out.

JaseP

  • Addicted
  • *
  • Posts: 526
    • View Profile
    • JaseP's LinuxMCE Wiki User page
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #5 on: July 23, 2012, 02:53:31 am »
Quick question for you l3me, while we're on the subject, ... Does UI2 w; Alpha Blending use any of KDE's kwin composite "magic," or is only using the composite extensions available through the Xserver/drivers?

Reason I ask is that, I recently had a minor breakthrough with my little machine that uses a GMA500,... getting Kubuntu 12.04 running on it with the open source driver (2D acceleration only, but included translucency). Someone got the touchscreen running on it, but graphics only supported with the Open Source 2D accelerated drivers for the GMA500...

And I figured that there had to be a reason Kubuntu was chosen over Ubuntu ... but I didn't know the rationale...
See my User page on the LinuxMCE Wiki for a description of my system configuration (click the little globe under my profile pic).

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #6 on: July 23, 2012, 11:22:36 am »
No... we don't use any kwin. We just use native Xserver capabilities and make our own fun. If it were up to some, there wouldn't even be a desktop available. You may have noticed that Kubuntu is not the lightest weight distro out there (though 1204 definitely feels that way in contrast to Ubuntu/Unity). There are some reasons that Kubuntu was chosen over Ubuntu, however there is nothing really tying us to Kubuntu. Indeed the goal is to have a package that can be installed over any buntu/debian with an apt/aptitude get. If I am not mistaken we were originally ported to Ubuntu, and I cant remember why we moved. We could be ported to any linux distro. It would take some work... that is for sure. In my mind we are a bit too tied to GNU/buntu... but this is mostly due to the scripting which holds everything together. We are not POSIX friendly atm, and a whole lot would have to be rewritten to make that happen. We are also tied to a lot of projects that would need some porting as well... but MOST everything would just move from point A to port B.

I am curious about your GMA500 stuff however.
I never quit... I just ping out.

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #7 on: July 23, 2012, 11:24:41 am »
So I should then select one of the other choices? IIRC there was another UI2 setting to choose from, it is called medium here?
Hmm, are there nvidia cards out there that can do Alpha blending/compositing AND tearing free playback?


Well, yes, I have installed my own driver on the system where I did run the lspci command. I took it from my 0810. Sorry, should have written that. Just thought you needed the version of the card. To get the test system online i have to shutdown my prod system as they use the same network and MD. Only the server is a different PC.
Do you need the line from the real 1004 system? Then I will get it. I will also look at if I am using the right driver.

IIRC (am not at home right now) then  "Gforce or TNT2" was already choosen. I did then select VDPAU in the two places "accelleration" and "interlacing". Did a quick reload and also a reboot of the MD.  But that did NOT change anything in MythTV. I had to go there and setup "VDPAU normal" manually.

Thanks for clearing things up, it will surely also help the next one having trouble (if the find this thread).

Are there any guidance or HOWTO's in the wiki or elsewhere that tell you what to do if you have a NVidia card in your MD and would like clean nice playback. And the same if you have an Intel/AMD or whatever...
I am just thinking, that I have some trouble getting it online and I have done it before. If we want newbies to get into this they should be guided. Maybe some links on the download page.

Regards Viking

JaseP

  • Addicted
  • *
  • Posts: 526
    • View Profile
    • JaseP's LinuxMCE Wiki User page
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #8 on: July 23, 2012, 06:06:22 pm »
I am curious about your GMA500 stuff however.

Please see here for the driver in the current K/L/X/Ubuntu:
https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo/
Here about the project lead:
http://en.wikipedia.org/wiki/Alan_Cox
The support thread:
http://ubuntuforums.org/showthread.php?t=1984236
Here for some add'l technical issues:
http://blog.bodhizazen.net/linux/ubuntu-12-04-gma500-poulsbo-boot-options/

Note: Watch the stuff about which tty is being used and the "black screen issue," which is solvable by passing a grub parameter:
http://forum.xda-developers.com/showthread.php?t=1598207

It may need to be back ported to 10.04. It provides 2D acceleration (including compositing, but not a high performance driver) ripped from the open source Intel drivers, but removes the PowerVR 3D acceleration stuff (and binaries). It is probably the least capable of drivers for the GMA500 series, but since it's completely open source, it's the only one with official kernel support (post ver. 3.0). It can be paired with Mesa Glx for software based 3D support for "passable" 3D,... but with lackluster performance (manages about 50FPS in glxgears, but note that glxgears normally limits frames to the refresh rate).

If you're able to make something of it, it will open up opportunities with some low cost/low end Atom chipsets that use it, for cheap, entry level MDs, and maybe some tablets acting as Orbiters.

See my User page on the LinuxMCE Wiki for a description of my system configuration (click the little globe under my profile pic).

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #9 on: July 23, 2012, 10:26:49 pm »
So I should then select one of the other choices? IIRC there was another UI2 setting to choose from, it is called medium here?
Hmm, are there nvidia cards out there that can do Alpha blending/compositing AND tearing free playback?


Well, yes, I have installed my own driver on the system where I did run the lspci command. I took it from my 0810. Sorry, should have written that. Just thought you needed the version of the card. To get the test system online i have to shutdown my prod system as they use the same network and MD. Only the server is a different PC.
Do you need the line from the real 1004 system? Then I will get it. I will also look at if I am using the right driver.

IIRC (am not at home right now) then  "Gforce or TNT2" was already choosen. I did then select VDPAU in the two places "accelleration" and "interlacing". Did a quick reload and also a reboot of the MD.  But that did NOT change anything in MythTV. I had to go there and setup "VDPAU normal" manually.

Thanks for clearing things up, it will surely also help the next one having trouble (if the find this thread).

Are there any guidance or HOWTO's in the wiki or elsewhere that tell you what to do if you have a NVidia card in your MD and would like clean nice playback. And the same if you have an Intel/AMD or whatever...
I am just thinking, that I have some trouble getting it online and I have done it before. If we want newbies to get into this they should be guided. Maybe some links on the download page.

Regards Viking

If you did not try to install a different driver on 1004 then all I said there about that is irrelevant.

If you do indeed have the nForce selected as video card, and vdpau selected as accel/interlacing options... then... I am a tad confused as to why you are having issues. This USED to occur for me on 810 with a similar chipset... however on 1004 I have no issues. On 810... I had to select Standard as video card... and xv in accel, and high on interlaced. I would be curious if you would play around with THOSE settings and not the compositing, what your results were. Maybe it is related to your tv's odd hz desire.

VDPAU is the only thing that might need tweaking for nVidia only... in an ideal world. Radeon drivers are not going to like compositing AND screensaver... so... I recommend blowing off screen saver. Each nVidia GPU is different too... trying to put together a "what to do" would cause more confusion than anything imo. There is a reason I work off of PCIIDs instead of models. Different PCIIDs of the same model have different capabilities. HOWEVER, if I was to put together a "todo" for your card, it would be what you believe you have done, which isn't working...

I will do ANYTHING I can to get you proper support, and make it work for everyone... but I need the ACTUAL confirmed information from that install/settings.

So play around... make changes... reload your router... and get back to me please. Tell me what works best, using compositing. Your chipset should handle it... I will check your TV thread next to see if you have replied there.

*you didn't. lol.

Thank you JaseP
« Last Edit: July 23, 2012, 10:30:56 pm by l3mce »
I never quit... I just ping out.

JaseP

  • Addicted
  • *
  • Posts: 526
    • View Profile
    • JaseP's LinuxMCE Wiki User page
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #10 on: July 24, 2012, 12:03:13 am »
Quote from: l3mce
Thank you JaseP

You're welcome... By the way check out the old drivers link on the Ubuntu wiki. Unfortunately, as I think we discussed before, to get full 3D acceleration would require backporting the old PSB drivers & the whole Xserver from ... Karmic, I think it was?!... & I'd guess that'd break a lot of stuff... But for simple UI1 stuff, no 1080i/p playback, the psb_gfx/gma500_gfx drivers should work. Looks like there's some breakage in kernels past 3.3, and I don't know about pre 3.0 kernels (couldn't find anything on backports).

See my User page on the LinuxMCE Wiki for a description of my system configuration (click the little globe under my profile pic).

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Why is "Composite" default not "Disable" in xorg.conf ?
« Reply #11 on: July 30, 2012, 11:14:35 am »
Ok, here we go ... now with everything from the 1004 test system

# lspci -nnk | grep VGA -A2
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G98 [GeForce 8400 GS] [10de:06e4] (rev a1)
        Kernel driver in use: nvidia
        Kernel modules: nvidia-glx-260, nvidiafb, nouveau

That looks like yours, it is the right kernel modules :-)

I did test 
standard video card, xv and high
Geforce and TNT2 video card, xv and high
standard video card, vdpau and vdpau
Geforce and TNT2 video card, vdpau and vdpau

Did the tests with 1080p@50i and 1080@p50

no difference, tearing in myth TV and sometimes I also saw it in screensaver.

Restarted AV wizard, selected "Medium" settings and really nice recording playback/myth TV without tearing :-)
That was using Geforce and TNT2 video card, vdpau and vdpau


No idea why it does not work, but I can live with the missing transparency - even if it does look nicer ;-)


L3MCE, thanks a LOT for helping out and gettings things to work in LinuxMCE, I really appriciate that!

Regards
Viking