Author Topic: [SOLVED] IP Camera in 1004  (Read 14987 times)

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3059
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: IP Camera in 1004
« Reply #30 on: August 03, 2012, 06:43:37 pm »
replace the core_Advanced_IP_Camera_123412341234 with the name and location of your coredump in /home/...

brononius

  • Guru
  • ****
  • Posts: 381
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: IP Camera in 1004
« Reply #31 on: August 03, 2012, 07:32:11 pm »
Ahhh, i thought it simply put the output in a file.  :-\
Why do we think we always know it better? ;)

It went better with follow command (thanks!):

sudo gdb /usr/pluto/bin/Advanced_IP_Camera /home/coredump/1/core_Advanced_IP_Cam_1344009871_11
Code: [Select]
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/pluto/bin/Advanced_IP_Camera...(no debugging symbols found)...done.

warning: core file may not match specified executable file.
[New Thread 18662]

warning: Can't read pathname for load map: Input/output error.
Reading symbols from /usr/lib/libcurl.so.4...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libcurl.so.4
Reading symbols from /usr/lib/libmysqlclient_r.so.16...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libmysqlclient_r.so.16
Reading symbols from /usr/pluto/lib/libSerializeClass.so...(no debugging symbols found)...done.
Loaded symbols for /usr/pluto/lib/libSerializeClass.so
Reading symbols from /usr/pluto/lib/libDCECommon.so...(no debugging symbols found)...done.
Loaded symbols for /usr/pluto/lib/libDCECommon.so
Reading symbols from /usr/pluto/lib/libPlutoUtils.so...(no debugging symbols found)...done.
Loaded symbols for /usr/pluto/lib/libPlutoUtils.so
Reading symbols from /lib/tls/i686/cmov/libpthread.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libpthread.so.0
Reading symbols from /usr/lib/libstdc++.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libstdc++.so.6
Reading symbols from /lib/tls/i686/cmov/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libm.so.6
Reading symbols from /lib/libgcc_s.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/tls/i686/cmov/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libc.so.6
Reading symbols from /usr/lib/libidn.so.11...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libidn.so.11
Reading symbols from /usr/lib/liblber-2.4.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/liblber-2.4.so.2
Reading symbols from /usr/lib/libldap_r-2.4.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libldap_r-2.4.so.2
Reading symbols from /lib/tls/i686/cmov/librt.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/librt.so.1
Reading symbols from /usr/lib/libgssapi_krb5.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgssapi_krb5.so.2
Reading symbols from /lib/i686/cmov/libssl.so.0.9.8...(no debugging symbols found)...done.
Loaded symbols for /lib/i686/cmov/libssl.so.0.9.8
Reading symbols from /lib/i686/cmov/libcrypto.so.0.9.8...(no debugging symbols found)...done.
Loaded symbols for /lib/i686/cmov/libcrypto.so.0.9.8
Reading symbols from /lib/libz.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libz.so.1
Reading symbols from /lib/tls/i686/cmov/libcrypt.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libcrypt.so.1
Reading symbols from /lib/tls/i686/cmov/libnsl.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libnsl.so.1
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /lib/tls/i686/cmov/libresolv.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libresolv.so.2
Reading symbols from /usr/lib/libsasl2.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libsasl2.so.2
Reading symbols from /usr/lib/libgnutls.so.26...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgnutls.so.26
Reading symbols from /usr/lib/libkrb5.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libkrb5.so.3
Reading symbols from /usr/lib/libk5crypto.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libk5crypto.so.3
Reading symbols from /lib/libcom_err.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/libcom_err.so.2
Reading symbols from /usr/lib/libkrb5support.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libkrb5support.so.0
Reading symbols from /lib/tls/i686/cmov/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libdl.so.2
Reading symbols from /lib/libkeyutils.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libkeyutils.so.1
Reading symbols from /usr/lib/libtasn1.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libtasn1.so.3
Reading symbols from /lib/libgcrypt.so.11...(no debugging symbols found)...done.
Loaded symbols for /lib/libgcrypt.so.11
Reading symbols from /lib/libgpg-error.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib/libgpg-error.so.0
Reading symbols from /lib/tls/i686/cmov/libnss_files.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libnss_files.so.2
Core was generated by `/usr/pluto/bin/Advanced_IP_Camera -d 191 -r localhost -l /var/log/pluto/191_Adv'.
Program terminated with signal 11, Segmentation fault.
#0  0x0806db4c in ?? ()
(gdb) bt
#0  0x0806db4c in ?? ()
#1  0x0805a984 in ?? ()
#2  0x08059320 in ?? ()
#3  0x0078bbd6 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#4  0x08058501 in ?? ()
(gdb)

Does this say anything?
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: IP Camera in 1004
« Reply #32 on: August 03, 2012, 10:24:27 pm »
no beacuse it is stripped:

Reading symbols from /usr/pluto/bin/Advanced_IP_Camera...(no debugging symbols found)...done.

It needs to be compiled with "-g".
rock your home - http://www.agocontrol.com home automation

brononius

  • Guru
  • ****
  • Posts: 381
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: IP Camera in 1004
« Reply #33 on: August 04, 2012, 06:53:52 am »
It needs to be compiled with "-g".

You lost me there...  :-[
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: IP Camera in 1004
« Reply #34 on: August 05, 2012, 12:36:07 am »
gdb needs "debug symbols" to print out useful backtraces. Either these are stripped off in your case or the binary was not compiled with the proper compiler switch at all. Somebody needs to compile the camera device with the "-g" switch and pass you that binary or provide the debug symbols as a separate file.
rock your home - http://www.agocontrol.com home automation

brononius

  • Guru
  • ****
  • Posts: 381
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: IP Camera in 1004
« Reply #35 on: August 06, 2012, 05:57:04 am »
Oh, ok. Will somebody be so kind to... ;)

ps, must i mention this to somebody somewhere?
Since it's a default DVD/image installation, i can image that others will have the same issue...
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

sambuca

  • Guru
  • ****
  • Posts: 449
    • View Profile
Re: IP Camera in 1004
« Reply #36 on: August 06, 2012, 08:29:00 am »
I will provide a binary with symbols later today (if no one else beats me to it...)

I don't know what the consensus about debug symbols in the default packages is? I know I haven't changed the build of the Advanced IP Camera in any way related to that.

br,
sambuca

sambuca

  • Guru
  • ****
  • Posts: 449
    • View Profile
Re: IP Camera in 1004
« Reply #37 on: August 06, 2012, 10:24:58 am »
Download this binary http://hob.dyndns.org/lmce/Advanced_IP_Camera and run it on the command line (no need to replace the one in /usr/pluto/bin), and try again.

br,
sambuca

brononius

  • Guru
  • ****
  • Posts: 381
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: IP Camera in 1004
« Reply #38 on: August 06, 2012, 10:52:07 am »
hmmm, seems to give me the same result/error...


sudo ./Advanced_IP_Camera -d 191
Code: [Select]
Advanced_IP_Camera, v.<=version=>
Visit www.plutohome.com for source code and license information

05 08/06/12 10:50:51.731 m_vectEventMethod.size() = 5. Configured EventMethods: <0xb77676f0>
05 08/06/12 10:50:51.731 m_mapPK_Device_OutputDevice.size() = 0. Configured OutputDevices: <0xb77676f0>
Segmentation fault
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

brononius

  • Guru
  • ****
  • Posts: 381
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: IP Camera in 1004
« Reply #39 on: August 06, 2012, 10:54:22 am »
And the gdb:


sudo gdb /tmp/Advanced_IP_Camera /home/coredump/1/core_Advanced_IP_Cam_1344243051_11
Code: [Select]
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /tmp/Advanced_IP_Camera...done.

warning: core file may not match specified executable file.
[New Thread 15911]
[New Thread 15914]
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/ld-linux.so.2
Core was generated by `/usr/pluto/bin/Advanced_IP_Camera -d 191 -r localhost -l /var/log/pluto/191_Adv'.
Program terminated with signal 11, Segmentation fault.
#0  0x0806db4c in __gnu_cxx::new_allocator<std::_Rb_tree_node<std::pair<int const, std::string> > >::allocate (this=0x0, __n=3218971160)
    at /usr/include/c++/4.4/ext/new_allocator.h:86
86 if (__builtin_expect(__n > this->max_size(), false))
(gdb) bt
#0  0x0806db4c in __gnu_cxx::new_allocator<std::_Rb_tree_node<std::pair<int const, std::string> > >::allocate (this=0x0, __n=3218971160)
    at /usr/include/c++/4.4/ext/new_allocator.h:86
#1  0x0805a984 in ~Advanced_IP_Camera (this=0x891e478, __in_chrg=<value optimized out>) at Advanced_IP_Camera.cpp:60
#2  0x08059320 in main (argc=7, argv=0xbfdd9ba4) at Main.cpp:203
(gdb)
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

sambuca

  • Guru
  • ****
  • Posts: 449
    • View Profile
Re: IP Camera in 1004
« Reply #40 on: August 06, 2012, 02:04:16 pm »
Not sure if I have fixed it, but can you download the binary again - I've created a new version, and try again. See if it still segfaults.

br,
sambuca

brononius

  • Guru
  • ****
  • Posts: 381
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: IP Camera in 1004
« Reply #41 on: August 06, 2012, 02:19:58 pm »
Seems to be a lot better. Thanks !!!
At least i don't have the 'segfault' anymore...
Now back to the camera setup. Or must there be done something else before?


sudo ./Advanced_IP_Camera -d 191
Code: [Select]
Advanced_IP_Camera, v.<=version=>
Visit www.plutohome.com for source code and license information

05 08/06/12 14:18:01.422 m_vectEventMethod.size() = 5. Configured EventMethods: <0xb77da6f0>
05 08/06/12 14:18:01.422 m_mapPK_Device_OutputDevice.size() = 0. Configured OutputDevices: <0xb77da6f0>



sudo gdb /usr/pluto/bin/Advanced_IP_Camera /home/coredump/1/core_Advanced_IP_Cam_1344243051_11
Code: [Select]
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/pluto/bin/Advanced_IP_Camera...done.

warning: core file may not match specified executable file.
[New Thread 15911]
[New Thread 15914]
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/ld-linux.so.2
Core was generated by `/usr/pluto/bin/Advanced_IP_Camera -d 191 -r localhost -l /var/log/pluto/191_Adv'.
Program terminated with signal 11, Segmentation fault.
#0  0x0806db4c in std::copy<ItemToSerialize**, ItemToSerialize**> (__first=0x0, __last=0xbfdd9a18, __result=0x0)
    at /usr/include/c++/4.4/bits/stl_algobase.h:458
458    copy(_II __first, _II __last, _OI __result)
(gdb) bt
#0  0x0806db4c in std::copy<ItemToSerialize**, ItemToSerialize**> (__first=0x0, __last=0xbfdd9a18, __result=0x0)
    at /usr/include/c++/4.4/bits/stl_algobase.h:458
#1  0xbfdd9a38 in ?? ()
#2  0x0805a984 in ~Advanced_IP_Camera (this=0x891e478, __in_chrg=<value optimized out>) at Advanced_IP_Camera.cpp:66
#3  0x08059320 in main (argc=7, argv=0xbfdd9ba4) at Main.cpp:203

Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

sambuca

  • Guru
  • ****
  • Posts: 449
    • View Profile
Re: IP Camera in 1004
« Reply #42 on: August 06, 2012, 02:32:11 pm »
You should be able to set up the camera now.

What you can do is to edit the /etc/pluto.conf file and find the LogLevels line. Add ,10 to the end of it to get more logging:
Code: [Select]
LogLevels = 1,5,7,8,10And do a quick reload - or if you like, for testing purposes, you can start the device on the command line (no reload required).

br,
sambuca

brononius

  • Guru
  • ****
  • Posts: 381
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: IP Camera in 1004
« Reply #43 on: August 06, 2012, 03:32:59 pm »
I've recreated the camera (id 192) and rebooted the server completly.
Afterwards, no luck with the camera.  :-[


tail -f /var/log/pluto/192_Advanced_IP_Camera.log
Code: [Select]
== ATTEMPT FRESH START ==
1 08/06/12 15:15:03 /usr/pluto/bin/Spawn_Device.sh 192 (spawning-device) 15920 Dev: 192; Already Running list: 15,16,18,19,29,30,123,180,
== FRESH START ==
1 08/06/12 15:15:03 /usr/pluto/bin/Spawn_Device.sh 192 (spawning-device) device: 192 ip: localhost cmd_line: Advanced_IP_Camera
0 08/06/12 15:15:03 192 (spawning-device) Entering 192
========== NEW LOG SECTION ==========
1 08/06/12 15:15:03 192 (spawning-device) Starting... 1
1 08/06/12 15:15:03 192 (spawning-device) Found /usr/pluto/bin/Advanced_IP_Camera
05 08/06/12 15:15:03.792 m_vectEventMethod.size() = 5. Configured EventMethods: <0xb77796f0>
05 08/06/12 15:15:03.792 m_mapPK_Device_OutputDevice.size() = 0. Configured OutputDevices: <0xb77796f0>




A manual start, sudo /usr/pluto/bin/Advanced_IP_Camera -d 192
Code: [Select]
Advanced_IP_Camera, v.<=version=>
Visit www.plutohome.com for source code and license information

05 08/06/12 15:26:40.225 m_vectEventMethod.size() = 5. Configured EventMethods: <0xb77c46f0>
05 08/06/12 15:26:40.225 m_mapPK_Device_OutputDevice.size() = 0. Configured OutputDevices: <0xb77c46f0>
No error afterwards, just keeps running?





And a debug, sudo gdb /usr/pluto/bin/Advanced_IP_Camera /home/coredump/1/core_Advanced_IP_Cam_1344257657_11
Code: [Select]
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/pluto/bin/Advanced_IP_Camera...done.

warning: core file may not match specified executable file.
[New Thread 3512]
[New Thread 3515]

warning: Can't read pathname for load map: Input/output error.
Reading symbols from /usr/lib/libcurl.so.4...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libcurl.so.4
Reading symbols from /usr/lib/libmysqlclient_r.so.16...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libmysqlclient_r.so.16
Reading symbols from /usr/pluto/lib/libSerializeClass.so...(no debugging symbols found)...done.
Loaded symbols for /usr/pluto/lib/libSerializeClass.so
Reading symbols from /usr/pluto/lib/libDCECommon.so...(no debugging symbols found)...done.
Loaded symbols for /usr/pluto/lib/libDCECommon.so
Reading symbols from /usr/pluto/lib/libPlutoUtils.so...(no debugging symbols found)...done.
Loaded symbols for /usr/pluto/lib/libPlutoUtils.so
Reading symbols from /lib/tls/i686/cmov/libpthread.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libpthread.so.0
Reading symbols from /usr/lib/libstdc++.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libstdc++.so.6
Reading symbols from /lib/tls/i686/cmov/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libm.so.6
Reading symbols from /lib/libgcc_s.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/tls/i686/cmov/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libc.so.6
Reading symbols from /usr/lib/libidn.so.11...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libidn.so.11
Reading symbols from /usr/lib/liblber-2.4.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/liblber-2.4.so.2
Reading symbols from /usr/lib/libldap_r-2.4.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libldap_r-2.4.so.2
Reading symbols from /lib/tls/i686/cmov/librt.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/librt.so.1
Reading symbols from /usr/lib/libgssapi_krb5.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgssapi_krb5.so.2
Reading symbols from /lib/i686/cmov/libssl.so.0.9.8...(no debugging symbols found)...done.
Loaded symbols for /lib/i686/cmov/libssl.so.0.9.8
Reading symbols from /lib/i686/cmov/libcrypto.so.0.9.8...(no debugging symbols found)...done.
Loaded symbols for /lib/i686/cmov/libcrypto.so.0.9.8
Reading symbols from /lib/libz.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libz.so.1
Reading symbols from /lib/tls/i686/cmov/libcrypt.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libcrypt.so.1
Reading symbols from /lib/tls/i686/cmov/libnsl.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libnsl.so.1
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /lib/tls/i686/cmov/libresolv.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libresolv.so.2
Reading symbols from /usr/lib/libsasl2.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libsasl2.so.2
Reading symbols from /usr/lib/libgnutls.so.26...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgnutls.so.26
Reading symbols from /usr/lib/libkrb5.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libkrb5.so.3
Reading symbols from /usr/lib/libk5crypto.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libk5crypto.so.3
Reading symbols from /lib/libcom_err.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/libcom_err.so.2
Reading symbols from /usr/lib/libkrb5support.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libkrb5support.so.0
Reading symbols from /lib/tls/i686/cmov/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libdl.so.2
Reading symbols from /lib/libkeyutils.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libkeyutils.so.1
Reading symbols from /usr/lib/libtasn1.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libtasn1.so.3
Reading symbols from /lib/libgcrypt.so.11...(no debugging symbols found)...done.
Loaded symbols for /lib/libgcrypt.so.11
Reading symbols from /lib/libgpg-error.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib/libgpg-error.so.0
Reading symbols from /lib/tls/i686/cmov/libnss_files.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/i686/cmov/libnss_files.so.2
Core was generated by `/usr/pluto/bin/Advanced_IP_Camera -d 192 -r localhost -l /var/log/pluto/192_Adv'.
Program terminated with signal 11, Segmentation fault.
#0  DCE::EventMethod::Start (this=0x805b164) at EventMethod.cpp:51
51 EventMethod.cpp: No such file or directory.
in EventMethod.cpp
(gdb) bt
#0  DCE::EventMethod::Start (this=0x805b164) at EventMethod.cpp:51
#1  0xbf86c7a8 in ?? ()
#2  0x0805b164 in ~Advanced_IP_Camera (this=0x96d0478, __in_chrg=<value optimized out>) at Advanced_IP_Camera.cpp:54
#3  0x08059500 in main (argc=7, argv=0xbf86c914) at Main.cpp:236
(gdb) quit
Now a 'segmentation fault' more at the end? ps i don't now what i'm looking at  :-X


Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

sambuca

  • Guru
  • ****
  • Posts: 449
    • View Profile
Re: IP Camera in 1004
« Reply #44 on: August 06, 2012, 03:56:58 pm »
The log wont show much more than now before something starts happening..

But you should enable more logging like I described, it will help troubleshoot.

br,
sambuca