Author Topic: [solved] 10.04 / asterisk / creating phones  (Read 962 times)

brononius

  • Guru
  • ****
  • Posts: 379
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
[solved] 10.04 / asterisk / creating phones
« on: July 24, 2012, 03:30:56 pm »
Hey,

I'm trying to install some phones in 10.04. I've got a bunch of cisco 7940 & 7960 phones that have SIP installed on.
In LMCE, i go to 'Wizard'  > 'devices' > 'phones'.

I add following information for the first phone
  • Phonename: office
  • Location: office
  • sip password: sip
  • IP adress: 192.168.2.231
  • MAC: 11:22:33:44:55:66
The phone is properly configured.
A SIP112233445566.cnf is created.

Now i'm adding a second phone:
  • Phonename: bedroom
  • Location: bedroom
  • sip password: sip
  • IP adress: 192.168.2.232
  • MAC: 11:22:33:44:55:77

When i now check the tftpboot folder, a SIP112233445577 is created.
But the webpage seems to keep refreshing?  >:(

Next i'm checking with the command top in a console. And i see that some scripts keep returning. They disapperar, coming back...
  • db_phone_config
  • configure_cisco

And the files in the folder tftpboot are recreating the whole time?

Any idea what's going on?
Not sure what to do (beside rebooting the server)... ???
« Last Edit: July 31, 2012, 08:42:08 am by brononius »
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

cfernandes

  • Guru
  • ****
  • Posts: 291
    • View Profile
    • my company web site
Re: 10.04 / asterisk / creating phones
« Reply #1 on: July 24, 2012, 04:57:03 pm »
hi  brononi,

i do the same config   on my  instalation and  i can't reproduce  this  error .

what device template  you used to create this cisco phones ?

cfernandes

  • Guru
  • ****
  • Posts: 291
    • View Profile
    • my company web site
Re: 10.04 / asterisk / creating phones
« Reply #2 on: July 24, 2012, 05:11:58 pm »
Brononi ,

i found a error on scripts that create  this extensions .

i need some time to fix then .
   


brononius

  • Guru
  • ****
  • Posts: 379
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: 10.04 / asterisk / creating phones
« Reply #3 on: July 24, 2012, 08:02:34 pm »
Great!

Not that you've got a problem, but great that you found something...  ::)
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02

cfernandes

  • Guru
  • ****
  • Posts: 291
    • View Profile
    • my company web site
Re: 10.04 / asterisk / creating phones
« Reply #4 on: July 28, 2012, 02:57:09 pm »

brononius

  • Guru
  • ****
  • Posts: 379
  • Trying to keep it simple and centralized...
    • View Profile
    • OnIrIa - linuxMCE blog (runs on ... linuxmce server)
Re: 10.04 / asterisk / creating phones
« Reply #5 on: July 31, 2012, 08:41:52 am »
Hey cfernandes,

With your temp workaround, i was able to insert all phones in my linuxmce, thanks!!!

For those who've the same issue (till the new release):
Quote from: cfernandes
  • edit /usr/pluto/bin/db_phone_config.sh
  • change  RunConfigureScript to # RunConfigureScript on line 243 (or 232?)
Version: linuxMCE 1004 (v 2012-07-01)
Extra's: Cacti, webmin, phpmyadmin, joomla

Server: MSI MS-7519 / E7400 2,8GB / 4GB / SSD 60GB / Radeon HD4350 / RTL8111 - 3C905C-TX
Orbiters: HTC Desire Z, HP PocketPC, Samsung Galaxy S, iPAD, ASUS eeePAD
Automation: EIB technology, KNX IP ROUTER 750
Phones: Cisco 7940, Cisco 7960
Camera's: IPCAM02