Author Topic: Raspberry Pi builder  (Read 10226 times)

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Raspberry Pi builder
« on: July 24, 2012, 01:52:45 pm »
Picking up the discussion from here http://forum.linuxmce.org/index.php/topic,12147.msg90780.html#msg90780
and Thom's suggestion http://forum.linuxmce.org/index.php/topic,12689.msg90909.html#msg90909
What do I need to start running and breaking ;)
I'm assuming the database changes need to happen first to allow the builder scripts to operate correctly?

-Coley.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1015
    • View Profile
Re: Raspberry Pi builder
« Reply #1 on: July 24, 2012, 04:18:59 pm »
Database changes are the first step.  New builder conf files to add the new distro and arch information are also required.  I have this working here.  I've finally got some time and I'll jump into -devel and see if I can get on the database changes.

J.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1015
    • View Profile
Re: Raspberry Pi builder
« Reply #2 on: July 24, 2012, 06:04:03 pm »
I setup a wiki page with some basic steps, issue list etc for following/post documenting porting to raspbian, please add/remove/comment as you see issues arise and fall.

http://wiki.linuxmce.org/index.php/Porting_Raspbian

J.
« Last Edit: August 14, 2012, 05:02:52 pm by phenigma »

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: Raspberry Pi builder
« Reply #3 on: August 28, 2012, 01:22:30 pm »
you've made progress :)

Is there anything I can test? maybe help with some of the iterative tasks of the builder

-Coley.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1015
    • View Profile
Re: Raspberry Pi builder
« Reply #4 on: August 28, 2012, 06:07:07 pm »
I'm on the verge of submitting the build script changes that I am using.  I am working my way through a build now and fixing up some multi-arch include issues.

The biggest issue I am having right now is that I cannot get the arm mysqld to run in a qemu chroot.  I keep getting segfaults.  I'm working around this right now by running mysqld outside the chroot and sharing the database across multiple chroot builders (raspbian wheezy armhf & ubuntu lucid i386).

The createbuilder script I am using creates a raspbian builder, it also creates ubuntu builders, with shared source tree and shared database.

I have an initial device template for the rpi and I'm researching the MD detection/creation process to see how to proceed there.

Builds take a long time under qemu, there is a lot of waiting to see if the build succeeds/fails.

Once possy accepts the build script changes I will likely request svn access so I can apply patches as I go, it is much more efficient than having to ask and wait for others to apply patches.  This is the primary reason I am not creating patches regularly as I go, it becomes difficult to manage

J.

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: Raspberry Pi builder
« Reply #5 on: September 28, 2012, 02:38:29 pm »
I tried following your instructions to set up a Pi as an MD - but even after an sqlCVS update I don't have the Device template you mention, is there something I'm missing?
Are your raspbian builder scripts available somewhere?

thanks,
-Coley.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1015
    • View Profile
Re: Raspberry Pi builder
« Reply #6 on: September 30, 2012, 05:08:26 am »
Hmm, strange.  I have sqlCVS updated many systems to get the Raspberry pi as MD device template (#2216).  It is there.  Make sure you sqlcvs update the 'dce' table AND the 'ir' table or the template probably won't show up due to missing data.

The Ubuntu_Helper diffs are in svn, not applied.  http://svn.linuxmce.org/trac.cgi/ticket/1521, I'll post the createbuilder script I use and try to provide a coherent set of steps to get raspbian build going.    Tomorrow, on my way to bed now...

J.
« Last Edit: September 30, 2012, 05:30:20 am by phenigma »

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1015
    • View Profile
Re: Raspberry Pi builder
« Reply #7 on: October 03, 2012, 11:26:03 pm »
Sorry Coley, been really sick and very busy, I haven't forgotten, I am delayed though...  I plan to get to this ASAP.

J.

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: Raspberry Pi builder
« Reply #8 on: October 04, 2012, 12:01:59 pm »
No worries, whenever you get to it.
I installed a recent snap on a VM and do see your RPi device template - so I'm "guessing" my dB has a few non-standard entries which is preventing the template from appearing :)

I'll grab the Disk Image stuff from svn and see how far I get.

Get well soon.

-Coley.

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: Raspberry Pi builder
« Reply #9 on: October 12, 2012, 01:16:44 am »
Holy crap! the chroot'd raspbian build is sloooow - or maybe that's because I have it in a VM...
Don't have a full builder set up but am building up some of the common lmce libs.
I know qOrbiter has all the stuff statically linked but I figured its better back as a shared lib when there is less memory to go around as on the Rpi.

-Coley.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1015
    • View Profile
Re: Raspberry Pi builder
« Reply #10 on: October 17, 2012, 03:52:35 am »
QEMU is slooow.  I build in VMs all the time, and building with qemu in a vm is very slow.  I'm away for the remainder of the week, I'll get to posting my createbuilder script this weekend.

J.

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: Raspberry Pi builder
« Reply #11 on: October 17, 2012, 11:15:02 pm »
Maybe should start a new topic
MoonPi :)
http://i.imgur.com/6dpvl.jpg

-Coley.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Raspberry Pi builder
« Reply #12 on: October 17, 2012, 11:21:38 pm »
coley :D

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1015
    • View Profile
Re: Raspberry Pi builder
« Reply #13 on: October 19, 2012, 11:24:06 pm »
Very good!  I'm glad someone else has tested the changes and things are working as I hoped.  My big question is:  Have you managed to get qOrbiter running yet?  I haven't had the time to get it going.  As soon as we have a build scenario for qOrbiter I'll flush out the MD creation more completely.  I've been running standard SDL orbiter on my (moon)Pi for some months now.  We are very close to having a working accelerated X on Pi which would allow SDL orbiter to function more fluidly.  qOrbiter is still the way to go moving forward of course.

J.

Maybe should start a new topic
MoonPi :)
http://i.imgur.com/6dpvl.jpg

-Coley.

« Last Edit: October 19, 2012, 11:27:59 pm by phenigma »

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: Raspberry Pi builder
« Reply #14 on: October 20, 2012, 01:58:54 am »
I've been making some progress.
I've packaged the qt5 I've built with phonon as a deb and installed that.
qOrbiter runs but I'll have to stub out the AudioVisual Plugin for the moment until I can get it compiled. There have been changes in how plugins do their exporting.

-Coley.