Author Topic: Dianemo S Media files Sync  (Read 1031 times)

gadget

  • Veteran
  • ***
  • Posts: 136
    • View Profile
Dianemo S Media files Sync
« on: June 13, 2012, 02:14:00 pm »

I can't seem to get to the video/audio files from either pluto or dianemo web admin to display. All of the data is on a linux NAS and that isn't showing under media files sync but the audio/movies are definitely there when I play them from the NC or an MM.

gadget

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4462
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Dianemo S Media files Sync
« Reply #1 on: June 13, 2012, 04:42:40 pm »
I can't seem to get to the video/audio files from either pluto or dianemo web admin to display. All of the data is on a linux NAS and that isn't showing under media files sync but the audio/movies are definitely there when I play them from the NC or an MM.

gadget

So you can see the files on your NAS from an Orbiter and they play ok... but you can't see them in Web Admin - file sync? Is that a correct description of your problem?

If you PM me with your Dianemo installation ID I will have someone look into it for you later today through Remote Assistance.

All the best

Andrew
« Last Edit: June 14, 2012, 11:18:39 am by totallymaxed »
Andy Herron,
Convergent Home Technologies Ltd

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4462
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Dianemo S Media files Sync
« Reply #2 on: June 19, 2012, 04:14:43 pm »
I can't seem to get to the video/audio files from either pluto or dianemo web admin to display. All of the data is on a linux NAS and that isn't showing under media files sync but the audio/movies are definitely there when I play them from the NC or an MM.

gadget

We'll look into this today via Remote Assistance.

Regards


Andrew
Andy Herron,
Convergent Home Technologies Ltd

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4462
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Dianemo S Media files Sync
« Reply #3 on: June 19, 2012, 04:49:54 pm »
We'll look into this today via Remote Assistance.

Regards


Andrew

We've just looked into this issue via Remote Assistance. It appears that you chose not to use the Pluto File structure when adding these shares. When you do this all the content stored on these devices appears under 'Other'. If you drill down under other you will see all of your media files are there and manageable from Web Admin.

For files to appear in the normal locations in Media Files Synch you must add your storage devices and use the Pluto File Structure. Having said that there is nothing at all wrong with the way you have setup your storage devices  - they clearly pre-existed your Pluto or Dianemo S installation and there the choice of not using the Pluto File Structure was correct and logical.

All the best


Andrew
« Last Edit: June 19, 2012, 05:24:46 pm by totallymaxed »
Andy Herron,
Convergent Home Technologies Ltd

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

gadget

  • Veteran
  • ***
  • Posts: 136
    • View Profile
Re: Dianemo S Media files Sync
« Reply #4 on: June 21, 2012, 04:53:09 am »
Thanks Andrew.

These shares were all created using the original LMCE directory structure so not sure why they don't fit the pluto structure. What do I need to do to fix them now. Do I delete the shares and re-add them of can I create a pluto structure manually.

gadget

gadget

  • Veteran
  • ***
  • Posts: 136
    • View Profile
Re: Dianemo S Media files Sync
« Reply #5 on: June 25, 2012, 06:02:32 am »
Hi Andrew,

I removed and re-added the share and selected dianemo file structure as per the wiki. Doing /usr/pluto/bin/Configure_1837.sh -d ?? then called /usr/pluto/bin/StorageDevices_Setup.sh. However there was an error that djmount was not found.

I have just done and apt-get install djmount and have the following errors when running /usr/pluto/bin/StorageDevices_Setup.sh
Code: [Select]
chmod: cannot access `/home//usr/pluto/locks': No such file or directory
chmod: cannot access `/home//usr/pluto/locks': No such file or directory
chmod: cannot access `/home//usr/pluto/locks': No such file or directory
chmod: cannot access `/home//usr/pluto/locks': No such file or directory
chmod: cannot access `/home//usr/pluto/locks': No such file or directory

and at the bottom.

/mnt/upnp is not a mountpoint

My shares do now show up where I expect them in Media Files but wanted to know if there is anything I need to do to fix the above errors.

gadget

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4462
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Dianemo S Media files Sync
« Reply #6 on: June 26, 2012, 12:08:42 am »
Hi Andrew,

I removed and re-added the share and selected dianemo file structure as per the wiki. Doing /usr/pluto/bin/Configure_1837.sh -d ?? then called /usr/pluto/bin/StorageDevices_Setup.sh. However there was an error that djmount was not found.

I have just done and apt-get install djmount and have the following errors when running /usr/pluto/bin/StorageDevices_Setup.sh
Code: [Select]
chmod: cannot access `/home//usr/pluto/locks': No such file or directory
chmod: cannot access `/home//usr/pluto/locks': No such file or directory
chmod: cannot access `/home//usr/pluto/locks': No such file or directory
chmod: cannot access `/home//usr/pluto/locks': No such file or directory
chmod: cannot access `/home//usr/pluto/locks': No such file or directory

and at the bottom.

/mnt/upnp is not a mountpoint

My shares do now show up where I expect them in Media Files but wanted to know if there is anything I need to do to fix the above errors.

gadget

Yes we've seen that djmount error. We're looking into a fixs o that you wont get those messages. In the mean time it's not harmful so don't worry about it.

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk