Author Topic: Dianemo issue with USB Webcam  (Read 2043 times)

gtsupport

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Dianemo issue with USB Webcam
« on: May 17, 2012, 03:28:07 pm »
Next problem.

I have got my webcam somewhere near, when I plug it in I get the green led now, also it has created /dev/video1 which seems promising.  When I try to access it from the security cameras screen on either the webadmin, or from the dianemo ipad app. I get "unable to open video device".

The webcam is a "Creative Webcam Go" and worked fine previously.  I'm sure its a setting that I haven't done properly, so all comments appreciated.
LinuxMCE - If it was easy, everybody would be doing it!!

gtsupport

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: Dianemo issue with USB Webcam
« Reply #1 on: May 22, 2012, 10:03:37 pm »
Update,

I tried to use the camera via the desktop, but any software that I try to open to test it with fails to open with a message about dynamic twinview disabled.  I've tried cheese, plus one other I can't remember at the moment.
LinuxMCE - If it was easy, everybody would be doing it!!

ladekribs

  • Veteran
  • ***
  • Posts: 86
    • View Profile
Re: Dianemo issue with USB Webcam
« Reply #2 on: May 23, 2012, 08:38:00 am »
I am no expert, but I am trying to understand webcam under 1004.

what does cat /dev/videox say?


BR Stefan

gtsupport

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: Dianemo issue with USB Webcam
« Reply #3 on: May 23, 2012, 02:33:28 pm »
Hi Stefan,

I tried the command you suggested from a terminal, and it just spewed out a continuous load of characters, which could represent an image, or not.  I have attached a screenshot of the output, but its just code, and goes on until you ctrl C out of it.

LinuxMCE - If it was easy, everybody would be doing it!!

ladekribs

  • Veteran
  • ***
  • Posts: 86
    • View Profile
Re: Dianemo issue with USB Webcam
« Reply #4 on: May 24, 2012, 09:12:33 am »
Oh I am sorry it should have been "cat /dev/video*" and it should give something like /dev/video0

BR Stefan

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3059
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Dianemo issue with USB Webcam
« Reply #5 on: May 24, 2012, 03:05:21 pm »
I am fairly positive you meant to say
Quote
ls -l /dev/video*

ladekribs

  • Veteran
  • ***
  • Posts: 86
    • View Profile
Re: Dianemo issue with USB Webcam
« Reply #6 on: May 25, 2012, 08:36:11 am »
Yes POSDE I will be quiet for a while now

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Dianemo issue with USB Webcam
« Reply #7 on: June 06, 2012, 10:57:32 pm »
Update,

I tried to use the camera via the desktop, but any software that I try to open to test it with fails to open with a message about dynamic twinview disabled.  I've tried cheese, plus one other I can't remember at the moment.

Hi,

We just released Dianemo S for Ubuntu 12.04lTS earlier this evening. You could test your Webcam with a Ubuntu 12.04LTS LiveCD and see if you can get the camera working. If that works then you might want to try upgrading to 12.04. See the Dianemo S Wiki page for upgrade information.

All the best


Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: Dianemo issue with USB Webcam
« Reply #8 on: June 21, 2012, 12:54:38 am »
Ok I thought I would add to this thread instead of starting a new one.

I have today installed my usb webcam.

It was detected fine and I got /dev/video0

I have added the camera as per the linuxmce wiki instructions and all is setup.

If I go onto a media manager and select the camera from the on-screen orbiter it loads and displays fine.

However for some reason when I go onto the webadmin and try and view camera it gives me a broken image logo where the picture should be.

Any ideas?

Regards

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Dianemo issue with USB Webcam
« Reply #9 on: June 21, 2012, 08:33:28 am »
Ok I thought I would add to this thread instead of starting a new one.

I have today installed my usb webcam.

It was detected fine and I got /dev/video0

I have added the camera as per the linuxmce wiki instructions and all is setup.

If I go onto a media manager and select the camera from the on-screen orbiter it loads and displays fine.

However for some reason when I go onto the webadmin and try and view camera it gives me a broken image logo where the picture should be.

Any ideas?

Regards

Hi fibres,

I've looked at your NC via Remote Assistance and the usb camera device looks ok. But we dont often use usb cameras in pro installations so i will have someone else check it over later today for you (he uses them on his home system).

On a general point I would suggest that adding your camera (usb or ip) under Motion Wrapper is the best choice as this allows you to do basic viewing of the cameras but also use them for motion detection too. I'll look at extending the 'Surveillance Camera' section of the Dianemo S wiki page to cover the procedure for this.

All the best

Andrew

Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: Dianemo issue with USB Webcam
« Reply #10 on: June 21, 2012, 02:23:21 pm »
Hi Andrew.

Thanks for looking at that. Its really strange as I can see the image. All be it a very poor image but that could be the camera I have yet to full investigate this from the on-screen just not the web interface.

I thought I had added it under the motion wrapper?

It is setup as a child device of the motion wrapper template.

Regards

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Dianemo issue with USB Webcam
« Reply #11 on: June 21, 2012, 04:15:57 pm »
Hi Andrew.

Thanks for looking at that. Its really strange as I can see the image. All be it a very poor image but that could be the camera I have yet to full investigate this from the on-screen just not the web interface.

I thought I had added it under the motion wrapper?

It is setup as a child device of the motion wrapper template.

Regards

Your right it is a child of Motion Wrapper... my mistake ;-)

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk