Author Topic: 8.10 + SqueezeBox + Cant play audio via LMCE  (Read 1059 times)

essem_9

  • Regular Poster
  • **
  • Posts: 31
  • Fascinated by LMCE
    • View Profile
8.10 + SqueezeBox + Cant play audio via LMCE
« on: April 15, 2012, 02:54:41 am »
Just received my new squeezebox yesterday and follow the instructions on the wiki to set it up (pretty much plug and play). The core configured it as soon as the box booted up (over Ethernet). I mapped it to the kitchen. From my core on-screen orbiter, choose kitchen-->audio-->selected music. There was no audio :(. Since my audio is on the NAS, i moved over a file to /home/public/data/audio/. Still no luck.

Under the Device Tree I see Slim Server Streamer (Registered). Under that i see SqueezeBox Player (it sure is mapped to the kitchen)

Navigated to Advanced-->Configuration-->SqueezeBox Server, it only shows Loading SqueezeBox Server. Navigated to 192.168.80.1:9000 and the UI did show up. I could play music on the box from /home/public/data/audio/. In the settings-->Information tab i do see the following:
Player Model: Squeezebox Radio
Firmware: 7.6.1-r9482
Player IP Address: 192.168.80.146
Player MAC Address: xx:xx:xx:xx:xx:xx

So it seems the Squeezebox is connected and can be controlled by the server. But not sure why i cant play music via the orbiter.

ps -ef |grep Slim
shiv     17578 23303  0 17:52 pts/32   00:00:00 grep Slim
root     20349     1  0 17:16 ?        00:00:00 /usr/bin/SCREEN -d -m -S Slim_Server_Streamer130 /usr/pluto/bin/Spawn_Device.sh 130 localhost LaunchSlimServer.sh
root     20352 20349  0 17:16 pts/19   00:00:00 /bin/bash /usr/pluto/bin/Spawn_Device.sh 130 localhost LaunchSlimServer.sh
root     20419 20352  0 17:16 pts/19   00:00:00 /bin/bash /usr/pluto/bin/LaunchSlimServer.sh -d 130 -r localhost -l /var/log/pluto/130_LaunchSlimServer.sh.log
root     20424 20419  0 17:16 pts/19   00:00:00 ./Slim_Server_Streamer -d 130

Any help will be appreciated Thanks!



 

Gangsingen

  • Veteran
  • ***
  • Posts: 54
    • View Profile
Re: 8.10 + SqueezeBox + Cant play audio via LMCE
« Reply #1 on: April 15, 2012, 11:52:30 am »
I had the same problem with my 10.04 install. The CLI (Command Line Interface) should be activated and set to port 9090.

essem_9

  • Regular Poster
  • **
  • Posts: 31
  • Fascinated by LMCE
    • View Profile
Re: 8.10 + SqueezeBox + Cant play audio via LMCE
« Reply #2 on: April 15, 2012, 07:02:45 pm »
Gangsingen,
I have tried using 9090 as well as 7890 as recommended on the Wiki with no luck. However I did notice the following:

1. Navigating through Advance-->Configuration-->Squeezebox Server does not display the page. So i browsed via 192.168.80.1:9000
2. Navigated to Settings-->Plugins-->CLI
3. Here the Radio button is checked, however it is greyed out. Which means i can't enable/disable it. Is that expected?
4. I sure can click on settings and see that the port is set to 9090
But i am not sure if it is enabled since the radio button is checked but greyed out. Any thoughts?

Following is the SqueezeBox Server Info
Version: 7.6.1 - r33110 @ Wed Aug 17 18:50:10 PDT 2011
Hostname: dcerouter
Server IP Address: 192.168.2.199
Server HTTP Port Number: 9000
Operating system: Debian - C - utf8
Platform Architecture: i686-linux
Perl Version: 5.10.0 - i486-linux-gnu-thread-multi
Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
Total Players Recognized: 1

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: 8.10 + SqueezeBox + Cant play audio via LMCE
« Reply #3 on: April 17, 2012, 07:24:49 am »
I set mine up earlier tonight and have the same info as you in 1-4. with the following server info:

Version: 7.6.1 - r33110 @ Wed Aug 17 18:50:10 PDT 2011
Hostname: dcerouter
Server IP Address: xxx.xxx.xxx.xxx
Server HTTP Port Number: 9000
Operating system: Debian - C - utf8
Platform Architecture: i686-linux
Perl Version: 5.10.0 - i486-linux-gnu-thread-multi
Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
Total Players Recognized: 1

My server IP address is my external address - is this the same for you?  is 192.168.2.199 listed under webadmin network settings under the external IP Address?

if you browse to 192.168.80.1:9000 and then start something playing on the orbiter can you see it start on the server web page?  in the top right hand corner is the player name listed?

essem_9

  • Regular Poster
  • **
  • Posts: 31
  • Fascinated by LMCE
    • View Profile
Re: 8.10 + SqueezeBox + Cant play audio via LMCE
« Reply #4 on: April 17, 2012, 11:34:05 pm »
Yes, 192.168.2.199 is the external IP address of my core. I am currently traveling and will test display on the server webpage this weekend and report back. Is the setup working for you?

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: 8.10 + SqueezeBox + Cant play audio via LMCE
« Reply #5 on: April 18, 2012, 05:07:59 am »
So you know, I am using 0810

essem_9

  • Regular Poster
  • **
  • Posts: 31
  • Fascinated by LMCE
    • View Profile
Re: 8.10 + SqueezeBox + Cant play audio via LMCE - SOLVED
« Reply #6 on: April 21, 2012, 08:16:17 am »
The top right hand corner always shows "Squeezebox Radio". There is no other option in the drop down list.

I took wired traces and I can see the Slimdevice messages go by. I had deleted the device numerous times in the past. This time I deleted the device and added it to the Garage as opposed to the Kitchen. To my amazement it started to work. Not sure what was wrong setting it in the Kitchen. Probably some orbiter settings. Will probably dig a deeper later but for now I can at least enjoy some music. Thank you folks!

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 8.10 + SqueezeBox + Cant play audio via LMCE
« Reply #7 on: April 21, 2012, 08:35:30 am »
Did you already have a MD in the kitchen? Only one MD per room is allowed.

essem_9

  • Regular Poster
  • **
  • Posts: 31
  • Fascinated by LMCE
    • View Profile
Re: 8.10 + SqueezeBox + Cant play audio via LMCE
« Reply #8 on: April 21, 2012, 09:31:15 am »
I do not have any devices in the kitchen. I had first installed the squeezebox in the office. When I started to play audio, it started on my core. It made sense that only one device is allowed since Audio is a generic button. Moved it to the kitchen by deleting it numerous times. I may have goofed up some where I guess.

Intially I thought it was because of my setup with eth0 and eth0.80. Using a single interface with VLAN tagging and eth0.80 being the internal network. I added another NIC and it still did not work.

Finally moving it to garage worked. So now I am back to using one NIC with vlan tagging and alls well so far. Have rebooted the core as well as the squeezebox and it works. Thanks!

essem_9

  • Regular Poster
  • **
  • Posts: 31
  • Fascinated by LMCE
    • View Profile
SOLVED: 8.10 + SqueezeBox + Cant play audio via LMCE
« Reply #9 on: April 21, 2012, 06:48:36 pm »
posde,
After your post, I took a closer look all my devices and found the issue. Your were right. While I was testing PXE Boot of a MD, I had assigned it to the kitchen. Even though the MD was a temporary test unit and not there anymore, it was in the devices list mapped to the kitchen. That solves the mystery. Appreciate your input. Thanks!

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
[solved] Re: 8.10 + SqueezeBox + Cant play audio via LMCE
« Reply #10 on: April 21, 2012, 07:12:16 pm »
Nice! Thanks for reporting back.
« Last Edit: April 21, 2012, 07:23:59 pm by posde »