Author Topic: VDR stream issue  (Read 726 times)

pointman87

  • Veteran
  • ***
  • Posts: 108
    • View Profile
VDR stream issue
« on: March 03, 2012, 09:17:34 pm »
Hi everybody. I have a non LMCE specific problem with VDR and i can't find info anywhere so I'm trying here.

I can watch VDR for some time on my MD but after a while the stream freezes and the syslog on the MD starts to fill up with:


Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: no payload, size 0
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: no payload, size 0
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: payload not PES ?
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: no payload, size 0
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: dropping broken PES packet
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: no payload, size 0
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: last message repeated 4 times
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: payload not PES ?
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: dropping broken PES packet
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: no payload, size 0
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: no payload, size 0
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: payload not PES ?
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: dropping broken PES packet
Mar  3 20:22:53 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: no payload, size 0
Mar  3 20:22:54 moon144 vdr-sxfe[4636]: last message repeated 2 times
Mar  3 20:22:54 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: payload not PES ?
Mar  3 20:22:54 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: dropping broken PES packet
Mar  3 20:22:54 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: no payload, size 0
Mar  3 20:22:54 moon144 vdr-sxfe[4636]: last message repeated 5 times
Mar  3 20:22:54 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: payload not PES ?
Mar  3 20:22:54 moon144 vdr-sxfe[4636]: [4649] [demux_vdr] ts2es: dropping broken PES packet


It continues like that until i turn off VDR. I then have to /etc/init.d/vdr restart on the core to be able to watch again.
Is someone else experiencing the same issue with VDR?

Best regards, Daniel

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2846
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: VDR stream issue
« Reply #1 on: March 04, 2012, 05:38:47 pm »
For the record: I do not have that problem.

Do you have the same problem when you watch on the machine containing the tuner card?

pointman87

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: VDR stream issue
« Reply #2 on: March 04, 2012, 07:41:41 pm »
I have actually not tried that because my core is standing headless in a wardrobe. Im gonna connect a monitor and try. I will get back to you, thanks

BR Daniel

pointman87

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: VDR stream issue
« Reply #3 on: March 05, 2012, 06:26:09 am »
The same thing happens when I'm watching on the core itself.

BR Daniel

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2846
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: VDR stream issue
« Reply #4 on: March 05, 2012, 06:44:01 am »
Sounds like a driver or reception issue to me. Try to look at it from that direction.

pointman87

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: VDR stream issue
« Reply #5 on: March 06, 2012, 11:31:08 pm »
I have tried newest s2-liplianin to replace the kernel drivers but no difference, my card btw is a hauppauge NovaHD S2.
My reception is strong and constant, so is signal quality.
Im very thankful for more tips from all you people, sometimes another perspective can be a good solution.

BR Daniel


pointman87

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: VDR stream issue
« Reply #6 on: March 09, 2012, 07:19:21 pm »
Bumping this. Have anyone experienced this sort of VDR behavior?

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2846
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: VDR stream issue
« Reply #7 on: March 09, 2012, 08:01:37 pm »
I don't have that problem on my 1004 based LinuxMCE system with VDR, using 2x cineS2 DVB-S2 and 1x WinTV-NOVA-S, using the latest linuxtv mercurial repo. Your best bet would be to check in vdr-portal.de to see if anyone else has a clue. This is not LinuxMCE specific, but a VDR issue. I still would love to help, but I do not have that card :/