Author Topic: [SOLVED] Installation - Partitioning Issue (SATA controller mode compatibility)  (Read 1467 times)

KernyKat

  • Making baby steps
  • Posts: 3
    • View Profile
Hello!

I'm attempting to install LinuxMCE 8.10 on a new HTPC... I boot the LinuxMCE DVD using an external USB DVD drive, and choose LinuxMCE from the menu. I get as far as the "Prepare Partitions" screen, which doesn't list any hard disks or partitions.

Clicking any of the buttons (except "undo partition changes") seems to do nothing: i.e. create new partition table, create new partition, edit partition, delete partition.

If I click "undo partition changes", the cursor goes into busy mode (the two balls orbiting around each other) indefinitely.

I have a Gigabyte Z68MA-D2H-B3 motherboard with a Western Digital Caviar Green WD20EARX 2TB hard disk plugged into the first SATA port.

I was succesfully able to install Ubuntu 11.10, which detected the hard disk fine, but Kubuntu 8.10 from the same LinuxMCE DVD has the same issue (can't seem to detect the hard disk).

Any ideas?
« Last Edit: February 20, 2012, 03:17:28 am by KernyKat »

locutus

  • Veteran
  • ***
  • Posts: 88
    • View Profile
Re: Installation - Partitioning Issue
« Reply #1 on: February 19, 2012, 06:45:28 am »
I'm going to take a shot in the dark and say try a smaller hard drive. Large drives and older versions of Ubuntu don't mix well.

jill

  • Regular Poster
  • **
  • Posts: 24
    • View Profile
Re: Installation - Partitioning Issue
« Reply #2 on: February 19, 2012, 10:16:56 am »
For the price of a blank cd you can try ubuntu 11.4 and see if the disk comes up and will tell you if its too big for kubuntu to see if thats the case just pop in a small drive and install lmce on it and use the large drive for storage or use that same cd to create 2 (1tb) partitions.
btw did you try making a partition smaller then the full capacity of the HDD?
« Last Edit: February 19, 2012, 10:19:20 am by jill »

KernyKat

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Installation - Partitioning Issue
« Reply #3 on: February 19, 2012, 03:41:15 pm »
Thanks for replying!

I tried Ubuntu 11.04, and was able to see the disk as /dev/sda, so I used fdisk to partition it...
First I tried two 1TB partitions... then I tried three partitions of approximately 600-700MB each.

...still nothing showing up on the "Prepare Partitions" screen during LinuxMCE/Kbuntu install!

Is it the size of the partitions that matters or the size of the whole hard disk? And what's the limit?

If I go buy a smaller hard disk to boot LinuxMCE from... will I be able to use this 2TB hard disk as a secondary hard disk in the same machine?

jill

  • Regular Poster
  • **
  • Posts: 24
    • View Profile
Re: Installation - Partitioning Issue
« Reply #4 on: February 19, 2012, 07:06:49 pm »
 ive looked and cant find the limit for Kubuntu 8.10 but here is a thought try live booting kubuntu and see if the drive shows up that will tell you if it can see it as a second drive.

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Installation - Partitioning Issue
« Reply #5 on: February 19, 2012, 07:14:19 pm »
it is more likely a problem with the motherboard hardware, since it cannot see the drive at all. the controller just may be too new to have support in 8.10.
 you may want to try 10.04 instead.

jill

  • Regular Poster
  • **
  • Posts: 24
    • View Profile
Re: Installation - Partitioning Issue
« Reply #6 on: February 19, 2012, 07:23:30 pm »
 In your Bios see if you have a option called (Boot mode) or something like that try the other options should be Bios, MBR, and UEIF

JaseP

  • Addicted
  • *
  • Posts: 526
    • View Profile
    • JaseP's LinuxMCE Wiki User page
Re: Installation - Partitioning Issue
« Reply #7 on: February 19, 2012, 11:47:46 pm »
I've had problems with 8.10 before (not LinuxMCE, but other uses). It has issues with certain disk controllers, particularly PATA and newer SATA drive controllers. I concur that you should try 1004... It was one of the reasons I abandoned LinuxMCE a few years ago.

I'm going to be starting, my 1004 install tonight... I just wanted to back up my Samba conf file first, Just in case.
See my User page on the LinuxMCE Wiki for a description of my system configuration (click the little globe under my profile pic).

KernyKat

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Installation - Partitioning Issue
« Reply #8 on: February 20, 2012, 03:15:49 am »
In the BIOS settings, I found a few mysterious options, apparently features of the Intel Z68 Chipset:

PCH SATA Control Mode = Can choose from:
  • IDE ... Disables RAID for the SATA controllers and configures the SATA controllers to IDE mode
  • RAID(XHD) ... Enables RAID using Gigabyte's "eXtreme Hard Drive" utility.
  • ACHI ... Configures the SATA controllers to Advanced Host Controller Interface (AHCI) mode. Allwes the storage driver to enable advanced Serial ATA features such as Native Command Queueing and hot plug.

SATA Port0-3 Native Mode = Can choose from:
  • Disabled ... (Legacy IDE mode) In Legacy mode the SATA controllers use dedicated IRQs that cannot be shared with other device. Set this option to Disabled if you wish to install operating systems that do not support Native mode.
  • Enabled ... (Native IDE mode) Enable Native IDE mode if you wish to install operating systems that support Native mode. (Default)

The default was set as:
  • PCH SATA Control Mode = IDE
  • SATA Port0-3 Native Mode = Enabled (Native IDE mode)


Since you guys seem to be talking about compatibility issues with newer stuff, I tried:
  • PCH SATA Control Mode = IDE
  • SATA Port0-3 Native Mode = Disabled (Legacy IDE mode)

That seemed to be the most non-cutting-edge mode :-) But no luck with LinuxMCE 810 in this mode.

Meanwhile, i've always thought it strange that my hard disk showed up in the BIOS listed under "IDE Channel 0 Primary Master" when the hard disk is SATA, not IDE. I guess it must be some sort of bridged mode, and since it's the default BIOS setting, I assumed it's fairly standard to bridge SATA to IDE this way (?).

So I tried:

  • PCH SATA Control Mode = AHCI
  • SATA Port0-3 Native Mode = Disabled (Legacy IDE mode)


With this mode, I noticed the hard disk no longer appears as detected within the BIOS setup menu (the IDE list), however... during the normal boot sequence, there's an additional screen that pops up after POST, titled "AHCI Bios efi" which appears to detect the hard disk there. Albiet with a warning that "this version recognises Hard Disk and CDROMS only" (Not sure what else I'd be plugging into the SATA ports anyway?!). Oh well...

Anyway, I went onto the LinuxMCE installation, and lo-and-behold, it recognises the hard disk!!!! Huzzah!

For completeness's sake, I also tried:

  • PCH SATA Control Mode = AHCI
  • SATA Port0-3 Native Mode = Enabled (Native IDE mode)

And this also works in LinuxMCE!

So "PCH SATA Control Mode = IDE" was the cause of my problem...

jill

  • Regular Poster
  • **
  • Posts: 24
    • View Profile
it was the changeing to AHCI glad you got it working ^_^ (Advanced Host Controller Interface)
« Last Edit: February 22, 2012, 06:06:33 am by jill »

jamo

  • Guru
  • ****
  • Posts: 457
    • View Profile
    • LMCE user Page
I had very similar experience - see my thread:

http://forum.linuxmce.org/index.php/topic,12315.0.html

However, my solution ended up being to swap a smaller disk in (320Gb) and use my 2Tb disk in my desktop. Install went through a breeze thereafter.

I also thought it was solved until I got to the partitioning part and still wasn't able to create partitions or even see the drive. I knew it wasn't a hardward thing because Fedora installed without a hitch.

If you do some web searches on Kubunti 8.10 and harddrive size you will find many with similar issues- in fact, if you try installing just kubuntu 8.10 plain you'll find the same problem.

I figured I'd just pop a couple of extra 500Gb drives in if I wanted more space on my core, otherwise go for a NAS if media gets out of hand.

JaseP

  • Addicted
  • *
  • Posts: 526
    • View Profile
    • JaseP's LinuxMCE Wiki User page
You can try using gparted to partition the larger drives down to smaller volume sizes. However, if you are not using a recent version of Linux, you may want to burn yourself a Gparted Live disk in order to partition the drive(s). Just be sure you know what drove is what, so you don't accidently re-partition your system drive. Some external drives (such as larger Western Digital drives) use partition schemes that are not compatible with Linux (and/or some sort of internal controller). For external drives, I recommend Seagate drives,... they are re-partitioning friendly and generally cheaper, though not generally as visibly attractive).

You can find Gparted Live here:
http://sourceforge.net/projects/gparted/files/gparted-live-stable/
See my User page on the LinuxMCE Wiki for a description of my system configuration (click the little globe under my profile pic).

seth

  • Guru
  • ****
  • Posts: 485
  • A day w/o LinuxMCE is like a day w/o sunshine!
    • View Profile
It could be that the 11.4 Live Disk partitioned the hard drive using ext4. Perhaps there is some incompatibility there. You could try running the 11.4 disk again, this time choosing to create the partitions using the ext3 file system.

If you have already done this. Please ignore this post.   ;)

Best regards,

Seth
".....Because Once you've LinuxMCE'd....."
System stats located at my user page:

http://wiki.linuxmce.org/index.php/User:Seth