Author Topic: Upgrade failing in 10.04  (Read 603 times)

m3freak

  • Veteran
  • ***
  • Posts: 125
    • View Profile
Upgrade failing in 10.04
« on: February 06, 2012, 12:18:51 am »
I tried updating my 10.04 install, but it's failing with this error (snippet):

Code: [Select]
Bareword found where operator expected at /usr/pluto/bin/update2utf8.pl line 6, near "// We"
(Missing operator before We?)
syntax error at /usr/pluto/bin/update2utf8.pl line 6, near "// We try "
Execution of /usr/pluto/bin/update2utf8.pl aborted due to compilation errors.
dpkg: error processing pluto-system-database (--configure):
 subprocess installed post-installation script returned error exit status 255
dpkg: dependency problems prevent configuration of pluto-std-plugins:
 pluto-std-plugins depends on pluto-system-database (>= 2.0.0.45); however:
  Package pluto-system-database is not configured yet.
 pluto-std-plugins depends on pluto-system-database (<< 2.0.0.46); however:
  Package pluto-system-database is not configured yet.
dpkg: error processing pluto-std-plugins (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pluto-dcerouter:
 pluto-dcerouter depends on pluto-std-plugins (>= 2.0.0.45); however:
  Package pluto-std-plugins is not configured yet.
 pluto-dcerouter depends on pluto-std-plugins (<< 2.0.0.46); however:
  Package pluto-std-plugins is not configured yet.
 pluto-dcerouter depends on pluto-system-database (>= 2.0.0.45); however:
  Package pluto-system-database is not configured yet.
 pluto-dcerouter depends on pluto-system-database (<< 2.0.0.46); however:
  Package pluto-system-database is not configured yet.
dpkg: erNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                  No apport report written because the error message indicates its a followup error from a previous failure.
              ror processing pluto-dcerouter (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pluto-system-database
 pluto-std-plugins
 pluto-dcerouter
E: Sub-process /usr/bin/dpkg returned an error code (1)

I ran 'apt-get upgrade' a couple of times - same result.  Any ideas on how I could fix this?

m3freak

  • Veteran
  • ***
  • Posts: 125
    • View Profile
Re: Upgrade failing in 10.04
« Reply #1 on: February 06, 2012, 12:34:04 am »
SOLVED

Fixed the problem by putting a hash in front of line 6 in /usr/pluto/bin/update2utf8.pl.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2984
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Upgrade failing in 10.04
« Reply #2 on: February 06, 2012, 10:54:12 am »
Problem is fixed in the next release. Sorry for the problem.

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: Upgrade failing in 10.04
« Reply #3 on: February 06, 2012, 04:21:38 pm »
I did an update and upgrade, and no problems.