Author Topic: update media runs alot and zaps cpu  (Read 587 times)

kyfalcon

  • Guru
  • ****
  • Posts: 390
    • View Profile
update media runs alot and zaps cpu
« on: February 22, 2012, 01:58:06 am »
My update media runs way too much and graps most of the cpu. Brings the system to a crawl

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: update media runs alot and zaps cpu
« Reply #1 on: February 22, 2012, 05:27:29 am »
How is your IOWait percentage in TOP during UpdateMedia's run?

-Thom

kyfalcon

  • Guru
  • ****
  • Posts: 390
    • View Profile
Re: update media runs alot and zaps cpu
« Reply #2 on: February 22, 2012, 04:02:58 pm »
i'll have to check tonight

kyfalcon

  • Guru
  • ****
  • Posts: 390
    • View Profile
Re: update media runs alot and zaps cpu
« Reply #3 on: February 23, 2012, 12:43:46 am »

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                                   
 4248 root      39  19 93256  32m 2508 S   73  1.6 864:22.47 UpdateMedia                                                                                               
26960 root      20   0 74728 4400 1928 S    5  0.2  67:57.13 Generic_Serial_                                                                                           
26817 kevin     20   0  265m  60m  25m S    2  3.0   0:07.85 firefox-bin                                                                                               
272

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: update media runs alot and zaps cpu
« Reply #4 on: February 23, 2012, 01:11:12 am »
No, i need the iowait (% wa) at the top.

-Thom

kyfalcon

  • Guru
  • ****
  • Posts: 390
    • View Profile
Re: update media runs alot and zaps cpu
« Reply #5 on: February 23, 2012, 02:45:32 am »
kevin@dcerouter:~$ top -p 4248
top - 20:44:49 up 1 day,  2:05,  1 user,  load average: 1.33, 1.38, 1.42
Tasks:   1 total,   0 running,   1 sleeping,   0 stopped,   0 zombie
Cpu(s):  2.8%us, 13.4%sy, 28.6%ni, 48.9%id,  5.3%wa,  0.3%hi,  0.7%si,  0.0%st
Mem:   2060140k total,  1736560k used,   323580k free,   148960k buffers
Swap: 14194700k total,    35588k used, 14159112k free,   768060k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                                    
 4248 root      39  19 93332  32m 2508 S   74  1.6 943:30.01 UpdateMedia                                                                                                
943 minutes seems awfully long









tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: update media runs alot and zaps cpu
« Reply #6 on: February 23, 2012, 02:49:08 am »
Your iowait is still below 10% which, while it isn't waiting on I/O, it's still nominal..it's okay.

-Thom

kyfalcon

  • Guru
  • ****
  • Posts: 390
    • View Profile
Re: update media runs alot and zaps cpu
« Reply #7 on: February 23, 2012, 02:52:51 am »
what about the cpu that high for that many minutes

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: update media runs alot and zaps cpu
« Reply #8 on: February 23, 2012, 02:54:52 am »
no. UpdateMedia is very active, and once it finishes a run, it pauses for two minutes before it starts another run.

-Thom