Author Topic: SOLVED | 1004 | Cannot upgrade core  (Read 1202 times)

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
SOLVED | 1004 | Cannot upgrade core
« on: January 22, 2012, 10:39:50 am »
Code: [Select]
dcerouter_1018133:/usr/pluto/bin# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  asterisk linux-generic linux-headers-generic linux-image-generic pluto-mythtv-player
The following packages will be upgraded:
  libpq5 libt1-5 libxine2 libxml2 libxml2-utils pluto-dcerouter pluto-mplayer-player python-lazr.restfulclient xine-ui
9 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
1 not fully installed or removed.
Need to get 0B/6,825kB of archives.
After this operation, 406kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  pluto-dcerouter pluto-mplayer-player libxml2 libpq5 libt1-5 libxine2 libxml2-utils python-lazr.restfulclient xine-ui
Authentication warning overridden.
Setting up radvd (1:1.3-1.1ubuntu0.1) ...
Starting radvd: [Jan 22 10:39:38] radvd: syntax error in /etc/radvd.conf, line 2:
[Jan 22 10:39:38] radvd: error parsing or activating the config file: /etc/radvd.conf
failed.
invoke-rc.d: initscript radvd, action "start" failed.
dpkg: error processing radvd (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 radvd
E: Sub-process /usr/bin/dpkg returned an error code (1)
dcerouter_1018133:/usr/pluto/bin#

Is there something wrong with my sources.list? Or is there a bug? I also have problems creating diskless image, maybe related?
http://forum.linuxmce.org/index.php/topic,12330.0.html
« Last Edit: February 09, 2012, 08:18:18 am by bongowongo »

Murdock

  • Guru
  • ****
  • Posts: 229
    • View Profile
Re: 1004 | Cannot upgrade core
« Reply #1 on: January 23, 2012, 01:52:01 am »
I haven't looked too deep into it for a permenant fix yet, though that has come up on my system twice and it has to do with ipv6 comparability.

Is there a ticket open on this?

A basic workaround/config that will allow radvd.conf to continue is:

Code: [Select]
interface eth0 {
        AdvSendAdvert on;
        MinRtrAdvInterval 3;
        MaxRtrAdvInterval 10;
        prefix 2001:0db8:0100:f101::/64 {
                AdvOnLink on;
                AdvAutonomous on;
                AdvRouterAddr on;
        };
};

So if you place that into the file /etc/radvd.conf - re-run apt-get upgrade it will conclude.

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: 1004 | Cannot upgrade core
« Reply #2 on: January 23, 2012, 08:49:22 am »
I haven't looked too deep into it for a permenant fix yet, though that has come up on my system twice and it has to do with ipv6 comparability.

Is there a ticket open on this?

A basic workaround/config that will allow radvd.conf to continue is:

Code: [Select]
interface eth0 {
        AdvSendAdvert on;
        MinRtrAdvInterval 3;
        MaxRtrAdvInterval 10;
        prefix 2001:0db8:0100:f101::/64 {
                AdvOnLink on;
                AdvAutonomous on;
                AdvRouterAddr on;
        };
};

So if you place that into the file /etc/radvd.conf - re-run apt-get upgrade it will conclude.

thanks that did the trick, I will make a ticket and post your solution.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3012
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 1004 | Cannot upgrade core
« Reply #3 on: January 23, 2012, 10:39:25 am »
The problem is, that somewhere a blank conf file comes from. Easiest is, to delete said file.

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: 1004 | Cannot upgrade core
« Reply #4 on: January 23, 2012, 10:50:17 am »
The problem is, that somewhere a blank conf file comes from. Easiest is, to delete said file.

Yes the file was blank, still a bug though?

Tred

  • Veteran
  • ***
  • Posts: 68
    • View Profile
Re: 1004 | Cannot upgrade core
« Reply #5 on: February 09, 2012, 04:05:07 am »
Does this configuration assume that the core's lan port is eth0 and wan is eth1?
« Last Edit: February 09, 2012, 07:04:29 pm by Tred »

Foxi352

  • Veteran
  • ***
  • Posts: 52
    • View Profile
Re: SOLVED | 1004 | Cannot upgrade core
« Reply #6 on: February 28, 2012, 08:09:09 pm »
Issue has been fixed in 10.04 long time ago, and in 0810 some weeks ago. After update / upgrade it should be ok.

Workaround is to simply delete /etc/radvd.conf