Author Topic: Improving network proformance  (Read 1686 times)

tux-box1

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Re: Improving network proformance
« Reply #15 on: January 20, 2012, 05:26:28 pm »
I'm not using my lmce box as a router at the moment. So my eth0 is both WAN and LAN for now. Ill do a reboot and do some more tests this weekend when I have the time.
As for the actual lay out of the etwork . My cable modem feeds my wireless router that has DD-wrt on it so I can do reserved dhcp leases to an VMware esxi server easier than static IPs. This is also so when I have friends over they. Have internet without access to my media. If once supports reserved dhcp ill be glad to make some changes.

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
Re: Improving network proformance
« Reply #16 on: January 20, 2012, 06:17:06 pm »
I'm not using my lmce box as a router at the moment. So my eth0 is both WAN and LAN for now. Ill do a reboot and do some more tests this weekend when I have the time.
As for the actual lay out of the etwork . My cable modem feeds my wireless router that has DD-wrt on it so I can do reserved dhcp leases to an VMware esxi server easier than static IPs. This is also so when I have friends over they. Have internet without access to my media. If once supports reserved dhcp ill be glad to make some changes.

I'm pretty sure the lease time in LMCE is such that the IP addresses to clients don't change.  I'm very certain I read that some where... maybe Thom said it.. don't quote me on who said it.

It would be great if you had a drawing of your network.  I'd like to think you can set this up a little more straight forward and efficient than it is, at least based on what it sounds like you're doing.  DD-WRT supports virtual ssids and vlans so right there you have a better network design that adheres to the supported LMCE network configuration.

tux-box1

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Re: Improving network proformance
« Reply #17 on: January 20, 2012, 08:12:10 pm »
Here's a dirty picture of the network lay out.
https://docs.google.com/drawings/d/16q2MupQs-oDVCizGwLtPblzh-kNESZ4_quzM27EaPrI/edit


I've recently changed it to
https://docs.google.com/drawings/d/1gNgYkh1P3Z7oS3F4_GzH5cGhrgQlPRtHePEbno-NHNk/edit

I moved to the second image to see if eth0 was the problem due to the amount of dropped packets.
My nest test I'm removing the wireless router completely. I don't think its the problem but.for through testing.
« Last Edit: January 20, 2012, 08:37:53 pm by tux-box1 »

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
Re: Improving network proformance
« Reply #18 on: January 20, 2012, 09:18:41 pm »
Here's a dirty picture of the network lay out.
https://docs.google.com/drawings/d/16q2MupQs-oDVCizGwLtPblzh-kNESZ4_quzM27EaPrI/edit


I've recently changed it to
https://docs.google.com/drawings/d/1gNgYkh1P3Z7oS3F4_GzH5cGhrgQlPRtHePEbno-NHNk/edit

I moved to the second image to see if eth0 was the problem due to the amount of dropped packets.
My nest test I'm removing the wireless router completely. I don't think its the problem but.for through testing.


Just curious, In the first diagram did you have the external and internal nics connected to the GB switch or was the internal nic for Lmce left unused or not even installed?

Does anyone know if the firewall in linuxmce will cause the dropped packets amount reported using ifconfig to go up as it drops undefined connection attempts?  I'm guessing no but i've never used the lmce firewall.  Either way you need to figure out why your dropped packets count is so high.  Have you tried swapping the nics on the core?  I think someone suggested that earlier.  Are you conducting these test from the wireless or the PC?  Have you tried using different ports on the switch?  You never indicated the make, model or condition of your switch but i've seen a similair situation before and it turned out to be a bad port on the switch. 


tux-box1

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Re: Improving network proformance
« Reply #19 on: January 20, 2012, 10:12:50 pm »
On of the reasons I'm reluctant to give out more information than what is required. No I'm not doing this over wireless, no I'm not plugging both NICs of the lmce box into the switch. I went so far as to completely disable the ip4 and 6 firewalls. Ran watch ipconfig and the dropped packets were still cranking.
« Last Edit: January 21, 2012, 03:45:07 am by tux-box1 »

tux-box1

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Re: Improving network proformance
« Reply #20 on: January 21, 2012, 05:44:27 am »
I ran some IPERF tests using setup of network 2
Code: [Select]
[  4] local 192.168.80.1 port 5001 connected with 192.168.80.129 port 51904
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec    363 MBytes    304 Mbits/sec
[  5] local 192.168.80.1 port 5001 connected with 192.168.80.129 port 51922
[  5]  0.0-10.0 sec    374 MBytes    314 Mbits/sec
[  4] local 192.168.80.1 port 5001 connected with 192.168.80.129 port 51932
[  4]  0.0-10.0 sec    200 MBytes    167 Mbits/sec   <---- This is because I was coping a file at the time. So ignore it
[  5] local 192.168.80.1 port 5001 connected with 192.168.80.129 port 51941
[  5]  0.0-10.0 sec    370 MBytes    310 Mbits/sec
[  4] local 192.168.80.1 port 5001 connected with 192.168.80.129 port 51953
[  4]  0.0-10.0 sec    370 MBytes    310 Mbits/sec
[  5] local 192.168.80.1 port 5001 connected with 192.168.80.129 port 51954
[  5]  0.0-10.0 sec    374 MBytes    314 Mbits/sec
[  4] local 192.168.80.1 port 5001 connected with 192.168.80.129 port 51958
[  4]  0.0-10.0 sec    360 MBytes    302 Mbits/sec
[  5] local 192.168.80.1 port 5001 connected with 192.168.80.129 port 51959
[  5]  0.0-10.0 sec    371 MBytes    311 Mbits/sec