Author Topic: ZBox ID41 libdvdcss issue  (Read 805 times)

bushtech

  • Veteran
  • ***
  • Posts: 97
    • View Profile
ZBox ID41 libdvdcss issue
« on: January 11, 2012, 11:44:55 am »
Running 0810 RC. Ran diskless setup and plugged Zbox in. Installed perfectly and ran after a reboot of the md. However when I tried to play DVD’s off the core I get a message on the md’s screen stating that libdvdcss is required.

Ssh into the md and running “sudo apt-get install lidvdcss wcodecs32” gives me this error:

“Package libdvdcss is not available but is referred to by another package
This may mean that the package is missing, has been obsoleted, or is
Only available from another source
E: package libdvdcss has no installation candidate”  ???

Can somebody please tell me if I’m doing something stupid/wrong or how to sort this out.

Please keep in mind that I’m not a linux expert.

Thanks
Core:Asus P8H77-V, Intel core i3-3240 LGA155, Inno 3D Nvidia 240 GT (DVI+VGA+HDMI), 4Gb ram, 125Gb SSD
MD: Zotax Zbox ID41

Dan249

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: ZBox ID41 libdvdcss issue
« Reply #1 on: January 11, 2012, 04:18:07 pm »
Bushtech,
 
Did you use libdvdcss2 in the install command? If not try that!

Dan
 

bushtech

  • Veteran
  • ***
  • Posts: 97
    • View Profile
Re: ZBox ID41 libdvdcss issue
« Reply #2 on: January 11, 2012, 04:33:29 pm »
Dan

Tried css, css2 & css3.
Same result for all

Thanks
Core:Asus P8H77-V, Intel core i3-3240 LGA155, Inno 3D Nvidia 240 GT (DVI+VGA+HDMI), 4Gb ram, 125Gb SSD
MD: Zotax Zbox ID41

bushtech

  • Veteran
  • ***
  • Posts: 97
    • View Profile
Re: ZBox ID41 libdvdcss issue
« Reply #3 on: January 11, 2012, 04:54:30 pm »
Correction.

css3 replies: package not found
Core:Asus P8H77-V, Intel core i3-3240 LGA155, Inno 3D Nvidia 240 GT (DVI+VGA+HDMI), 4Gb ram, 125Gb SSD
MD: Zotax Zbox ID41

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: ZBox ID41 libdvdcss issue
« Reply #4 on: January 11, 2012, 07:23:05 pm »
It is libdvdcss2 and w32codecs.

Find your moon number, and log into it.
Code: [Select]
sudo su
ls /usr/pluto/diskless
ssh moonXX
Where XX is your moon number.
Code: [Select]
apt-get update
apt-get install libdvdcss2
apt-get install w32codecs
If you cannot get them make sure that you have the medibuntu source in your repo list (ls /etc/apt/sources.list).
Confirm that your repos are like in the installing linuxmce 810 wiki. If you have to add them then make sure you apt-get update again before trying to get the packages again.
I never quit... I just ping out.

bushtech

  • Veteran
  • ***
  • Posts: 97
    • View Profile
Re: ZBox ID41 libdvdcss issue
« Reply #5 on: January 12, 2012, 07:22:44 pm »
OK, working now ;D

So big thank you to l3mce.

Not to sure how or when I did the right thing that started it working. Lots of updates, installed the medibuntu keyring, added medibuntu to sources.list, left the repo's alone as 0810 RC's repo's are different from the wiki one, RC looks like a later version. Then suddenly at another attempt at installing the packages it started downloading the packages and we were sweet.

Curios, though, the sources.list on my md and the sources.list on the Core are now different (medibuntu) but the Core has always been able to play DVD's.

A question: during the installation of w32codecs I got a " Suggested packages: gstreamer 0.10-pitfdll"
Should I install this?

Thanks again l3mce

Much appreciated
Core:Asus P8H77-V, Intel core i3-3240 LGA155, Inno 3D Nvidia 240 GT (DVI+VGA+HDMI), 4Gb ram, 125Gb SSD
MD: Zotax Zbox ID41

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: ZBox ID41 libdvdcss issue
« Reply #6 on: January 12, 2012, 07:56:44 pm »
We aren't using gstreamer yet.

Your MD sources.list is daughtered from your cores at the time you run Diskless_CreateTBZ.sh, so any changes after that time are not reflected... so is the software list. It seems like your Diskless_CreateTBZ.sh was run before the system was done with its install. If you install everything you want on your core, and run diskless again, it should all be available to the future MDs you create.
I never quit... I just ping out.