Author Topic: wii remove cursor hover wrong menu item  (Read 958 times)

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
wii remove cursor hover wrong menu item
« on: January 10, 2012, 11:24:59 pm »
Hello,

my Wii Mote works pretty good on 1004.
When i hover a menu item some other (random) menu item is marked as hoverd (red outline) and sometimes jumping around.

see the video its better than my description  :-)
http://dokuwiki.knallimall.org/linuxmce_macmini4_1?&#cursor_menu_issue

i followed the instructions here: http://wiki.linuxmce.org/index.php/Nintendo_WiiMote


Is there a way to fix this issue?


Thanks in advance

Cheers,
« Last Edit: January 10, 2012, 11:32:17 pm by polly »

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: wii remove cursor hover wrong menu item
« Reply #1 on: March 14, 2012, 10:29:21 pm »
The Problem was caused by the auto-installed Gamepad.

Solution for 1004:
1. Delete all Gamepad Devices from your device tree
2. Edit /usr/pluto/bin/Gamepad_Detect.sh and add  a "exit 0" (insert it before "done")
Code: [Select]
...
sleep 5

### FIX FOR GAMEPAD
exit 0

done

3. reboot


Thanks to tschak for the solution/wokraround


phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1004
    • View Profile
Re: wii remove cursor hover wrong menu item
« Reply #2 on: March 15, 2012, 09:42:28 pm »
Any chance of you adding that to the wiki for future users?

J.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: wii remove cursor hover wrong menu item
« Reply #3 on: March 19, 2012, 10:36:24 pm »
I need someone to look at the USB_Game_Pad code and seeing if we can make a sane fix for this.

-Thom

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: wii remove cursor hover wrong menu item
« Reply #4 on: March 20, 2012, 09:55:12 am »
i'll add it to the wiki. But not now...

actually i'm not good at coding.... but I'll have a look.