Author Topic: Main Program Terminates on Install (Assume Kernel Problem)  (Read 1344 times)

okfineimanewbie

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Scottdale Salvage
Main Program Terminates on Install (Assume Kernel Problem)
« on: January 08, 2012, 12:13:45 am »
I normally don't feel like a super noob but I guess that was before I tried to make a LMCE install happen.  When trying to install LMCE the first time I got:
int:rc-default main process (5220) terminated with status 255.

Above was a string of int unable to execute errors because of permission denied in (bin/sh) and a few segfaults for seasoning.

I thought that was odd and checked the integrity of the DVD on two machines, both came up clean.  Memory check on the install machine (more on that including components later).

Tried the kubuntu install and got the same error but with a different line number (5058) and in etc/initd and it was "not found" instead of "permission denied."

Then I tried installing with quite and splash cleared and noted every "udeed-event run program [blahblah] failed"

Have XP on the HD (planned to wipe it in install if I get that far), went in and added the kubuntu grub menu, and on restart/install was only able to make it to busybox.
I assume I've got to change around the kernal parameters, but I've never done that, and couldn't find something that seemed appropriate to walk me through.

Anything would be helpful.  System info:
[inherited Frankenstein that will correctly and fully run xp and ubuntu]
Intel i945P/G chip set [dual core 2.86GHz
MOBO: Intel D945GTP ver. AAC97834-301
Integrated video: Intel 82945G Express **more on this below
PCI-e Video Card: Nvidia GeForce 96000GT
Lite-On DVDRW SHW-160PGS
HD: Seagate Barracuda ST3160812AS [SATA]
Network Card 1: Integrated Intel Pro/100 VE 
Network Card 2: linksys WMP110 Range Plus [PCI slot 1]
BCM v0.90 56K modem [PCI slot 2]

I have one monitor plugged into the integrated and another in the GeForce.

***Further interesting problem:
The BIOS has video settings that can be set:
Auto (chooses the PCI Express GeForce)
Integrated
PCI-E
Or PCI (which doesn't have a graphics card in it)

I can not get the machine to boot to the LMCE DVD if the integrated chip is chosen, it will always go to the HD, even if it's below the DVD in the boot order.  No problem with this on Auto or PCI-E.  I'm not sure if this has something to do with the problem, but I'm going to keep playing around with it (unplug the HD, take out the cards, etc).

My goal is to ram through the install tonight, so if anyone can help me tonight I'd be doubly thankful.
Everything tastes better when you slice it with a plasma cutter.

okfineimanewbie

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Scottdale Salvage
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #1 on: January 08, 2012, 02:08:09 am »
Short update, can't get LMCE dvd to boot w/o Geforce installed and selected under any circumstance.  Was able to boot Ubuntu...?
Everything tastes better when you slice it with a plasma cutter.

okfineimanewbie

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Scottdale Salvage
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #2 on: January 08, 2012, 04:08:42 am »
I assume this is not worth a bug report (trac ticket).  Was able to do a full install from that DVD on a laptop (which sadly I don't want to have LMCE on).  Not able to load live cd to "try" kunbuntu.  Had same errors as before.
Everything tastes better when you slice it with a plasma cutter.

Kezza

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #3 on: January 08, 2012, 06:44:04 am »
Sounds like your trying 8.10?

I'd give 10.04 a go as it has better hardware support so might have better luck

http://wiki.linuxmce.org/index.php/Installing_1004

I've just installed it with pretty smooth install although I cannot get video wizard to come up so running default video/audio settings.

okfineimanewbie

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Scottdale Salvage
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #4 on: January 09, 2012, 04:15:30 am »
Thanks for that.  I was trying to use 8.10 (mostly because I want this to be a box that works simply so my none tech wife can use it...and not end up coming home to Roku...no offense to Roku users).  Alright now I'm trying 10.04.  It brought up a corrupted low memory error.  I think it's wrong because the memory test passes and I tried throwing a new stick in.  Could the MoBo be bad?  I've heard of this problem happening to others and I'll see if I can find a good work around.  If anyone knows one quick off hand I'd appreciated it.

Thanks.
Everything tastes better when you slice it with a plasma cutter.

okfineimanewbie

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Scottdale Salvage
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #5 on: January 09, 2012, 05:08:49 am »
Changing memory_corruption_check_size=64k all the way up to 512k didn't help.  still getting low memory corruption.  Maybe it's one of the cards.  So help me I might rebuild this whole thing if I can't figure it out.  I've dropped all the other cards out except the video card just FYI.

And I still can't boot from dvd with the integrated graphics card selected (or the Geforce taken out)...I can't help but feel that's related.  I would post the trace but I can't seem to get to busybox/anything/have anywhere mounted for a log...ideas?

Thanks again.
« Last Edit: January 09, 2012, 05:29:57 am by okfineimanewbie »
Everything tastes better when you slice it with a plasma cutter.

Kezza

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #6 on: January 09, 2012, 10:10:43 pm »
Since the DVD works on another machine and 2 versions of kubuntu not working I'm guessing hardware is the issue.

Have you tried booting a windows CD? Not a faulty DVD drive by chance?


DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #7 on: January 10, 2012, 07:04:34 am »
1. Try new, different memory. If you have two memory modules installed take one out and only use one at a time.
 Alternating memory modules and slots. I have found that a memory slot could be faulty to.

2. boot the pc without the Harddrive connected. How far do you get then?

3. If posible try swapping the CPU.

Karel

okfineimanewbie

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Scottdale Salvage
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #8 on: January 10, 2012, 02:41:40 pm »
Kezza:  I can do you one better, I've booted an Ocelot DVD and Hiren's Boot.  Tonight I will delve deep into hardware checks.  At this point all I can think of is the L1 or L2 cache, but then again wouldn't that screw everything.

DragonK:  Already tried everything but the CPU.  I'm going to try and get my hands on another one today (don't think I'll have a problem).

I'm still puzzled as to why Kubuntu won't boot the integrated video card.  If I have the Geforce out and the HDD unplugged then it comes with a "no bootable media found" error.  With the Geforce in and the HDD unplugged it will of course boot (but I'm trying to install so that's a bit pointless).  I'll see what I can find from Hiren's and try to swap out the CPU.  If anyone has other ideas I'm all ears.

Edit: I'm now wondering about the MGCH b/c of the GeForce problem.  I will try to change out the MOBO if the CPU doesn't change anything.  I've got Ocelot installed the HDD.  Would have thought I'd run into the same problem.
« Last Edit: January 10, 2012, 04:19:06 pm by okfineimanewbie »
Everything tastes better when you slice it with a plasma cutter.

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #9 on: January 11, 2012, 07:00:34 am »
Have you tried a different DVD drive too? On the pc thats giving the prob?

okfineimanewbie

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Scottdale Salvage
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #10 on: January 12, 2012, 05:08:39 pm »
I haven't.  I was doing a memory checks and every time I tried to test the L1 cash the test hangs (can't even get a segfault out, total lock up).  Thus it my current assumption that there must be some problem with the CPU.  That said, I find my self confused that I was able to get Ubuntu 11.10 installed.  I hopefully will have time to change out the CPU tonight.
Everything tastes better when you slice it with a plasma cutter.

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #11 on: January 13, 2012, 05:07:05 pm »
Well..... you might be heading in the right direction.....

One of our office ladies pc is running OpenSuse 11.0. From Yesterday it randomly freezes and boots halfway with various errors.
Segfaults or Kernel errors. After swapping memory still no luck. Sometimes boot further than others. Then after I replaced the CPU, it Worked.
Even when putting the old memory back. In the end I only replaced the cpu and it was working again.
BUT.... when I put the faulty CPu in a Windows XP pc..... The XP booted fine. And is still working.....


Karel

okfineimanewbie

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Scottdale Salvage
Re: Main Program Terminates on Install (Assume Kernel Problem)
« Reply #12 on: January 19, 2012, 08:56:59 pm »
Ok new MoBo fixed it but I'm officially trashing the system, and will build another one.  I currently have LME installed on my gamer (which I like to leave Windows, go ahead and groan but it's still easier for real gaming [based on content]), and I think I'm getting everything worked out.  I realize the difficulty with Radeon cards, and will open lines accordingly (it's off the 990FX chipset with a FX 8120 so I want it back hogging out games in windows).

So I think this is closed with the problem being the MoBo.  It's a cool trick, however, that windows never failed under these conditions.  Like to figure that one out too.
Everything tastes better when you slice it with a plasma cutter.