Author Topic: Installation of 8.10 fails to detect harddrive  (Read 1399 times)


  • First post!
  • Posts: 1
    • View Profile
Installation of 8.10 fails to detect harddrive
« on: January 07, 2012, 04:22:20 pm »
Hi forum,

I tried to install LinuxMCE 8.10. I burned the iso-dvd and when it comes to create partitions I don't see any harddrives.

Then I tried to create partitions via gparted-Live CD. That worked and I could create the partitions.

Then I tried to get back to the installation but I still see no harddisk. I ran the Kubuntu edition and tried to get information about the harddrives:

Code: [Select]
root@ubuntu:~# lshw -C disk -C storage                                         
       description: IDE interface                                                                                                           
       product: M5229 IDE                                                                                                                   
       vendor: ALi Corporation                                                                                                             
       physical id: 1f                                                                                                                             
       bus info: pci@0000:00:1f.0                                                                                                                 
       logical name: scsi4                                                                                                                         
       version: c7                                                                                                                                 
       width: 32 bits                                                                                                                             
       clock: 66MHz                                                                                                                               
       capabilities: ide bus_master emulated                                                                                                       
       configuration: driver=pata_ali latency=32 module=pata_ali                                                                                   
          description: DVD writer
          product: DVD DD DW1640
          vendor: BENQ
          physical id: 0.0.0
          bus info: scsi@4:0.0.0
          logical name: /dev/cdrom
          logical name: /dev/cdrw
          logical name: /dev/dvd
          logical name: /dev/dvdrw
          logical name: /dev/scd0
          logical name: /dev/sr0
          logical name: /cdrom
          version: BSLB
          capabilities: removable audio cd-r cd-rw dvd dvd-r
          configuration: ansiversion=5 mount.fstype=iso9660 mount.options=ro,noatime state=mounted status=ready
             physical id: 0
             logical name: /dev/cdrom
             logical name: /cdrom
             configuration: mount.fstype=iso9660 mount.options=ro,noatime state=mounted
       description: RAID bus controller
       product: ULi 5287 SATA
       vendor: ALi Corporation
       physical id: 1f.1
       bus info: pci@0000:00:1f.1
       logical name: scsi0
       version: 02
       width: 32 bits
       clock: 66MHz
       capabilities: storage pm bus_master cap_list emulated
       configuration: driver=sata_uli latency=128 module=sata_uli
          description: ATA Disk
          product: ST2000DL003-9VT1
          vendor: Seagate
          physical id: 0.0.0
          bus info: scsi@0:0.0.0
          logical name: /dev/sda
          version: CC3C
          serial: 5YD6NYKX
          configuration: ansiversion=5
root@ubuntu:~# fdisk /dev/sda

Unable to read /dev/sda

So I suppose the HDD is not supported? It's a Seagate Barracuda Green 2TB connected via SATA.

Any help would be appreciated..


  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3647
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Installation of 8.10 fails to detect harddrive
« Reply #1 on: January 07, 2012, 04:25:14 pm »
If Kubuntu 810 does not see the drive, it is very well possible, that there are some incompatibilities between your hardware and Kubuntu 810. I would try two things:

1) try a smaller HDD

2) try disabling some stuff in the BIOS, like AHCI.

Good luck.


  • Guru
  • ****
  • Posts: 463
    • View Profile
    • LMCE user Page
Re: Installation of 8.10 fails to detect harddrive
« Reply #2 on: January 20, 2012, 08:24:11 am »
Hey proesterchen, can't believe I didn't see this post.

Have had exactly the same issues with a 2TB Seagate SATA drive!

Have you made any progress?

Here's what I found:

If I set the "Sata Mode" in BIOS to "IDE" (presumably IDE compatability), Kubuntu install didn't go anywhere- after the swiping bar splash screen it went to a black screen and then dumped to initramfs prompt.

If I set the "Sata Mode" to "AHCI" Kubuntu install would get to hard disk partitioning and not see anything.

If I booted the live and ran lshw I'd get similar output to yours above. Significantly no disk size shown and fdisk would also not see the drive.

I'd still like to find a work around but no luck so far.

I tried 10.04 and it sees and partitions no problem so it does seem related to the 8.10 or possibly the older kernel.