Author Topic: Lirc client  (Read 1641 times)

k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Lirc client
« on: March 19, 2007, 12:33:44 am »
Hi,

I got a USBUIRT device hooked up to another server, i connect to this device via LIRC client's and it all works perfect,
Can LinuxMCE use this USBUIRT device, like all other programs which support lirc can?

normally i just start lirc with -c and specify ip and port to the server.

Thanks.

webpaul1

  • Veteran
  • ***
  • Posts: 140
    • View Profile
Re: Lirc client
« Reply #1 on: March 25, 2007, 05:01:13 am »
usb uirt is fully plug and play.  lirc isn't required.  just plug it in, use a windows mc remote, and it works.  Also, it has i/r learning and transmit as well

k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: Lirc client
« Reply #2 on: March 30, 2007, 02:58:40 pm »
Hi

My USBUIRT 0056 does not seem to be noticed under linuxMCE,
even tried to use it with lirc drivers from the pluto admin page, but that does not work either.

It\s working flawlessly in lirc on my other computer.
(Send,recieve,learn 0.7.1patched or 0.8.x)

I can only select USBUIRT 0038 on the pltuo admin page, guess the difference is that i got the one with extra transmitter.

Any id\s to change or something?

Thanks in advance.q

webpaul1

  • Veteran
  • ***
  • Posts: 140
    • View Profile
Re: Lirc client
« Reply #3 on: April 03, 2007, 06:56:07 am »
When you plug it in, run TailDCERouter.sh in a console.  You should see "Device Detected" events, and a blue popup on the screen.  It should be added to teh table PnpQueue in pluto_main, and in there will be a reference to the device it added.  If none of this happens, what's in your HAL log (/var/log/pluto/*HAL*) since that device is responsible for firing the events when usb is inserted/removed?  What does lsusb show?

k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: Lirc client
« Reply #4 on: April 20, 2007, 12:22:09 pm »
Got it working,

1) I added child device, under "generic pc as md"
2) I checked dmesg to get what port was assigned to my usbuirt (ttyUSB0)
3) I edited the configuration of my new USBUIRT 0038 device, in the dropdown box i could select a PCI card and /dev/ttyS0
    -i did a nasty fix to this one, i selected ttyS0, then i removed & linked /dev/ttyS0 to /dev/ttyUSB0

I'm sure this can be done somewhere in the mysql table, e.g put in /dev/ttyUSB0, but i didnt find it at first look.
Since ubuntu uses udev, i had to add this symlink to the startup.

Result:
My USBUIRT is working Recieving & Transmitting, finally i can control my reciever volume with my gyration mouse :-)